summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-06-21 05:42:13 +0200
committerMichał Górny <mgorny@gentoo.org>2023-06-21 06:14:45 +0200
commitf20573257f73c0afc1e93ae9a8ec4ea33f81a36c (patch)
treed57cf529ec2010bd28a0be8823d5dae63850789c
parentdev-python/ypy-websocket: Bump to 0.12.1 (diff)
downloadgentoo-f20573257f73c0afc1e93ae9a8ec4ea33f81a36c.tar.gz
gentoo-f20573257f73c0afc1e93ae9a8ec4ea33f81a36c.tar.bz2
gentoo-f20573257f73c0afc1e93ae9a8ec4ea33f81a36c.zip
dev-python/natsort: Bump to 8.4.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/natsort/Manifest1
-rw-r--r--dev-python/natsort/natsort-8.4.0.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/natsort/Manifest b/dev-python/natsort/Manifest
index 02d3026a050c..b8d6ddeea97e 100644
--- a/dev-python/natsort/Manifest
+++ b/dev-python/natsort/Manifest
@@ -1 +1,2 @@
DIST natsort-8.3.1.tar.gz 123736 BLAKE2B 3ad4d8884b463fa792f7930f6d92dda146c96cd929a58a1d418c59f8b3c5fc06329e2cf0341963c820fb8d2fc67b287ce69083a2cba9f20bd8abc06c0fca6a44 SHA512 98ee9bfed9307487b9ae9ced5ce723b6840c6f882d06702f205986430572b767f3ac0930ffdf0663d99256f6feed704394b2b7e11f4b01f4f0241cd8639df622
+DIST natsort-8.4.0.tar.gz 76575 BLAKE2B 924058bd0770866d7945edc7886c5d517bf6c886b85c09f7fb0c3f4e7e7e3678993b62bf905245569e36a4acc6437f80e8671f928837d5708d1fe318c7b83320 SHA512 a005abc0fe7ccbb58d1926698a841d90f7f3eac72f062044a6716f0676e0b0766f3e7e14867fb2a0ff1124deaf9796d096744d68b2f6eea001841abed49345c8
diff --git a/dev-python/natsort/natsort-8.4.0.ebuild b/dev-python/natsort/natsort-8.4.0.ebuild
new file mode 100644
index 000000000000..41ce1f1d5f5e
--- /dev/null
+++ b/dev-python/natsort/natsort-8.4.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 optfeature pypi
+
+DESCRIPTION="Natural sorting for Python"
+HOMEPAGE="
+ https://github.com/SethMMorton/natsort/
+ https://pypi.org/project/natsort/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ optfeature "sorting results that match most file browsers" "dev-python/pyicu"
+}