summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVirgil Dupras <vdupras@gentoo.org>2019-04-02 13:23:34 -0400
committerVirgil Dupras <vdupras@gentoo.org>2019-04-02 13:23:34 -0400
commitf216cea1c7798ed8c7ac126db24a62a37213677c (patch)
treea20f0644c52e5e52843c155a9578591169d2a3c2
parentdev-lang/go: add non-vulnerable version of go 1.11 (diff)
downloadgentoo-f216cea1.tar.gz
gentoo-f216cea1.tar.bz2
gentoo-f216cea1.zip
dev-python/python-sqlparse: add py37 compat and cleanup ebuild
Most of the hoops that were present to build doc and run tests weren't actually necessary. Signed-off-by: Virgil Dupras <vdupras@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11
-rw-r--r--dev-python/python-sqlparse/python-sqlparse-0.3.0.ebuild22
1 files changed, 3 insertions, 19 deletions
diff --git a/dev-python/python-sqlparse/python-sqlparse-0.3.0.ebuild b/dev-python/python-sqlparse/python-sqlparse-0.3.0.ebuild
index 8d9e4eac466c..eca64775215c 100644
--- a/dev-python/python-sqlparse/python-sqlparse-0.3.0.ebuild
+++ b/dev-python/python-sqlparse/python-sqlparse-0.3.0.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy )
inherit distutils-r1
@@ -19,35 +19,19 @@ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~a
LICENSE="BSD-2"
IUSE="doc test"
-REQUIRED_USE="doc? ( || ( $(python_gen_useflags 'python2*') ) )"
-
DEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? (
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/pytest-cov[${PYTHON_USEDEP}]
- )"
-# Required for running tests
-DISTUTILS_IN_SOURCE_BUILD=1
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
S="${WORKDIR}"/${P#python-}
-pkg_setup() {
- use doc && DISTUTILS_ALL_SUBPHASE_IMPLS=( 'python2*' )
-}
-
python_compile_all() {
use doc && emake -C docs html
}
python_test() {
- if python_is_python3; then
- 2to3 -w --no-diffs -n tests/ sqlparse/
- py.test ./tests || die "testsuite failed ${EPYTHON}"
- else
- py.test tests || die "testsuite failed under ${EPYTHON}"
- fi
+ pytest tests || die "testsuite failed under ${EPYTHON}"
}
python_install_all() {