summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2021-01-05 20:55:34 +0100
committerAlexis Ballier <aballier@gentoo.org>2021-01-05 21:03:03 +0100
commitf22ad97e0307dbbf280482875c9455d110f94016 (patch)
treed207f3099064168037a09969e17f1e93d9cdcf17
parentdev-ros/image_rotate: Bump to 1.15.3. (diff)
downloadgentoo-f22ad97e0307dbbf280482875c9455d110f94016.tar.gz
gentoo-f22ad97e0307dbbf280482875c9455d110f94016.tar.bz2
gentoo-f22ad97e0307dbbf280482875c9455d110f94016.zip
dev-ros/image_view: Bump to 1.15.3.
Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
-rw-r--r--dev-ros/image_view/Manifest1
-rw-r--r--dev-ros/image_view/image_view-1.15.3.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-ros/image_view/Manifest b/dev-ros/image_view/Manifest
index f95181cdfa0a..4008f263090f 100644
--- a/dev-ros/image_view/Manifest
+++ b/dev-ros/image_view/Manifest
@@ -1 +1,2 @@
DIST image_pipeline-1.15.2.tar.gz 147570 BLAKE2B 7e6ecad344e38426148017c4bdd109cdb505201256b811d7479b2fa5f2b6a94f94708ffd0e2a3c273f09fb8db0afdedb6955320bc142e4b48fbf94eeef45b453 SHA512 8fe9fa7759d83b2585589c6667c82b154c6ab748aa1644e8a58c75550e4c581fdea1b42f91a8c64df4eb7a06b33a76e55325268f314f3ec1f06ee38ee7b06bfc
+DIST image_pipeline-1.15.3.tar.gz 150900 BLAKE2B 75bce8146c5273d5896ccb226bb9223f696f341089948aa44bbc932af15a1c80e6a5dbc036b4a37dcaecfca6a3e896df0935dcfb8305e23cc1a73fa77cef7a2e SHA512 9e1d21d1a43e932078938aeca4e5e6902e36e6d034a467cbd69734e318e5c4a689cb133acc7f8098f4ca928312661eb5b2aa7fae38e3d2a904b0e34889da0d32
diff --git a/dev-ros/image_view/image_view-1.15.3.ebuild b/dev-ros/image_view/image_view-1.15.3.ebuild
new file mode 100644
index 000000000000..dd6d0aaf5cd4
--- /dev/null
+++ b/dev-ros/image_view/image_view-1.15.3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+ROS_REPO_URI="https://github.com/ros-perception/image_pipeline"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Simple viewer for ROS image topics"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/camera_calibration_parsers
+ >=dev-ros/cv_bridge-1.11.10
+ dev-ros/image_transport
+ dev-ros/message_filters
+ dev-ros/nodelet
+ dev-ros/rosconsole
+ dev-libs/console_bridge:=
+ dev-ros/roscpp
+ dev-ros/dynamic_reconfigure[${PYTHON_SINGLE_USEDEP}]
+
+ dev-libs/boost:=[threads]
+ media-libs/opencv:=
+ x11-libs/gtk+:3
+ media-libs/harfbuzz:=
+"
+DEPEND="${RDEPEND}
+ dev-ros/stereo_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/std_srvs[${CATKIN_MESSAGES_CXX_USEDEP}]
+"
+BDEPEND="
+ virtual/pkgconfig
+"