summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-02-07 17:59:00 +0100
committerMichał Górny <mgorny@gentoo.org>2020-02-09 17:31:31 +0100
commitf2512a9554b509c74827e1191ba34368d2beaa11 (patch)
tree18e566975426001ae876c6e10e2f95cc39675d0b
parentmedia-video/pymp: Switch to PYTHON_MULTI_USEDEP API (diff)
downloadgentoo-f2512a95.tar.gz
gentoo-f2512a95.tar.bz2
gentoo-f2512a95.zip
media-video/totem: Switch to PYTHON_MULTI_USEDEP API
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--media-video/totem/totem-3.32.1-r2.ebuild (renamed from media-video/totem/totem-3.32.1-r1.ebuild)12
1 files changed, 9 insertions, 3 deletions
diff --git a/media-video/totem/totem-3.32.1-r1.ebuild b/media-video/totem/totem-3.32.1-r2.ebuild
index 0a1b3d38e9a1..dc7f5d912604 100644
--- a/media-video/totem/totem-3.32.1-r1.ebuild
+++ b/media-video/totem/totem-3.32.1-r2.ebuild
@@ -45,7 +45,10 @@ DEPEND="
lirc? ( app-misc/lirc )
python? (
${PYTHON_DEPS}
- >=dev-python/pygobject-2.90.3:3[${PYTHON_USEDEP}] )
+ $(python_gen_cond_dep '
+ >=dev-python/pygobject-2.90.3:3[${PYTHON_MULTI_USEDEP}]
+ ')
+ )
"
RDEPEND="${DEPEND}
media-plugins/grilo-plugins:0.3
@@ -53,8 +56,11 @@ RDEPEND="${DEPEND}
media-plugins/gst-plugins-taglib:1.0
x11-themes/adwaita-icon-theme
python? (
- >=dev-libs/libpeas-1.1.0[python,${PYTHON_USEDEP}]
- dev-python/dbus-python[${PYTHON_USEDEP}] )
+ >=dev-libs/libpeas-1.1.0[python,${PYTHON_SINGLE_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/dbus-python[${PYTHON_MULTI_USEDEP}]
+ ')
+ )
"
BDEPEND="
dev-lang/perl