summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-26 09:22:45 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-26 09:34:43 +0100
commitf2716c30cd31d25eadc307b13933459a8f8ec817 (patch)
treee2f78ae0c100723d75206b5e50239b3e3e452e8f
parentdev-python/pygal: Migrate to PEP517 build (diff)
downloadgentoo-f2716c30.tar.gz
gentoo-f2716c30.tar.bz2
gentoo-f2716c30.zip
dev-python/random2: EAPI 8, PEP517
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/random2/random2-1.0.1-r2.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/random2/random2-1.0.1-r2.ebuild b/dev-python/random2/random2-1.0.1-r2.ebuild
new file mode 100644
index 000000000000..2a366d4c7b1b
--- /dev/null
+++ b/dev-python/random2/random2-1.0.1-r2.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python-2.7 random module ported to python-3"
+HOMEPAGE="https://pypi.org/project/random2/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+
+BDEPEND="app-arch/unzip"
+
+distutils_enable_tests setup.py
+
+PATCHES=( "${FILESDIR}/${P}-py39-tests.patch" )