summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-12-30 20:51:43 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-12-30 21:07:26 +0100
commitf28b737d3d3c4afd68df7dfd7a55dc6b2d7c3f3a (patch)
tree2cb2bd716a3635fc3d6c16f156f25fa6811c953a
parentapp-text/libwpd: 0.10.3 version bump (diff)
downloadgentoo-f28b737d.tar.gz
gentoo-f28b737d.tar.bz2
gentoo-f28b737d.zip
media-libs/libcdr: 0.1.5 version bump
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--media-libs/libcdr/Manifest1
-rw-r--r--media-libs/libcdr/libcdr-0.1.5.ebuild60
-rw-r--r--media-libs/libcdr/libcdr-9999.ebuild27
3 files changed, 77 insertions, 11 deletions
diff --git a/media-libs/libcdr/Manifest b/media-libs/libcdr/Manifest
index 96c205c9a7e6..5229407d9c88 100644
--- a/media-libs/libcdr/Manifest
+++ b/media-libs/libcdr/Manifest
@@ -1 +1,2 @@
DIST libcdr-0.1.4.tar.xz 609592 BLAKE2B 201ed19cfe9aa93137279dfa6b9c3908691b2bddd1e8b7fb25505ab475cb8ae533d1b27857c99e36f618938aa7ee88075c3c7f5780872abe68994f380dc893c8 SHA512 769b0319b5a904ce9f727b7076f82cd915ecd8c9e5e2456416e3e6739c6403bbd4108787ab124d36efb1b47d5c9e37c48b0e12d096eb440ae8f9979ec06048a6
+DIST libcdr-0.1.5.tar.xz 612252 BLAKE2B d23c7ae0d0f5cbdb535bfba4dff4ad40e8b0633115cbc8c5b3a40343d941eaeafbffafe99ba2107640eafdd8181ab6eed7917095d05644a43f2b11cfcc66f8f1 SHA512 e985389b0cbad65dbfa9f59d7f9dba55f1684f63e852f9acca9abb863cdaab17072e761b48dca690673360d643686b5e9bc9878530f0a3a8b5b98d917f892cf0
diff --git a/media-libs/libcdr/libcdr-0.1.5.ebuild b/media-libs/libcdr/libcdr-0.1.5.ebuild
new file mode 100644
index 000000000000..091f92e616d7
--- /dev/null
+++ b/media-libs/libcdr/libcdr-0.1.5.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic
+
+if [[ ${PV} = 9999 ]]; then
+ EGIT_REPO_URI="https://anongit.freedesktop.org/git/libreoffice/libcdr.git"
+ inherit autotools git-r3
+else
+ SRC_URI="https://dev-www.libreoffice.org/src/libcdr/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+fi
+
+DESCRIPTION="Library parsing the Corel cdr documents"
+HOMEPAGE="https://wiki.documentfoundation.org/DLP/Libraries/libcdr"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+IUSE="doc static-libs test"
+
+RDEPEND="
+ dev-libs/icu:=
+ dev-libs/librevenge
+ media-libs/lcms:2
+ sys-libs/zlib
+"
+DEPEND="${RDEPEND}
+ dev-libs/boost
+"
+BDEPEND="
+ sys-devel/libtool
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+ test? ( dev-util/cppunit )
+"
+
+src_prepare() {
+ default
+ [[ -d m4 ]] || mkdir "m4"
+ [[ ${PV} == 9999 ]] && eautoreconf
+}
+
+src_configure() {
+ # bug 619448
+ append-cxxflags -std=c++14
+
+ local myeconfargs=(
+ $(use_with doc docs)
+ $(use_enable static-libs static)
+ $(use_enable test tests)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
diff --git a/media-libs/libcdr/libcdr-9999.ebuild b/media-libs/libcdr/libcdr-9999.ebuild
index 3c04d584f9e0..091f92e616d7 100644
--- a/media-libs/libcdr/libcdr-9999.ebuild
+++ b/media-libs/libcdr/libcdr-9999.ebuild
@@ -1,21 +1,23 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit flag-o-matic
-EGIT_REPO_URI="https://anongit.freedesktop.org/git/libreoffice/libcdr.git"
-[[ ${PV} == 9999 ]] && inherit autotools git-r3
+if [[ ${PV} = 9999 ]]; then
+ EGIT_REPO_URI="https://anongit.freedesktop.org/git/libreoffice/libcdr.git"
+ inherit autotools git-r3
+else
+ SRC_URI="https://dev-www.libreoffice.org/src/libcdr/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+fi
DESCRIPTION="Library parsing the Corel cdr documents"
HOMEPAGE="https://wiki.documentfoundation.org/DLP/Libraries/libcdr"
-[[ ${PV} == 9999 ]] || SRC_URI="https://dev-www.libreoffice.org/src/libcdr/${P}.tar.xz"
LICENSE="MPL-2.0"
SLOT="0"
-[[ ${PV} == 9999 ]] || \
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86"
IUSE="doc static-libs test"
RDEPEND="
@@ -26,6 +28,8 @@ RDEPEND="
"
DEPEND="${RDEPEND}
dev-libs/boost
+"
+BDEPEND="
sys-devel/libtool
virtual/pkgconfig
doc? ( app-doc/doxygen )
@@ -42,11 +46,12 @@ src_configure() {
# bug 619448
append-cxxflags -std=c++14
- econf \
- --disable-werror \
- $(use_with doc docs) \
- $(use_enable static-libs static) \
+ local myeconfargs=(
+ $(use_with doc docs)
+ $(use_enable static-libs static)
$(use_enable test tests)
+ )
+ econf "${myeconfargs[@]}"
}
src_install() {