summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-04 16:53:08 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-04 19:03:11 +0100
commitf2993b47921a82d93c5c524afbd44164202b3b12 (patch)
tree243bf0a225ecbcc6ced0a447b251a1b81d26f732
parentdev-python/uncertainties: Enable py3.12 (diff)
downloadgentoo-f2993b47921a82d93c5c524afbd44164202b3b12.tar.gz
gentoo-f2993b47921a82d93c5c524afbd44164202b3b12.tar.bz2
gentoo-f2993b47921a82d93c5c524afbd44164202b3b12.zip
dev-python/txtorcon: Enable py3.12
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/txtorcon/txtorcon-23.5.0.ebuild19
1 files changed, 14 insertions, 5 deletions
diff --git a/dev-python/txtorcon/txtorcon-23.5.0.ebuild b/dev-python/txtorcon/txtorcon-23.5.0.ebuild
index a1f17ef91891..0046315727fb 100644
--- a/dev-python/txtorcon/txtorcon-23.5.0.ebuild
+++ b/dev-python/txtorcon/txtorcon-23.5.0.ebuild
@@ -3,14 +3,21 @@
EAPI=8
-PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_COMPAT=( python3_{10..12} )
DISTUTILS_USE_PEP517=setuptools
inherit distutils-r1
DESCRIPTION="Twisted-based Tor controller client, with state-tracking abstractions"
-HOMEPAGE="https://txtorcon.readthedocs.org https://pypi.org/project/txtorcon/"
-SRC_URI="https://github.com/meejah/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+HOMEPAGE="
+ https://txtorcon.readthedocs.org/
+ https://github.com/meejah/txtorcon/
+ https://pypi.org/project/txtorcon/
+"
+SRC_URI="
+ https://github.com/meejah/txtorcon/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
LICENSE="MIT"
SLOT="0"
@@ -22,12 +29,14 @@ RDEPEND="
dev-python/incremental[${PYTHON_USEDEP}]
dev-python/six[${PYTHON_USEDEP}]
dev-python/twisted[ssl,${PYTHON_USEDEP}]
- dev-python/zope-interface[${PYTHON_USEDEP}]"
+ dev-python/zope-interface[${PYTHON_USEDEP}]
+"
BDEPEND="
test? (
sys-process/lsof
dev-python/mock[${PYTHON_USEDEP}]
- )"
+ )
+"
distutils_enable_tests pytest