summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2023-08-26 09:18:14 +0200
committerHans de Graaff <graaff@gentoo.org>2023-08-26 09:18:14 +0200
commitf29bcd3c96c21a7e3cf57da01f801fd224a3067f (patch)
treee87724a49e00cbb524bd204e161b6f867536efea
parentdev-ruby/octokit: add 7.1.0 (diff)
downloadgentoo-f29bcd3c96c21a7e3cf57da01f801fd224a3067f.tar.gz
gentoo-f29bcd3c96c21a7e3cf57da01f801fd224a3067f.tar.bz2
gentoo-f29bcd3c96c21a7e3cf57da01f801fd224a3067f.zip
dev-ruby/pg: add 1.5.3
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
-rw-r--r--dev-ruby/pg/Manifest1
-rw-r--r--dev-ruby/pg/pg-1.5.3.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/dev-ruby/pg/Manifest b/dev-ruby/pg/Manifest
index 08c2c2792b82..2f56d026ceef 100644
--- a/dev-ruby/pg/Manifest
+++ b/dev-ruby/pg/Manifest
@@ -1,2 +1,3 @@
DIST pg-1.4.1.tar.gz 258388 BLAKE2B d2f2c81b51fb159a95990382cce316938b97d8ecb1c9590c4a70be741f4806bc47dc99423c1d54e939bc156e287cc7cba28d854dc68900501c10fbaf15cb3076 SHA512 e8e0ad7b6df4a98d8ac6dfa8006044f7fbfc45713e1aa866e80a83061be5a6a1a57456cc2ffc14d976c2d108ce526c6fa9d4ce59222a9d9bb3ef676e9dec8da9
DIST pg-1.4.6.tar.gz 282608 BLAKE2B 73616b6ba0373ae81394188fd96d7ca37144b76e5e89d0267e076ea39b9e33d19851d3881e70d9d5934ea26671c07635a22e7e530dd0094a243de8e9d9793fb5 SHA512 5cde5441f9864f89e7f44fd72d8becc60c223ba90793812c4756764f9807610d393ecca5ba05187e8aefb0d3530d67a7525b4e2c638160161410b369937e912a
+DIST pg-1.5.3.tar.gz 296167 BLAKE2B d1f3d0cfecd2cf006dae3373e378b7784d07d08710595b62c5b2f3e887b8e10f0fc06fb0fbb1cccb995a04c51ced781362ecfe7bc95a311c0609ffc62ed54a7e SHA512 d15f5ddcf83cf70df23cb1e127442ff94850aa47fa78f8fdf34aa88ae43039dca6395413e714b60bee9f825d1016e98fcf446b704bd9bebfc71c0a5a9109a73a
diff --git a/dev-ruby/pg/pg-1.5.3.ebuild b/dev-ruby/pg/pg-1.5.3.ebuild
new file mode 100644
index 000000000000..0d0fcd602ed2
--- /dev/null
+++ b/dev-ruby/pg/pg-1.5.3.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32"
+
+RUBY_FAKEGEM_GEMSPEC="pg.gemspec"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRADOC="Contributors.rdoc README.md History.md"
+
+RUBY_FAKEGEM_EXTENSIONS=(ext/extconf.rb)
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ruby extension library providing an API to PostgreSQL"
+HOMEPAGE="https://github.com/ged/ruby-pg"
+SRC_URI="https://github.com/ged/ruby-pg/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+RUBY_S="ruby-${P}"
+
+LICENSE="|| ( BSD-2 Ruby-BSD )"
+SLOT="1"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE=""
+
+RDEPEND+=" dev-db/postgresql:*"
+DEPEND+=" dev-db/postgresql
+ test? ( >=dev-db/postgresql-9.4[server(+),threads] )"
+
+all_ruby_prepare() {
+ # hack the Rakefile to make it sure that it doesn't load
+ # rake-compiler (so that we don't have to depend on it and it
+ # actually works when building with USE=doc).
+ sed -i \
+ -e '/Rakefile.cross/s:^:#:' \
+ -e '/ExtensionTask/,/^end$/ s:^:#:' \
+ Rakefile || die
+
+ sed -e 's/git ls-files -z/find * -print0/' \
+ -e "s:_relative ': './:" \
+ -e 's/__dir__/"."/' \
+ -i ${RUBY_FAKEGEM_GEMSPEC} || die
+
+ # Avoid tests that assume IPv4
+ sed -i -e '/expect.*hostaddr/ s:^:#:' spec/pg/connection_spec.rb || die
+
+ # Fails with network-sandbox
+ sed -i -e '/connects using without host but envirinment variables/askip "gentoo"' spec/pg/scheduler_spec.rb || die
+
+ # Avoid test that only works with bundled pg
+ sed -i -e '/tells about the libpq library path/askip "gentoo"' spec/pg_spec.rb || die
+}
+
+each_ruby_test() {
+ if [[ "${EUID}" -ne "0" ]]; then
+ # Make the rspec call explicit, this way we don't have to depend
+ # on rake-compiler (nor rubygems) _and_ we don't have to rebuild
+ # the whole extension from scratch.
+ RSPEC_VERSION=3 ruby-ng_rspec
+ else
+ ewarn "The userpriv feature must be enabled to run tests."
+ eerror "Testsuite will not be run."
+ fi
+}