summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-06-02 13:19:23 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2020-06-02 13:40:29 -0500
commitf29e96504bc6ee75d96e973853529b6ccb6f5641 (patch)
treefa42103fe9eff2a28cda5f97bc52c39636f2fd52
parentdev-python/oslo-upgradecheck: 1.0.1 bump (diff)
downloadgentoo-f29e9650.tar.gz
gentoo-f29e9650.tar.bz2
gentoo-f29e9650.zip
dev-python/oslo-concurrency: 4.0.2 bump
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
-rw-r--r--dev-python/oslo-concurrency/Manifest1
-rw-r--r--dev-python/oslo-concurrency/oslo-concurrency-4.0.2.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/oslo-concurrency/Manifest b/dev-python/oslo-concurrency/Manifest
index a6bb56ffd320..19e1dd9dc944 100644
--- a/dev-python/oslo-concurrency/Manifest
+++ b/dev-python/oslo-concurrency/Manifest
@@ -1 +1,2 @@
DIST oslo.concurrency-3.29.1.tar.gz 51785 BLAKE2B 4035981fcff3cb4384209f3b640b928dfacd13e324c9df1dfebb0c5230727736ff803b478e506b08ac4bd7bd405763b93bdb951b01751a5e293daa33df860c8e SHA512 f820b07dbb26be9170c7ded08ce96bebc8c8cbfa72a3be56e0cb0fd7a025160fe630ad256c8c5b1adc9059cd1608c3625513b3da311e5a611866280d2b65424e
+DIST oslo.concurrency-4.0.2.tar.gz 53910 BLAKE2B 090d9ba4b5267f63edf6cbc6f585e48019a4ac293e24914a8f7c52009b34ce9a4822a8705934c642663bd2a09be3085458868159ef041498e2085e4ccbec50f9 SHA512 ca1ef615ebe986acac853666877061bbc7a02c09bec294ec6221ae4800a561cf9f218855f7eb8b96184d645924e5c68963b47116835c7d2495de83617439d1ef
diff --git a/dev-python/oslo-concurrency/oslo-concurrency-4.0.2.ebuild b/dev-python/oslo-concurrency/oslo-concurrency-4.0.2.ebuild
new file mode 100644
index 000000000000..7d4e1b76c591
--- /dev/null
+++ b/dev-python/oslo-concurrency/oslo-concurrency-4.0.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_6 python3_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="library for running multi-thread, multi-process applications"
+HOMEPAGE="https://pypi.org/project/oslo.concurrency/"
+SRC_URI="mirror://pypi/${PN:0:1}/oslo.concurrency/oslo.concurrency-${PV}.tar.gz"
+S="${WORKDIR}/oslo.concurrency-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+RESTRICT=""
+
+CDPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/oslo-config-5.2.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/fasteners-0.7.0[${PYTHON_USEDEP}]
+"