summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Siebeck <gentoo.2019@r123.de>2020-04-20 00:02:26 +0200
committerJoonas Niilola <juippis@gentoo.org>2020-04-22 16:38:38 +0300
commitf2a8302db892759b973a994cdf8544bf431b7370 (patch)
tree6b57484eab53ce78f3de4fcea24ce688b597f3ad
parentdev-lang/python: Replace python_export usage (diff)
downloadgentoo-f2a8302db892759b973a994cdf8544bf431b7370.tar.gz
gentoo-f2a8302db892759b973a994cdf8544bf431b7370.tar.bz2
gentoo-f2a8302db892759b973a994cdf8544bf431b7370.zip
mail-client/alpine: don't call cc directly
Closes: https://bugs.gentoo.org/718368 Signed-off-by: Robert Siebeck <gentoo.2019@r123.de> Closes: https://github.com/gentoo/gentoo/pull/15424 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--mail-client/alpine/alpine-2.22.ebuild6
-rw-r--r--mail-client/alpine/files/alpine-2.22-cc.patch24
2 files changed, 30 insertions, 0 deletions
diff --git a/mail-client/alpine/alpine-2.22.ebuild b/mail-client/alpine/alpine-2.22.ebuild
index 75f6d6673383..c2b83e1187b5 100644
--- a/mail-client/alpine/alpine-2.22.ebuild
+++ b/mail-client/alpine/alpine-2.22.ebuild
@@ -27,9 +27,15 @@ RDEPEND="${DEPEND}
app-misc/mime-types
"
+PATCHES=(
+ "${FILESDIR}/${P}-cc.patch"
+)
+
src_prepare() {
default
eautoreconf
+ tc-export CC RANLIB AR
+ export CC_FOR_BUILD=$(tc-getBUILD_CC)
}
src_configure() {
diff --git a/mail-client/alpine/files/alpine-2.22-cc.patch b/mail-client/alpine/files/alpine-2.22-cc.patch
new file mode 100644
index 000000000000..87132bdd6b51
--- /dev/null
+++ b/mail-client/alpine/files/alpine-2.22-cc.patch
@@ -0,0 +1,24 @@
+--- ./imap/tools/Makefile 2020-04-19 23:45:13.080083548 +0200
++++ ./imap/tools/Makefile 2020-04-19 23:45:24.525083844 +0200
+@@ -21,7 +21,6 @@
+ # Internet: MRC@CAC.Washington.EDU
+
+
+-CC=cc
+ RM=rm -f
+
+
+--- ./imap/src/osdep/unix/Makefile 2020-04-19 23:54:55.454098598 +0200
++++ ./imap/src/osdep/unix/Makefile 2020-04-19 23:54:55.454098598 +0200
+@@ -132,10 +132,8 @@
+
+ # Commands possibly overridden by the individual port
+
+-ARRC=ar rc
+-CC=cc
++ARRC=$(AR) rc
+ LN=ln -s
+-RANLIB=ranlib
+
+
+ # Standard distribution build parameters