summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Torokhov <torokhov-s-a@yandex.ru>2020-04-21 04:17:42 +0300
committerMatthias Maier <tamiko@gentoo.org>2020-05-05 11:49:57 -0500
commitf2ace74dcbe808f7c6a6abd29d625f415602a633 (patch)
tree8fe22a356ecb8f4b8b9f7e83dd945e9234f0abb6
parentsci-libs/cantera: Revision bump. Pass FFLAGS for FORTRANFLAGS (diff)
downloadgentoo-f2ace74d.tar.gz
gentoo-f2ace74d.tar.bz2
gentoo-f2ace74d.zip
sci-libs/cantera: Fix site-packages install paths
Python 3.7 and 3.8 site-packages dirs are located under /lib for amd64 arch now (instead of /lib64 like for python2.7 and python3.6) so the changes for python installation patch is required. Signed-off-by: Sergey Torokhov <torokhov-s-a@yandex.ru> Signed-off-by: Matthias Maier <tamiko@gentoo.org>
-rw-r--r--sci-libs/cantera/cantera-2.4.0-r5.ebuild6
-rw-r--r--sci-libs/cantera/files/cantera_2.4.0_env_python_install_prefix.patch17
2 files changed, 20 insertions, 3 deletions
diff --git a/sci-libs/cantera/cantera-2.4.0-r5.ebuild b/sci-libs/cantera/cantera-2.4.0-r5.ebuild
index 78f23ee905bb..e4d8b7de2c0b 100644
--- a/sci-libs/cantera/cantera-2.4.0-r5.ebuild
+++ b/sci-libs/cantera/cantera-2.4.0-r5.ebuild
@@ -52,9 +52,9 @@ DEPEND="
PATCHES=(
"${FILESDIR}/${PN}_${PV}_env.patch"
- "${FILESDIR}/${PN}_${PV}_env_python_install.patch"
+ "${FILESDIR}/${PN}_${PV}_env_python_install_prefix.patch"
"${FILESDIR}/${PN}_${PV}_sundials4.patch"
- )
+)
pkg_setup() {
fortran-2_pkg_setup
@@ -107,7 +107,7 @@ src_test() {
}
src_install() {
- escons install stage_dir="${D}" libdirname="$(get_libdir)"
+ escons install stage_dir="${D}" libdirname="$(get_libdir)" python3_prefix="$(python_get_sitedir)"
if ! use cti ; then
rm -r "${D}/usr/share/man" || die "Can't remove man files."
else
diff --git a/sci-libs/cantera/files/cantera_2.4.0_env_python_install_prefix.patch b/sci-libs/cantera/files/cantera_2.4.0_env_python_install_prefix.patch
new file mode 100644
index 000000000000..838907996361
--- /dev/null
+++ b/sci-libs/cantera/files/cantera_2.4.0_env_python_install_prefix.patch
@@ -0,0 +1,17 @@
+diff -Nur old/interfaces/cython/SConscript new/interfaces/cython/SConscript
+--- old/interfaces/cython/SConscript 2018-08-24 16:24:45.000000000 +0300
++++ new/interfaces/cython/SConscript 2019-08-14 04:28:41.000000000 +0300
+@@ -83,10 +83,10 @@
+ extra = ''
+ elif localenv['OS'] == 'Darwin':
+ extra = localenv.subst(' --prefix=${python%s_prefix}' % major)
+- elif localenv['libdirname'] == 'lib64':
+- # 64-bit RHEL / Fedora
++ elif localenv['libdirname'] != 'lib':
++ # 64-bit RHEL / Fedora etc. or e.g. x32 Gentoo profile
+ extra = localenv.subst(
+- ' --prefix=${python%s_prefix} --install-lib=${python%s_prefix}/lib64/python%s.%s/site-packages' % (major, major, major, minor))
++ ' --prefix=${stage_dir}${prefix} --install-lib=${python%s_prefix}' % (major))
+ else:
+ extra = '--user'
+ localenv.AppendENVPath(