summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2023-07-11 16:01:22 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2023-07-11 16:01:40 -0500
commitf2d7cb8c5f0a787259227e2829437b3c4f4cdc3f (patch)
tree522cdef7bc81fde4f7c0fbe80ad1bd11cf85a410
parentapp-crypt/certbot: drop 2.5.0 (diff)
downloadgentoo-f2d7cb8c.tar.gz
gentoo-f2d7cb8c.tar.bz2
gentoo-f2d7cb8c.zip
app-crypt/acme: drop 2.5.0-r1
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
-rw-r--r--app-crypt/acme/Manifest1
-rw-r--r--app-crypt/acme/acme-2.5.0-r1.ebuild60
2 files changed, 0 insertions, 61 deletions
diff --git a/app-crypt/acme/Manifest b/app-crypt/acme/Manifest
index a06a8ca31a44..6bc3eac1503d 100644
--- a/app-crypt/acme/Manifest
+++ b/app-crypt/acme/Manifest
@@ -1,2 +1 @@
-DIST certbot-2.5.0.gh.tar.gz 1333903 BLAKE2B 2d30764616d2253fe320ad94182e64cc3e1ce75bd90322fcf7c303a52e32420a57cf84a3acf3f8f4825e058d6fe1e59438b728dacdf9032c4d8797312903825e SHA512 92313e352409d543f260fedee3f376c4750d9428cd39fde3518b162091667173ba6d582b4e91477f7122cf198f24119ecf34b2dce12734afbfc0ebedc395a49e
DIST certbot-2.6.0.gh.tar.gz 1336339 BLAKE2B 0c0575ad553ebe0f3ab56da750572bca46b30d034033e43c30c3793c114050ad824a277eab0be5a47326ea099e58e9a421448b53fc1b9173afae9a0ec308ac62 SHA512 d694156886484511f5a38fb5e40f98b2e2dbe4bc5110c95b2084ec03b39cb0eb9bbc623c7bca4a81054e980c8dbac752949042391813298a27be7e70410882e3
diff --git a/app-crypt/acme/acme-2.5.0-r1.ebuild b/app-crypt/acme/acme-2.5.0-r1.ebuild
deleted file mode 100644
index 3d1ceaa2e15f..000000000000
--- a/app-crypt/acme/acme-2.5.0-r1.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{9..11} )
-DISTUTILS_USE_PEP517=setuptools
-
-inherit distutils-r1
-
-PARENT_PN="certbot"
-PARENT_P="${PARENT_PN}-${PV}"
-
-if [[ "${PV}" == *9999 ]]; then
- inherit git-r3
-
- EGIT_REPO_URI="https://github.com/certbot/certbot.git"
- EGIT_SUBMODULES=()
- EGIT_CHECKOUT_DIR="${WORKDIR}/${PARENT_P}"
-else
- SRC_URI="
- https://github.com/certbot/certbot/archive/v${PV}.tar.gz
- -> ${PARENT_P}.gh.tar.gz
- "
- KEYWORDS="amd64 arm arm64 ~ppc64 ~riscv x86"
-fi
-
-DESCRIPTION="An implementation of the ACME protocol"
-HOMEPAGE="
- https://github.com/certbot/certbot
- https://letsencrypt.org/
-"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-
-S="${WORKDIR}/${PARENT_P}/${PN}"
-
-BDEPEND="
- test? (
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/pytest-xdist[${PYTHON_USEDEP}]
- dev-python/typing-extensions[${PYTHON_USEDEP}]
- )
-"
-# The requirement is really 17.5.0 but easier to require latest stable >= 23.1.1
-# to avoid broken 23.1.0.
-RDEPEND="
- dev-python/chardet[${PYTHON_USEDEP}]
- >=dev-python/cryptography-2.5.0[${PYTHON_USEDEP}]
- >=dev-python/josepy-1.13.0[${PYTHON_USEDEP}]
- >=dev-python/pyopenssl-23.1.1[${PYTHON_USEDEP}]
- dev-python/pyrfc3339[${PYTHON_USEDEP}]
- >=dev-python/pytz-2019.3[${PYTHON_USEDEP}]
- >=dev-python/requests-2.20.0[${PYTHON_USEDEP}]
- >=dev-python/requests-toolbelt-0.3.0[${PYTHON_USEDEP}]
-"
-
-distutils_enable_sphinx docs dev-python/sphinx-rtd-theme
-distutils_enable_tests pytest