summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-09-26 20:58:40 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2021-09-26 20:59:11 +0300
commitf2db65536a30a58238646f33d0e6fba208d0123f (patch)
treeff6035c6b5793c918bbf7185e359d87885e7a4e0
parentsys-apps/pkgcore: Stabilize 0.12.7 arm, #814536 (diff)
downloadgentoo-f2db65536a30a58238646f33d0e6fba208d0123f.tar.gz
gentoo-f2db65536a30a58238646f33d0e6fba208d0123f.tar.bz2
gentoo-f2db65536a30a58238646f33d0e6fba208d0123f.zip
dev-python/python-slugify: add 5.0.2
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/python-slugify/Manifest1
-rw-r--r--dev-python/python-slugify/python-slugify-5.0.2.ebuild21
2 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/python-slugify/Manifest b/dev-python/python-slugify/Manifest
index b6d307713919..5a4053f5cd47 100644
--- a/dev-python/python-slugify/Manifest
+++ b/dev-python/python-slugify/Manifest
@@ -1,3 +1,4 @@
DIST python-slugify-4.0.1.tar.gz 11509 BLAKE2B b505c62c959dae3823db4441b8811ed98ec8afa0278325cb2715abb63a84b5de1506362699bc39216bbac4100ae265671f940dbbbdaf9164fd251bdaa7af462a SHA512 c1d99a9dc891c4cfa927e4d2bc5701f47b23b7882cce22350283a53c6ded18e1290196c3bb9838883c29c9cb3582e5e684edffd50dfbb4e9da9c2b821ea54bb5
DIST python-slugify-5.0.0.tar.gz 11730 BLAKE2B 0ec93c230523bcd4ba5f917bc9d2676ae92fc164eccc84198777a59c36ff427fdb7a242bd89f9bc3d24e86b5a1d106f0118cf118349de648f5779c384445abab SHA512 b29c542ec3cb3d05d88be0fb53909b160022fe97dbc89efc0eef5f4e2414031026f570dd6eec1e7bbe2930d801c2fd8d152e49cd2639cddb23392c9b11e7266b
DIST python-slugify-5.0.1.tar.gz 11706 BLAKE2B 1fdffd6fb9eaec13a1ece65433c53dbcb35c5ccbe2ebfb07055acac4d9a7be1e0832535aa6f335ae7eda5b07b823a3b4d63ef1f95f220b5fbf26c28dfbe62ac2 SHA512 6c52d6242fb6b2379e28b074987b474111527ac336dfa673828e5283347cfc52e056d9485251cde90493ea2389210701f566ce01916ae250d76549aafbea75a8
+DIST python-slugify-5.0.2.tar.gz 11728 BLAKE2B 701fb3f679cd4f714b5c57c14fb8cbfefa5b8268e9c4b877dd1e558e8a7dac325d69519b8e666043b70540908dcb250f561cebf0c5f444f9a3cfae34d97456b1 SHA512 79cdd1d0312c9e34b07dca2e898f177a85b31d3f290403375032ae962df61f3a9c4167f4bdf10f47afd17d544731d6961810f8a081ef615d76d8758c1207e6b7
diff --git a/dev-python/python-slugify/python-slugify-5.0.2.ebuild b/dev-python/python-slugify/python-slugify-5.0.2.ebuild
new file mode 100644
index 000000000000..79448555636a
--- /dev/null
+++ b/dev-python/python-slugify/python-slugify-5.0.2.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A Python Slugify application that handles Unicode"
+HOMEPAGE="https://github.com/un33k/python-slugify https://pypi.org/project/python-slugify/"
+SRC_URI="https://github.com/un33k/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+RDEPEND="dev-python/text-unidecode[${PYTHON_USEDEP}]"
+
+distutils_enable_tests unittest