summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-26 11:23:31 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-26 11:26:39 +0100
commitf2fe81febc41a01b2d76702e9f1b5af0ec220899 (patch)
tree1530e7207ce264d67649ec4c57e73aadc0c83f9c
parentdev-python/aiohttp-cors: EAPI 8, PEP517 (diff)
downloadgentoo-f2fe81fe.tar.gz
gentoo-f2fe81fe.tar.bz2
gentoo-f2fe81fe.zip
dev-python/pywinrm: EAPI 8, PEP517
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pywinrm/pywinrm-0.4.2-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/pywinrm/pywinrm-0.4.2-r1.ebuild b/dev-python/pywinrm/pywinrm-0.4.2-r1.ebuild
new file mode 100644
index 000000000000..2eaa56b25615
--- /dev/null
+++ b/dev-python/pywinrm/pywinrm-0.4.2-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python client for the Windows Remote Management (WinRM) service"
+HOMEPAGE="https://github.com/diyan/pywinrm/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="kerberos"
+
+RDEPEND="
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/requests-ntlm[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/xmltodict[${PYTHON_USEDEP}]
+ kerberos? (
+ <dev-python/pykerberos-2.0.0[${PYTHON_USEDEP}]
+ dev-python/requests-credssp[${PYTHON_USEDEP}]
+ )
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest