summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2022-10-17 19:52:09 +0700
committerAndrey Grozin <grozin@gentoo.org>2022-10-17 19:52:53 +0700
commitf3165aed6e8a5e905c8c2415598c655179398e7d (patch)
tree4864c9196b02e7b93d4be4fb8d0199a65202b017
parentwww-apps/prowlarr: drop versions (diff)
downloadgentoo-f3165aed6e8a5e905c8c2415598c655179398e7d.tar.gz
gentoo-f3165aed6e8a5e905c8c2415598c655179398e7d.tar.bz2
gentoo-f3165aed6e8a5e905c8c2415598c655179398e7d.zip
app-text/pdfarranger: DEPEND on intltool
Closes: https://bugs.gentoo.org/877397 Signed-off-by: Andrey Grozin <grozin@gentoo.org>
-rw-r--r--app-text/pdfarranger/pdfarranger-1.9.1-r1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/app-text/pdfarranger/pdfarranger-1.9.1-r1.ebuild b/app-text/pdfarranger/pdfarranger-1.9.1-r1.ebuild
new file mode 100644
index 000000000000..135c68fd3242
--- /dev/null
+++ b/app-text/pdfarranger/pdfarranger-1.9.1-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{7..10} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1 optfeature xdg desktop
+
+DESCRIPTION="Merge or split pdfs; rearrange, rotate, crop pages"
+HOMEPAGE="https://github.com/jeromerobert/pdfarranger"
+SRC_URI="https://github.com/jeromerobert/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="
+ app-text/poppler[introspection,cairo]
+ >=dev-python/pikepdf-6.0.0[${PYTHON_USEDEP}]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP},cairo]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ x11-libs/gtk+:3[introspection]
+ x11-libs/pango[introspection]
+"
+DEPEND="${RDEPEND}
+ dev-python/python-distutils-extra[${PYTHON_USEDEP}]
+ dev-util/intltool
+"
+
+src_install() {
+ distutils-r1_src_install
+ for x in 16 32 48 256 scalable
+ do doicon -s ${x} data/icons/hicolor/${x}*/*
+ done
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ optfeature "image file import" media-gfx/img2pdf
+}