summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-05-19 07:20:57 +0200
committerMichał Górny <mgorny@gentoo.org>2024-05-19 08:02:31 +0200
commitf336b7dc58751e5c70dc5ec5bd339253cfff1533 (patch)
tree627e5249f6cdb9d563a69f219784b412385792b7
parentdev-python/pytest-localftpserver: Strip wrong wget rdep (diff)
downloadgentoo-f336b7dc58751e5c70dc5ec5bd339253cfff1533.tar.gz
gentoo-f336b7dc58751e5c70dc5ec5bd339253cfff1533.tar.bz2
gentoo-f336b7dc58751e5c70dc5ec5bd339253cfff1533.zip
dev-python/fakeredis: Bump to 2.23.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/fakeredis/Manifest1
-rw-r--r--dev-python/fakeredis/fakeredis-2.23.2.ebuild89
2 files changed, 90 insertions, 0 deletions
diff --git a/dev-python/fakeredis/Manifest b/dev-python/fakeredis/Manifest
index bd277ead80e3..7e67f79a0354 100644
--- a/dev-python/fakeredis/Manifest
+++ b/dev-python/fakeredis/Manifest
@@ -1,3 +1,4 @@
DIST fakeredis-2.22.0.tar.gz 130074 BLAKE2B 28ccc177c8f2d47515ff91834901b8fdf9559b83b1e7665101b5f17e57d65a3c820af6be21251257f35a7db858c22fac3395cfb550b724e020e96778ad380008 SHA512 a533f26c2a4289b1b4d398ee426f44c93f01a4aac0dc841854bf94674d7e0738fde38ea896280d4e83bf16041dba505db13e3fa3837a912dc872b1d36c05cc6e
DIST fakeredis-2.23.0.tar.gz 133649 BLAKE2B 4dcfb0b52f18101311cd6513fa236ecc6100d12fdfceb9eef12e40ea4fc2a8148dd93e2ad9a68cf5347a3048a95136b7fcbedab2ea5348fa789462b9fee6f920 SHA512 8c3b4ad153232101203811d2891985474fe17a86693217cb58e694ded3c309d101a6bef52e1b544bbc489a0c355792bdbdbed220dca00d0f50afb2fb1c6438ce
DIST fakeredis-2.23.1.tar.gz 132829 BLAKE2B 05bc696f22cd3280728cf96614ac68fa9243242934c2d25e09fc20a569295adea6b75efb890cc172b1a0c75b9d96e9a1b30c9c04a01bfca508609b3a6eaad5c5 SHA512 5b8d256460d5930896ee1d8b3259decfdee12d0699da852cf1d6ce2c00d70cb404840808c5385ebae8d4ba7accd744f7f969bee4fc73320f55fc34558dee1294
+DIST fakeredis-2.23.2.tar.gz 132956 BLAKE2B 48053663d6260d1153b57893795a97b8e72e21cad57907b006bb8be605cce56c474b1a6bb32d455f034da52bcf391d56139ed0c0bdff7f3c367cc0c365ebca40 SHA512 0994f7c7e955a8cc7b1046f62d37841ea592022f21c34cf1f7d3bb335ba88bda5abf08fa002b4b7c9f0b09a6837a38b1b49cec44a3185e16ab4d4711ad4f95d4
diff --git a/dev-python/fakeredis/fakeredis-2.23.2.ebuild b/dev-python/fakeredis/fakeredis-2.23.2.ebuild
new file mode 100644
index 000000000000..5bf1b6f5ea36
--- /dev/null
+++ b/dev-python/fakeredis/fakeredis-2.23.2.ebuild
@@ -0,0 +1,89 @@
+# Copyright 2020-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Fake implementation of redis API for testing purposes"
+HOMEPAGE="
+ https://github.com/cunla/fakeredis-py/
+ https://pypi.org/project/fakeredis/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ dev-python/packaging[${PYTHON_USEDEP}]
+ >=dev-python/redis-4.2[${PYTHON_USEDEP}]
+ <dev-python/sortedcontainers-3[${PYTHON_USEDEP}]
+ >=dev-python/sortedcontainers-2[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+BDEPEND="
+ test? (
+ dev-db/redis
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # also lupa
+ test/test_aioredis2.py::test_failed_script_error
+ # TODO
+ "test/test_fakeredis.py::test_set_get_nx[StrictRedis]"
+ "test/test_fakeredis.py::test_lpop_count[StrictRedis]"
+ "test/test_fakeredis.py::test_rpop_count[StrictRedis]"
+ "test/test_fakeredis.py::test_zadd_minus_zero[StrictRedis]"
+ "test/test_mixins/test_pubsub_commands.py::test_pubsub_channels[StrictRedis]"
+ test/test_mixins/test_set_commands.py::test_smismember_wrong_type
+ # new redis-server?
+ "test/test_mixins/test_pubsub_commands.py::test_pubsub_shardnumsub[StrictRedis]"
+ # json ext
+ test/test_json/test_json.py
+ test/test_json/test_json_arr_commands.py
+ # tdigest ext?
+ 'test/test_mixins/test_server_commands.py::test_command[FakeStrictRedis]'
+ )
+ local EPYTEST_IGNORE=(
+ # these tests fail a lot...
+ test/test_hypothesis.py
+ )
+ local args=(
+ # tests requiring lupa (lua support)
+ -k 'not test_eval and not test_lua and not test_script'
+ )
+ # Note: this package is not xdist-friendly
+ epytest "${args[@]}"
+}
+
+src_test() {
+ local redis_pid="${T}"/redis.pid
+ local redis_port=6379
+
+ einfo "Spawning Redis"
+ einfo "NOTE: Port ${redis_port} must be free"
+ "${EPREFIX}"/usr/sbin/redis-server - <<- EOF || die "Unable to start redis server"
+ daemonize yes
+ pidfile ${redis_pid}
+ port ${redis_port}
+ bind 127.0.0.1
+ EOF
+
+ # Run the tests
+ distutils-r1_src_test
+
+ # Clean up afterwards
+ kill "$(<"${redis_pid}")" || die
+}