summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-01-16 06:48:19 +0100
committerMaciej Barć <xgqt@gentoo.org>2023-01-16 13:20:45 +0100
commitf340486d72d901de4d69a253409938f72bbf6216 (patch)
treebb01cb13817b3fc9d22ba1c2192539c6d9dbf188
parentdev-ml/uucp: bump to 15.0.0 (diff)
downloadgentoo-f340486d.tar.gz
gentoo-f340486d.tar.bz2
gentoo-f340486d.zip
app-emacs/compat: bump to 29.1.1.1
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--app-emacs/compat/Manifest1
-rw-r--r--app-emacs/compat/compat-29.1.1.1.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/app-emacs/compat/Manifest b/app-emacs/compat/Manifest
index b933cb81646d..603b6654f493 100644
--- a/app-emacs/compat/Manifest
+++ b/app-emacs/compat/Manifest
@@ -2,3 +2,4 @@ DIST compat-28.1.1.3.tar.gz 72597 BLAKE2B 82186713370fed7f97eb057cb330d77c1d7582
DIST compat-28.1.2.2.tar.gz 82479 BLAKE2B 154104a3d1cf953f712de357d21736d648289dbdaccb0f9ca5cbd44cb1e41b9b7b4b52394548658b47216f9205f28d2020b015d22b5d0c4df63c79794ddfc56e SHA512 65cafbf4d48815f447e412c4dbd87c5bd3357df5302660a5296582648926f8e3fe96b4b90b53674f18be8affe66af95c8db7e58d7a9dd63d2b57983962e5a53c
DIST compat-29.1.0.1.tar.gz 98171 BLAKE2B 46fd4052b7e3f6deb7789cb50d2d6c19d698531de04a171b3afc9035ed6ff3e204ee58e770eb699c05d722141b409e34dc13df1af6e3cda275ff107759a0a957 SHA512 51af7d1f87c838d421f017f2bdcce215e6951bd69181abff64c2c87f6ff1aac1b5f29e0dc91be2f48589e9a6092007a99d987791213801c7e0d89a372dfa4b72
DIST compat-29.1.1.0.tar.gz 94072 BLAKE2B 675f0bbf4411fb0d2c2e8f77bcd62dbe56da1f052bd6e390dade0c8075eaa480bb387280a29ae09396a2f4bf27746ae1065d38dd1b7882b9c8c0ec3a4eb776e5 SHA512 5c7b093314cd8f8d8cbab4f470a64d3f104d0e79d2881f2f2309700c6fe5f58a72a8a65379868edba33c0b6af1d43f1474e2fefc65c033f39981d29fca35259a
+DIST compat-29.1.1.1.tar.gz 96932 BLAKE2B 69941bc24d5146103d82862214064b11bfdd335d1af48bf776024c4f73fa156b1d953bb7dad902bbf31a957dfa498762377136ea062fbc7aa0d716cc42bc0228 SHA512 d31b5544e703252d97ef8145ce9f1dc3265264d1e1b62ca46e0baf200b6fb839d20701dafccedb22661472678ca4fcb74fa613fe7244e6359504fb67699f18cc
diff --git a/app-emacs/compat/compat-29.1.1.1.ebuild b/app-emacs/compat/compat-29.1.1.1.ebuild
new file mode 100644
index 000000000000..459edf66eea1
--- /dev/null
+++ b/app-emacs/compat/compat-29.1.1.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=24.4
+
+inherit elisp
+
+DESCRIPTION="Compatibility libraries for Emacs"
+HOMEPAGE="https://github.com/emacs-compat/compat/
+ https://git.sr.ht/~pkal/compat/"
+SRC_URI="https://github.com/emacs-compat/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+BDEPEND="sys-apps/texinfo"
+
+ELISP_TEXINFO="${PN}.texi"
+
+src_compile() {
+ emake compile ${PN}.info
+}
+
+src_test() {
+ local has_json="$("${EMACS}" ${EMACSFLAGS} --eval "(princ (fboundp 'json-parse-string))")"
+ if [[ "${has_json}" != t ]] ; then
+ local line
+ while read line ; do
+ ewarn "${line}"
+ done <<-EOF
+ Your current Emacs version does not support native JSON parsing,
+ which is required for running tests of ${CATEGORY}/${PN}.
+ Emerge >=app-editors/emacs-27 with USE="json" and use "eselect emacs"
+ to select that version.
+ EOF
+ else
+ emake test
+ fi
+}