summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2020-10-12 20:16:34 +0200
committerThomas Deutschmann <whissi@gentoo.org>2020-10-12 20:16:34 +0200
commitf34067878c9d07f609037b6aeca1182d4916041c (patch)
tree32242a23d920599d9424e36f468365dd1a4136f6
parentwww-client/firefox-bin: bump to v81.0.2 (diff)
downloadgentoo-f3406787.tar.gz
gentoo-f3406787.tar.bz2
gentoo-f3406787.zip
media-libs/dav1d: bump to v0.7.1
Closes: https://bugs.gentoo.org/730630 Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
-rw-r--r--media-libs/dav1d/Manifest1
-rw-r--r--media-libs/dav1d/dav1d-0.7.1.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/media-libs/dav1d/Manifest b/media-libs/dav1d/Manifest
index 3fb1f2ededbd..dd7221f27c9d 100644
--- a/media-libs/dav1d/Manifest
+++ b/media-libs/dav1d/Manifest
@@ -1,2 +1,3 @@
DIST dav1d-0.5.2.tar.bz2 554192 BLAKE2B 29305d0bb20a3de0048d102789fe1fdb1a030596213a1e2f025918ac6bb37c92c8c5f8078320487702ed66b16d4d63234823b5475d84bdea853b92e76be4c70e SHA512 37da9138a1dba68b9e723ba48b23eab567f839308132fc5a28727c131280f2eca3e160b074982f5265c914dcad0e4029af9ce23909b32bb9ec60f235c623e384
DIST dav1d-0.7.0.tar.bz2 613106 BLAKE2B e41dcf4c597da437c0840753eedb3d4c8c7e53494376128f7c0cabf9fe00038fbe676f093f4bce079233934c9f78def0b98b4f09a464c6bd162b7b2fb9f88410 SHA512 2ee1de4c29db6a5cbba0a1db669fb1143f3bae26595c4ea3f17c555fdccbaabc814b7af5caf738cf4dbffd22c690cfe869d33cd830533e24990679b7b9cb4b8b
+DIST dav1d-0.7.1.tar.bz2 644556 BLAKE2B f3539d73b2731be882c71a0e8e90c4382282a650ff9e0aa2bb1142f59a823bbe00011e384c65ae86b8b617054a167b8c90b83d96591ad5c133b7de336c30c753 SHA512 7db0f2eb5f6cbf2809ffb9ebaa18bf1331df00dc6e9d571380b2524143ce3bfdd2e7df1a31e82a52640e7ac81b2712127a395e857d061118845011a1e5fb4751
diff --git a/media-libs/dav1d/dav1d-0.7.1.ebuild b/media-libs/dav1d/dav1d-0.7.1.ebuild
new file mode 100644
index 000000000000..b5737f217f03
--- /dev/null
+++ b/media-libs/dav1d/dav1d-0.7.1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+SCM=""
+if [[ "${PV}" == "9999" ]]; then
+ SCM="git-r3"
+ EGIT_REPO_URI="https://code.videolan.org/videolan/dav1d"
+else
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86"
+ SRC_URI="https://code.videolan.org/videolan/dav1d/-/archive/${PV}/${P}.tar.bz2"
+fi
+
+inherit ${SCM} meson ninja-utils multilib-minimal
+
+DESCRIPTION="dav1d is an AV1 Decoder :)"
+HOMEPAGE="https://code.videolan.org/videolan/dav1d"
+
+LICENSE="BSD-2"
+SLOT="0/4"
+IUSE="+8bit +10bit +asm"
+
+ASM_DEPEND=">=dev-lang/nasm-2.14.02"
+BDEPEND="asm? (
+ abi_x86_32? ( ${ASM_DEPEND} )
+ abi_x86_64? ( ${ASM_DEPEND} )
+ )"
+
+DOCS=( README.md doc/PATENTS THANKS.md )
+
+multilib_src_configure() {
+ local -a bits=()
+ use 8bit && bits+=( 8 )
+ use 10bit && bits+=( 16 )
+
+ local enable_asm
+ if [[ ${MULTILIB_ABI_FLAG} == abi_x86_x32 ]]; then
+ enable_asm=false
+ else
+ enable_asm=$(usex asm true false)
+ fi
+
+ local emesonargs=(
+ -D bitdepths=$(IFS=,; echo "${bits[*]}")
+ -D enable_asm=${enable_asm}
+ )
+ meson_src_configure
+}
+
+multilib_src_compile() {
+ eninja
+}
+
+multilib_src_install() {
+ DESTDIR="${D}" eninja install
+}