summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZamarin Arthur <arthurzam@gmail.com>2019-11-09 16:27:42 +0200
committerMichał Górny <mgorny@gentoo.org>2019-11-29 20:54:25 +0100
commitf3562b69840a493f7be255382d323aebe2027ab6 (patch)
treee0ae2a786787f04974f30a18ad29a6d03f28908d
parentdev-python/atomicwrites: bump v1.3.0 (diff)
downloadgentoo-f3562b69.tar.gz
gentoo-f3562b69.tar.bz2
gentoo-f3562b69.zip
dev-python/pathlib2: bump v2.3.5
add python3_8 Package-Manager: Portage-2.3.79, Repoman-2.3.18 Signed-off-by: Zamarin Arthur <arthurzam@gmail.com> Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pathlib2/Manifest1
-rw-r--r--dev-python/pathlib2/pathlib2-2.3.5.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/pathlib2/Manifest b/dev-python/pathlib2/Manifest
index c0e5edf89709..abe89efbe965 100644
--- a/dev-python/pathlib2/Manifest
+++ b/dev-python/pathlib2/Manifest
@@ -1,2 +1,3 @@
DIST pathlib2-2.3.0.tar.gz 34291 BLAKE2B ef1768f8a9cc9b28f85ef84c0dfdbfce0b0087c1ffb6718e2b13eb007ea3e0ab0eebe946a1bcc2683fed7db46867f415ad2b52abedcdc87fb67bd45d5998aea5 SHA512 715fbd981d42767862dcaf2cc0fee31b9ec5050915ef7d909d14587609a7a5939e32b39736b586a890e7625443bb163832896fcf138b5c2863c451b71c36a124
DIST pathlib2-2.3.2.tar.gz 33764 BLAKE2B c652069d60f489e482c6d75c0a201c5ac67c6b18b4acd6c8b00f7f12832f7165a45293d93ca7f6c45f1451c842e59931b6b8c45608de1bac91ad822cc3536105 SHA512 46ba0cc8b26006bc4cb914118b7c453dc49cc8a80147ea7a4b3d5a17e97d5538c5d73a3029bd7e5b59f42f256baba30ea273382e57468df1a459ac6f7c237ddc
+DIST pathlib2-2.3.5.tar.gz 34393 BLAKE2B 7e03214a53f1ebf7718d04f653e24ffa4b06070b0ae21583d98ea0ce956c5aced5ea63bf6062d8e8d979bef4c82137cd2d2d5d6121dc3dda0ae1f713c1868d36 SHA512 3f0f212bf5208d0965ac02a590bef6ac0ec5e3b702828c06c3c9d37119b3db422cc7873de614fdc37ebfb3f52239a6517008d9672a176ca15d03fe13baeeddc8
diff --git a/dev-python/pathlib2/pathlib2-2.3.5.ebuild b/dev-python/pathlib2/pathlib2-2.3.5.ebuild
new file mode 100644
index 000000000000..f91dd378eabd
--- /dev/null
+++ b/dev-python/pathlib2/pathlib2-2.3.5.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy{,3} python{2_7,3_{5,6,7,8}} )
+
+inherit distutils-r1
+
+DESCRIPTION="Fork of pathlib aiming to support the full stdlib Python API"
+HOMEPAGE="https://github.com/mcmtroffaes/pathlib2"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ $(python_gen_cond_dep 'dev-python/scandir[${PYTHON_USEDEP}]' -2 )
+ dev-python/six[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' -2)
+ )
+"
+
+python_test() {
+ "${EPYTHON}" tests/test_pathlib2.py -v || \
+ die "tests failed with ${EPYTHON}"
+}