summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>2020-01-02 01:59:00 -0100
committerJorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>2020-01-02 01:59:00 -0100
commitf364079f2e27d56cd30a7a6d441a4153ecc2d229 (patch)
tree219cf279a8f090139152f9f99545e06d72a43d78
parentgames-util/lutris: add patch to fix issue with x11-libs/gtk+-3.24.13 (diff)
downloadgentoo-f364079f.tar.gz
gentoo-f364079f.tar.bz2
gentoo-f364079f.zip
dev-db/phpmyadmin: 4.9.3 release bump and fixed php dep on 5.0.0.
The new 5.0.0 release requires at least php-7.1 and has a known issue with authentication, so be sure to read https://www.phpmyadmin.net/news/2019/12/26/phpmyadmin-500-released/ Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: Jorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>
-rw-r--r--dev-db/phpmyadmin/Manifest1
-rw-r--r--dev-db/phpmyadmin/phpmyadmin-4.9.3.ebuild61
-rw-r--r--dev-db/phpmyadmin/phpmyadmin-5.0.0.ebuild4
3 files changed, 64 insertions, 2 deletions
diff --git a/dev-db/phpmyadmin/Manifest b/dev-db/phpmyadmin/Manifest
index 74b7adce1b4c..ea2f57ffe572 100644
--- a/dev-db/phpmyadmin/Manifest
+++ b/dev-db/phpmyadmin/Manifest
@@ -1,2 +1,3 @@
DIST phpMyAdmin-4.9.2-all-languages.tar.xz 6118472 BLAKE2B 07093982aebf83017a1773a1cd1acac8b7a4cc9bf666f7c62fdef4b3b46441f5ee1da37746610b0ed6b92a67296d908dbf24ba1ea546c1b573c3593a02b90088 SHA512 426689c31f963a9cbe34b2116888aa0264801aa5ef18fb0e4b89811b032d4018c770538e823bccb684fb066ed27fcf6dc6e0fb4198d1e082e7eea15595b67727
+DIST phpMyAdmin-4.9.3-all-languages.tar.xz 6136280 BLAKE2B 638fef4a3b50a9c3d528c21d29a2c6d96fe2d425e0cbba03f55fce2bbbda8992cc5723be19ba40bd31ed2adf37fdbc3f382a22c9634bed37f3ac6107e40d06cc SHA512 ac6ec72efde6aad6b20d651328ad0d9440f11b150c38f4043f0e3916b97a15908f60b13a5948ec8767d62499a9d31d0bbe4d764f97f7236de3d7ba9cfc422379
DIST phpMyAdmin-5.0.0-all-languages.tar.xz 8130456 BLAKE2B f8006ed4b78674d835c348104bd0d6a84ee26ab918080a38cda218399b74d62c8b7fa23d75c87d1705090fe751e39d47f1c66edf2bac03f68a52e5ed40209042 SHA512 7b29193a7376044d05a97f7cf3080c90db23433ba4de98e95dc1162ab740c4facd9a7b52816a9e65b23a72d908746d27ca4df008e752af7117fa89ff7af962c9
diff --git a/dev-db/phpmyadmin/phpmyadmin-4.9.3.ebuild b/dev-db/phpmyadmin/phpmyadmin-4.9.3.ebuild
new file mode 100644
index 000000000000..b44663d57514
--- /dev/null
+++ b/dev-db/phpmyadmin/phpmyadmin-4.9.3.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit eutils webapp
+
+MY_PV=${PV/_/-}
+MY_PN="phpMyAdmin"
+MY_P="${MY_PN}-${MY_PV}-all-languages"
+
+DESCRIPTION="Web-based administration for MySQL database in PHP"
+HOMEPAGE="https://www.phpmyadmin.net/"
+SRC_URI="https://files.phpmyadmin.net/${MY_PN}/${MY_PV}/${MY_P}.tar.xz"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="setup"
+
+RDEPEND="
+ dev-lang/php[ctype,filter,json,session,unicode]
+ || (
+ dev-lang/php[mysqli]
+ dev-lang/php[mysql]
+ )
+ virtual/httpd-php:*
+"
+
+need_httpd_cgi
+
+S="${WORKDIR}"/${MY_P}
+
+pkg_setup() {
+ webapp_pkg_setup
+}
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc README RELEASE-DATE-${MY_PV} ChangeLog
+ rm -f LICENSE README* RELEASE-DATE-${MY_PV}
+
+ if ! use setup; then
+ rm -rf setup || die "Cannot remove setup utility"
+ elog "The phpMyAdmin setup utility has been removed."
+ elog "It is a regular target of various exploits. If you need it, set USE=setup."
+ else
+ elog "You should consider disabling the setup USE flag"
+ elog "to exclude the setup utility if you don't use it."
+ elog "It regularly is the target of various exploits."
+ fi
+
+ insinto "${MY_HTDOCSDIR#${EPREFIX}}"
+ doins -r .
+
+ webapp_configfile "${MY_HTDOCSDIR#${EPREFIX}}"/libraries/config.default.php
+ webapp_serverowned "${MY_HTDOCSDIR#${EPREFIX}}"/libraries/config.default.php
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en-3.1.txt
+ webapp_src_install
+}
diff --git a/dev-db/phpmyadmin/phpmyadmin-5.0.0.ebuild b/dev-db/phpmyadmin/phpmyadmin-5.0.0.ebuild
index 65c0132a20e8..bcfb741fefec 100644
--- a/dev-db/phpmyadmin/phpmyadmin-5.0.0.ebuild
+++ b/dev-db/phpmyadmin/phpmyadmin-5.0.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -18,7 +18,7 @@ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~ppc-macos ~x64
IUSE="setup"
RDEPEND="
- dev-lang/php[ctype,filter,json,session,unicode]
+ >=dev-lang/php-7.1[ctype,filter,json,session,unicode]
|| (
dev-lang/php[mysqli]
dev-lang/php[mysql]