summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-09-12 13:48:19 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-09-12 14:37:42 +0200
commitf36481dac4ef813759d7c6b43c091d0b30555317 (patch)
tree78613527535c9a45c1bfbeded8be5ace4f6d5331
parentkde-frameworks/knewstuff: 5.74.0 version bump (diff)
downloadgentoo-f36481da.tar.gz
gentoo-f36481da.tar.bz2
gentoo-f36481da.zip
kde-frameworks/knotifyconfig: 5.74.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--kde-frameworks/knotifyconfig/Manifest1
-rw-r--r--kde-frameworks/knotifyconfig/knotifyconfig-5.74.0.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/kde-frameworks/knotifyconfig/Manifest b/kde-frameworks/knotifyconfig/Manifest
index 4cb86313abac..ce4e4355fdce 100644
--- a/kde-frameworks/knotifyconfig/Manifest
+++ b/kde-frameworks/knotifyconfig/Manifest
@@ -1,2 +1,3 @@
DIST knotifyconfig-5.70.0.tar.xz 85324 BLAKE2B 4e7a41924f97e545cba52fa23f3983db0a5372536f6c8ea65dcc818f66edb4d82d5a79e674fa808e82e9472c6a890c25163710c7a856cf4ab5f1d793d9eec77e SHA512 49afc7f7c5da3b01a6ac5bb173239907e40f9cc4a7a32f804a5d3669a85f07c40b15f2531b9a792a40039a096c9c76ce7b4a98a486e6563c1ab79c424cebcdf3
DIST knotifyconfig-5.73.0.tar.xz 86068 BLAKE2B cb8f571e4ca5b4aabd2a9e882e2d97181b60eeca264711016b8255de5813ae8c025095e01b450270c7824fe332c8c9a5b79ce84dc71b1e77e99c04fa805cd215 SHA512 16555379c8f43be43906d0c01283438eafc88bc498bf6565d5fafa2125bb1d4c5aa96009d000207567ebbd6ce49862c57acc4b09fb3737cb0e72ff1809d8200e
+DIST knotifyconfig-5.74.0.tar.xz 84364 BLAKE2B 3745f0ccacad9f16b05d89a9451d1257a52ccc28b656e83dd7031c5d2951620dc745ca43895213a2b1c2788260387807c1de30712f40ebb93091b5fb2cab59e4 SHA512 73957b4977ebccc47c53fa65c6352ff333af7a170a55a6021e5426df3715c167a43170fc6d82ee7a452246560cc57a976341a013c9ed7afc243b74a18c755ffe
diff --git a/kde-frameworks/knotifyconfig/knotifyconfig-5.74.0.ebuild b/kde-frameworks/knotifyconfig/knotifyconfig-5.74.0.ebuild
new file mode 100644
index 000000000000..7aed7fde3444
--- /dev/null
+++ b/kde-frameworks/knotifyconfig/knotifyconfig-5.74.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_TEST="false"
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.14.2
+inherit ecm kde.org
+
+DESCRIPTION="Framework for configuring desktop notifications"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="phonon"
+
+DEPEND="
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ =kde-frameworks/kcompletion-${PVCUT}*:5
+ =kde-frameworks/kconfig-${PVCUT}*:5
+ =kde-frameworks/ki18n-${PVCUT}*:5
+ =kde-frameworks/kio-${PVCUT}*:5
+ !phonon? ( media-libs/libcanberra )
+ phonon? ( >=media-libs/phonon-4.11.0 )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package !phonon Canberra)
+ )
+ ecm_src_configure
+}