summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2017-07-12 06:24:32 +0200
committerHans de Graaff <graaff@gentoo.org>2017-07-12 06:24:32 +0200
commitf3705e69dcb7783fe7c991e80d8b7972a0f5801f (patch)
tree2b049924196358d8effe488d0e493bd659388eac
parentdev-ruby/oauth: add 0.5.3 (diff)
downloadgentoo-f3705e69dcb7783fe7c991e80d8b7972a0f5801f.tar.gz
gentoo-f3705e69dcb7783fe7c991e80d8b7972a0f5801f.tar.bz2
gentoo-f3705e69dcb7783fe7c991e80d8b7972a0f5801f.zip
dev-ruby/tilt: add 2.0.7
Package-Manager: Portage-2.3.6, Repoman-2.3.1
-rw-r--r--dev-ruby/tilt/Manifest1
-rw-r--r--dev-ruby/tilt/tilt-2.0.7.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-ruby/tilt/Manifest b/dev-ruby/tilt/Manifest
index 7f6e45ff4acb..3c5fea01ac8e 100644
--- a/dev-ruby/tilt/Manifest
+++ b/dev-ruby/tilt/Manifest
@@ -1,2 +1,3 @@
DIST tilt-1.4.1.gem 42496 SHA256 39820562c4f5db45fe18de87ccc30a0e77a998bf5334b1d8c10a2f7dbc1f5903 SHA512 10fec263596d0e18a7a1440a7edfa08a161526cc46cc70427bc251951c447c40b4a4e8675e9162a9ed288879682b4aceeeb35b48cf3f4925921025194543363f WHIRLPOOL 5d70949358b97e867cdec160bd3c3726dabfec94bfeadc3a12f17463d378779d8502dda6458c7deb92bd3d9def91e306077ef806a7f75bd6c892554739ce46e9
DIST tilt-2.0.5.gem 52224 SHA256 0ec3e46ff4dcbabe0e90af1e92786b3c88312ebca55816b04f2511d1dd42f351 SHA512 b032439d00e09d3968b20f5ea5937c5918b1e10e0255cce402b6859b7d59ecdc265523a151c0fcca0034e0de26ca5fe422944790939896d7e0000641980764fa WHIRLPOOL ab98e857c456b664e8364d037b800ace4559b3de317c72da116402d0845a697e1979c33a77606ebd976b7ac03d0ecd24d4c56711e53190ae62edb63bc19f8b9c
+DIST tilt-2.0.7.gem 54272 SHA256 eb684011d518d16d293a9fdc1ac52bdeb7b6c04153537dda453f1150b85741c7 SHA512 5becf05d870db6ddb656e7a1c45615aa821e0b9827a9cdc4212dcca25c24db671bd8d9fb8f8d6a6ea4095dbe6a80fc0b4792b4382d50ada6c0eec81fd6270064 WHIRLPOOL f3ca0c00b217140589da31255e2dcb62d873d65a54aee4777a7fbddee584194a571781e4832c9748727c70c6c68cbe37696890e1ee39c5dafb9ed4ec603462f2
diff --git a/dev-ruby/tilt/tilt-2.0.7.ebuild b/dev-ruby/tilt/tilt-2.0.7.ebuild
new file mode 100644
index 000000000000..2d2b204f530d
--- /dev/null
+++ b/dev-ruby/tilt/tilt-2.0.7.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby21 ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md docs/TEMPLATES.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Thin interface over template engines to make their usage as generic as possible"
+HOMEPAGE="https://github.com/rtomayko/tilt"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+# Block on some of the potential test dependencies. These dependencies
+# are optional for the test suite, and we don't want to depend on all of
+# them to faciliate keywording and stabling.
+ruby_add_bdepend "test? (
+ dev-ruby/bluecloth
+ dev-ruby/coffee-script
+ dev-ruby/erubis
+ dev-ruby/nokogiri
+ !!<dev-ruby/maruku-0.7.2 )"
+
+ruby_add_rdepend "!!<dev-ruby/tilt-1.4.1-r2:0"
+
+all_ruby_prepare() {
+ rm Gemfile || die
+ sed -e '/bundler/I s:^:#:' -i Rakefile test/test_helper.rb || die
+
+ # Avoid tests with minor syntax differences since this happens all
+ # the time when details in the dependencies change.
+ sed -e '/test_smarty_pants_true/,/^ end/ s:^:#:' \
+ -e '/test_smart_quotes_true/,/^ end/ s:^:#:' -i test/tilt_markdown_test.rb || die
+ sed -e '/smartypants when :smart is set/,/^ end/ s:^:#:' -i test/tilt_rdiscounttemplate_test.rb || die
+}