summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-09-19 20:52:34 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-09-19 22:18:42 +0200
commitf382ea24f03a66a0e21025df275d48c700c6b73a (patch)
tree60a1e49ba2707a19b5c9a850d7ffcbff5f29278f
parentapp-i18n/pology: live ebuild moved to kde overlay (diff)
downloadgentoo-f382ea24f03a66a0e21025df275d48c700c6b73a.tar.gz
gentoo-f382ea24f03a66a0e21025df275d48c700c6b73a.tar.bz2
gentoo-f382ea24f03a66a0e21025df275d48c700c6b73a.zip
dev-util/cmake: Disable broken tests
Permanently failing, oh well. - RunCMake.CommandLineTar Require Qt4: - RunCMake.IncompatibleQt - RunCMake.ObsoleteQtMacros Bug: https://bugs.gentoo.org/690186 Bug: https://bugs.gentoo.org/708402 Package-Manager: Portage-3.0.7, Repoman-3.0.1 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--dev-util/cmake/cmake-3.17.4-r1.ebuild14
-rw-r--r--dev-util/cmake/cmake-3.18.2.ebuild4
2 files changed, 11 insertions, 7 deletions
diff --git a/dev-util/cmake/cmake-3.17.4-r1.ebuild b/dev-util/cmake/cmake-3.17.4-r1.ebuild
index 3af2be355a2b..7575025aa80b 100644
--- a/dev-util/cmake/cmake-3.17.4-r1.ebuild
+++ b/dev-util/cmake/cmake-3.17.4-r1.ebuild
@@ -22,8 +22,8 @@ IUSE="doc emacs ncurses qt5 test"
RESTRICT="!test? ( test )"
RDEPEND="
- app-crypt/rhash
>=app-arch/libarchive-3.3.3:=
+ app-crypt/rhash
>=dev-libs/expat-2.0.1
>=dev-libs/jsoncpp-1.9.2-r2:0=
>=dev-libs/libuv-1.10.0:=
@@ -71,7 +71,7 @@ PATCHES=(
)
cmake_src_bootstrap() {
- # disable running of cmake in boostrap command
+ # disable running of cmake in bootstrap command
sed -i \
-e '/"${cmake_bootstrap_dir}\/cmake"/s/^/#DONOTRUN /' \
bootstrap || die "sed failed"
@@ -104,22 +104,24 @@ cmake_src_test() {
[[ -n ${TEST_VERBOSE} ]] && ctestargs="--extra-verbose --output-on-failure"
# Excluded tests:
- # BootstrapTest: we actualy bootstrap it every time so why test it.
+ # BootstrapTest: we actually bootstrap it every time so why test it.
# BundleUtilities: bundle creation broken
# CMakeOnly.AllFindModules: pthread issues
- # CTest.updatecvs: which fails to commit as root
+ # CTest.updatecvs: fails to commit as root
# Fortran: requires fortran
+ # RunCMake.CommandLineTar: whatever...
# RunCMake.CompilerLauncher: also requires fortran
# RunCMake.CPack_RPM: breaks if app-arch/rpm is installed because
# debugedit binary is not in the expected location
# RunCMake.CPack_DEB: breaks if app-arch/dpkg is installed because
# it can't find a deb package that owns libc
- # TestUpload, which requires network access
+ # RunCMake.{IncompatibleQt,ObsoleteQtMacros}: Require Qt4
+ # TestUpload: requires network access
"${BUILD_DIR}"/bin/ctest \
-j "$(makeopts_jobs)" \
--test-load "$(makeopts_loadavg)" \
${ctestargs} \
- -E "(BootstrapTest|BundleUtilities|CMakeOnly.AllFindModules|CompileOptions|CTest.UpdateCVS|Fortran|RunCMake.CompilerLauncher|RunCMake.PrecompileHeaders|RunCMake.CPack_(DEB|RPM)|TestUpload)" \
+ -E "(BootstrapTest|BundleUtilities|CMakeOnly.AllFindModules|CompileOptions|CTest.UpdateCVS|Fortran|RunCMake.CommandLineTar|RunCMake.CompilerLauncher|RunCMake.IncompatibleQt|RunCMake.ObsoleteQtMacros|RunCMake.PrecompileHeaders|RunCMake.CPack_(DEB|RPM)|TestUpload)" \
|| die "Tests failed"
popd > /dev/null
diff --git a/dev-util/cmake/cmake-3.18.2.ebuild b/dev-util/cmake/cmake-3.18.2.ebuild
index ab16a6de18f6..7334e72c320d 100644
--- a/dev-util/cmake/cmake-3.18.2.ebuild
+++ b/dev-util/cmake/cmake-3.18.2.ebuild
@@ -108,17 +108,19 @@ cmake_src_test() {
# CMakeOnly.AllFindModules: pthread issues
# CTest.updatecvs: fails to commit as root
# Fortran: requires fortran
+ # RunCMake.CommandLineTar: whatever...
# RunCMake.CompilerLauncher: also requires fortran
# RunCMake.CPack_RPM: breaks if app-arch/rpm is installed because
# debugedit binary is not in the expected location
# RunCMake.CPack_DEB: breaks if app-arch/dpkg is installed because
# it can't find a deb package that owns libc
+ # RunCMake.{IncompatibleQt,ObsoleteQtMacros}: Require Qt4
# TestUpload: requires network access
"${BUILD_DIR}"/bin/ctest \
-j "$(makeopts_jobs)" \
--test-load "$(makeopts_loadavg)" \
${ctestargs} \
- -E "(BootstrapTest|BundleUtilities|CMakeOnly.AllFindModules|CompileOptions|CTest.UpdateCVS|Fortran|RunCMake.CompilerLauncher|RunCMake.PrecompileHeaders|RunCMake.CPack_(DEB|RPM)|TestUpload)" \
+ -E "(BootstrapTest|BundleUtilities|CMakeOnly.AllFindModules|CompileOptions|CTest.UpdateCVS|Fortran|RunCMake.CommandLineTar|RunCMake.CompilerLauncher|RunCMake.IncompatibleQt|RunCMake.ObsoleteQtMacros|RunCMake.PrecompileHeaders|RunCMake.CPack_(DEB|RPM)|TestUpload)" \
|| die "Tests failed"
popd > /dev/null