summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-10-02 06:14:30 +0100
committerSam James <sam@gentoo.org>2021-10-02 06:23:36 +0100
commitf388dddf6055334dfe5f2452612272324bea70d8 (patch)
treec7800a2e14a2f4d692fe12271d506e5f484b9df8
parentdev-lang/ocaml: add 4.13.0 (diff)
downloadgentoo-f388dddf.tar.gz
gentoo-f388dddf.tar.bz2
gentoo-f388dddf.zip
dev-ml/ppxlib: stop blocking dev-libs/nss[utils]
I should've poked at this a bit more at the time, but it is what it is. Thanks to the reporter of this upstream, the ppxlib folks realised/noticed it as an error and have dropped the colliding 'pp'. It ended up not being supposed to be installed at all. See: https://github.com/ocaml-ppx/ppxlib/issues/224 See: c87dfe922463070c8ec351fa4341d97a1ed56f8a Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-ml/ppxlib/ppxlib-0.21.0-r2.ebuild (renamed from dev-ml/ppxlib/ppxlib-0.21.0-r1.ebuild)10
-rw-r--r--dev-ml/ppxlib/ppxlib-0.22.0-r2.ebuild (renamed from dev-ml/ppxlib/ppxlib-0.22.0-r1.ebuild)10
-rw-r--r--dev-ml/ppxlib/ppxlib-0.22.2-r1.ebuild (renamed from dev-ml/ppxlib/ppxlib-0.22.2.ebuild)10
3 files changed, 24 insertions, 6 deletions
diff --git a/dev-ml/ppxlib/ppxlib-0.21.0-r1.ebuild b/dev-ml/ppxlib/ppxlib-0.21.0-r2.ebuild
index 4e0bb08cb7f4..2f753797ef40 100644
--- a/dev-ml/ppxlib/ppxlib-0.21.0-r1.ebuild
+++ b/dev-ml/ppxlib/ppxlib-0.21.0-r2.ebuild
@@ -15,7 +15,6 @@ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
IUSE="+ocamlopt test"
RESTRICT="!test? ( test )"
-# nss[utils] has /usr/bin/pp
RDEPEND="
>=dev-ml/base-0.11.0:=
dev-ml/findlib:=
@@ -25,7 +24,6 @@ RDEPEND="
dev-ml/stdlib-shims:=
>=dev-ml/ppx_derivers-1.2.1:=
>=dev-ml/stdio-0.11.0:=
- !dev-libs/nss[utils]
"
DEPEND="${DEPEND}
test? (
@@ -33,3 +31,11 @@ DEPEND="${DEPEND}
dev-ml/re:=
)
"
+
+src_install() {
+ dune_src_install
+
+ # Clashes with dev-libs/nss[utils], accidentally installed upstream
+ # https://github.com/ocaml-ppx/ppxlib/issues/224
+ rm "${ED}"/usr/bin/pp || die
+}
diff --git a/dev-ml/ppxlib/ppxlib-0.22.0-r1.ebuild b/dev-ml/ppxlib/ppxlib-0.22.0-r2.ebuild
index 116ac1f1e0ee..53471d4c6327 100644
--- a/dev-ml/ppxlib/ppxlib-0.22.0-r1.ebuild
+++ b/dev-ml/ppxlib/ppxlib-0.22.0-r2.ebuild
@@ -15,14 +15,12 @@ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
IUSE="+ocamlopt test"
RESTRICT="!test? ( test )"
-# nss[utils] has /usr/bin/pp
RDEPEND="
>=dev-ml/ocaml-compiler-libs-0.11.0:=
>=dev-ml/ocaml-migrate-parsetree-2.1.0:=
dev-ml/sexplib0:=
dev-ml/stdlib-shims:=
>=dev-ml/ppx_derivers-1.2.1:=
- !dev-libs/nss[utils]
"
DEPEND="${DEPEND}
test? (
@@ -34,3 +32,11 @@ DEPEND="${DEPEND}
)
"
BDEPEND=">=dev-ml/dune-2.8"
+
+src_install() {
+ dune_src_install
+
+ # Clashes with dev-libs/nss[utils], accidentally installed upstream
+ # https://github.com/ocaml-ppx/ppxlib/issues/224
+ rm "${ED}"/usr/bin/pp || die
+}
diff --git a/dev-ml/ppxlib/ppxlib-0.22.2.ebuild b/dev-ml/ppxlib/ppxlib-0.22.2-r1.ebuild
index bc486940ff77..2986d9beed3a 100644
--- a/dev-ml/ppxlib/ppxlib-0.22.2.ebuild
+++ b/dev-ml/ppxlib/ppxlib-0.22.2-r1.ebuild
@@ -15,14 +15,12 @@ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
IUSE="+ocamlopt test"
RESTRICT="!test? ( test )"
-# nss[utils] has /usr/bin/pp
RDEPEND="
>=dev-ml/ocaml-compiler-libs-0.11.0:=
>=dev-ml/ocaml-migrate-parsetree-2.2.0:=
dev-ml/sexplib0:=
dev-ml/stdlib-shims:=
>=dev-ml/ppx_derivers-1.2.1:=
- !dev-libs/nss[utils]
"
DEPEND="${DEPEND}
test? (
@@ -34,3 +32,11 @@ DEPEND="${DEPEND}
)
"
BDEPEND=">=dev-ml/dune-2.8"
+
+src_install() {
+ dune_src_install
+
+ # Clashes with dev-libs/nss[utils], accidentally installed upstream
+ # https://github.com/ocaml-ppx/ppxlib/issues/224
+ rm "${ED}"/usr/bin/pp || die
+}