summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-12-07 16:21:53 +0100
committerMichał Górny <mgorny@gentoo.org>2022-12-07 16:59:44 +0100
commitf391c932cebe23ea6f3fc8bf16b9820ad0f0d67c (patch)
tree04f31f883a13f5da809b32a808d7ded10c56b47d
parentdev-python/installer: Bump to 0.6.0 (diff)
downloadgentoo-f391c932cebe23ea6f3fc8bf16b9820ad0f0d67c.tar.gz
gentoo-f391c932cebe23ea6f3fc8bf16b9820ad0f0d67c.tar.bz2
gentoo-f391c932cebe23ea6f3fc8bf16b9820ad0f0d67c.zip
dev-python/furo: Bump to 2022.12.7
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/furo/Manifest1
-rw-r--r--dev-python/furo/furo-2022.12.7.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/furo/Manifest b/dev-python/furo/Manifest
index 40df32f796cd..77fb99093d40 100644
--- a/dev-python/furo/Manifest
+++ b/dev-python/furo/Manifest
@@ -1 +1,2 @@
+DIST furo-2022.12.7-py3-none-any.whl 328721 BLAKE2B 2a2d215db9d63946da85579ccc5a71f87e3ecbca0fda180ed44b7e79e77744b47d2c17d4d5a256d71e02d5e7ac5165f3648f38c08567b7c871abf8d7edf2ce26 SHA512 ce44dd78db216875538722a56041ce7634bfeebbc6add6b52cdecd86d0f99f5f9c8aa0d275a8439a269f75345ae716a32b90701d031dfd3047df3f1db33e150e
DIST furo-2022.9.29-py3-none-any.whl 326787 BLAKE2B ef558aae586d2f189a0ec24e4dc5b8422167829ed8a917b276dcdac4ce7bcc12bdf9855b8fe6a75767b094e4e35b30b2eacd227b5d585de32845f2299f3acab1 SHA512 4ab394a006011ced6d74f696a49973628220719d1f8c1e5ae49b2a0c62dd3cc961f7a18d654bffcf385b07b6bc556930de5a5741c1e0dc9d7b6b6f4cc2cfc885
diff --git a/dev-python/furo/furo-2022.12.7.ebuild b/dev-python/furo/furo-2022.12.7.ebuild
new file mode 100644
index 000000000000..19c0fda7a8a4
--- /dev/null
+++ b/dev-python/furo/furo-2022.12.7.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# sphinx-theme-builder is completely unusable, as it requires pinning
+# to a very-specific nodejs version number, and ofc loves fetching
+# everything from the Internet
+
+DISTUTILS_USE_PEP517=standalone
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Clean customisable Sphinx documentation theme"
+HOMEPAGE="
+ https://pypi.org/project/furo/
+ https://github.com/pradyunsg/furo/
+"
+SRC_URI="
+ https://files.pythonhosted.org/packages/py3/${PN::1}/${PN}/${P}-py3-none-any.whl
+"
+S=${WORKDIR}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/sphinx-basic-ng[${PYTHON_USEDEP}]
+"
+
+python_compile() {
+ distutils_wheel_install "${BUILD_DIR}/install" \
+ "${DISTDIR}/${P}-py3-none-any.whl"
+}