summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-04-11 04:32:03 +0200
committerMichał Górny <mgorny@gentoo.org>2023-04-11 05:14:22 +0200
commitf39fdd2058bc46773f5995f8323eaca00df7b719 (patch)
tree0ffccc579fe8da8ce0ea5fb2ee132f410eff4523
parentapp-admin/awscli: Bump to 1.27.110 (diff)
downloadgentoo-f39fdd2058bc46773f5995f8323eaca00df7b719.tar.gz
gentoo-f39fdd2058bc46773f5995f8323eaca00df7b719.tar.bz2
gentoo-f39fdd2058bc46773f5995f8323eaca00df7b719.zip
dev-python/cfn-lint: Bump to 0.77.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/cfn-lint/Manifest1
-rw-r--r--dev-python/cfn-lint/cfn-lint-0.77.0.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/dev-python/cfn-lint/Manifest b/dev-python/cfn-lint/Manifest
index 509c7b42a51e..a7d892964ad7 100644
--- a/dev-python/cfn-lint/Manifest
+++ b/dev-python/cfn-lint/Manifest
@@ -2,3 +2,4 @@ DIST cfn-lint-0.74.3.gh.tar.gz 3456672 BLAKE2B 9cc68ddefda86ee26e900989e40c7ded0
DIST cfn-lint-0.75.1.gh.tar.gz 3487870 BLAKE2B 26aaf3b24023260d7a7d8f2b89fc9135e0c34786540c21d1c1763decad42167f1a29b01859bfcb17fe5ac1fbbb08aebf04191c6d1b21b335c92e2424c986cada SHA512 d4dfa9331c77f7c323b217203c470e15b4a62a86b42497934a4f9609d54a499211058cba4c561034f6c3dd6ba52ade30084e9a9d25da135289f783ed972a14ae
DIST cfn-lint-0.76.1.gh.tar.gz 3631194 BLAKE2B 95d395369fc230fe4e6c5d5e2a0e4bf246f1f312c6595e998004d43a7662e43ed0612a56893956fbb15e99ed197d9af2723fc1c2ea9b14fc27d8b4ff7b29e484 SHA512 5c65111fa7f57b268f2f3f52157d464de467cfdf16cd672e399ab7b2d23d648346c6754c45cd169f993ae15180ffafc710c9f2fa0675a7ecb1d8fc5b3d0ec5ce
DIST cfn-lint-0.76.2.tar.gz 3402554 BLAKE2B e5f9405d2852e3b81140a24d94c90a3bf8c919eb6823280a0a887c6acc56ec71d991cbc76532cc49d1189a8f64750ba3e9db02fb3b46b27a28ec3468f4dd268e SHA512 96351ade16308be18baace1351e263a179eacc0b3635e9baa959baadaebb6a08825f6cb9cd83cb83b8635785c7f54405bfcf00f85d6d95d101d3298919cd1ea7
+DIST cfn-lint-0.77.0.tar.gz 3474124 BLAKE2B 5715618f6b44a7a88ef3af8d21d038fa4ce4707973e64eb9712ff524cd5276e71802ad4b9a55580ac469b6474c7d48a8ccee04660bcaf7934df7a23cab1e5a9a SHA512 6509197ef29d8bcbfc416df0a63f89736f704b147bbeb489586b6a06e1818f1d91e59429c73a9e9e23dadb20325a3c79d0b8e1b4637cd0e131f9673422e36734
diff --git a/dev-python/cfn-lint/cfn-lint-0.77.0.ebuild b/dev-python/cfn-lint/cfn-lint-0.77.0.ebuild
new file mode 100644
index 000000000000..2b6753f1c840
--- /dev/null
+++ b/dev-python/cfn-lint/cfn-lint-0.77.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="CloudFormation Linter"
+HOMEPAGE="
+ https://github.com/aws-cloudformation/cfn-lint/
+ https://pypi.org/project/cfn-lint/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/aws-sam-translator-1.64.0[${PYTHON_USEDEP}]
+ dev-python/jsonpatch[${PYTHON_USEDEP}]
+ >=dev-python/jschema_to_python-1.2.3[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-3.0[${PYTHON_USEDEP}]
+ dev-python/junit-xml[${PYTHON_USEDEP}]
+ <dev-python/networkx-4[${PYTHON_USEDEP}]
+ >dev-python/pyyaml-5.4[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.15.0[${PYTHON_USEDEP}]
+ dev-python/regex[${PYTHON_USEDEP}]
+ >=dev-python/sarif_om-1.0.4[${PYTHON_USEDEP}]
+ >=dev-python/sympy-1.0.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin the deps
+ sed -e 's:~=[0-9.]*::' -i setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ test/unit/module/test_template.py::TestTemplate::test_build_graph
+ # requires git repo
+ test/unit/module/maintenance/test_update_documentation.py::TestUpdateDocumentation::test_update_docs
+ # Internet
+ test/unit/module/formatters/test_formatters.py::TestFormatters::test_sarif_formatter
+ test/unit/module/maintenance/test_update_resource_specs.py::TestUpdateResourceSpecs::test_update_resource_specs_python_3
+ # TODO: it looks as if AWS_DEFAULT_REGION didn't work
+ test/unit/module/core/test_run_cli.py::TestCli::test_bad_config
+ test/unit/module/core/test_run_cli.py::TestCli::test_override_parameters
+ test/unit/module/core/test_run_cli.py::TestCli::test_positional_template_parameters
+ test/unit/module/core/test_run_cli.py::TestCli::test_template_config
+ )
+
+ # from tox.ini
+ local -x AWS_DEFAULT_REGION=us-east-1
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}