summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-09-06 18:57:23 +0200
committerMaciej Barć <xgqt@gentoo.org>2022-09-06 19:00:11 +0200
commitf3c03ccdff809ca0d17ab98a9ac30419dbf97ba0 (patch)
treefdf5be4fbd794fb4f1263fa405f294c8eb22cace
parentdev-ml/menhir: bump to 20220210 (diff)
downloadgentoo-f3c03ccdff809ca0d17ab98a9ac30419dbf97ba0.tar.gz
gentoo-f3c03ccdff809ca0d17ab98a9ac30419dbf97ba0.tar.bz2
gentoo-f3c03ccdff809ca0d17ab98a9ac30419dbf97ba0.zip
dev-ml/ocaml-ssl: bump to 0.5.12
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--dev-ml/ocaml-ssl/Manifest1
-rw-r--r--dev-ml/ocaml-ssl/ocaml-ssl-0.5.12.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-ml/ocaml-ssl/Manifest b/dev-ml/ocaml-ssl/Manifest
index a06e08b2a767..3b06ae506dd4 100644
--- a/dev-ml/ocaml-ssl/Manifest
+++ b/dev-ml/ocaml-ssl/Manifest
@@ -1,2 +1,3 @@
DIST ocaml-ssl-0.5.10.tar.gz 33951 BLAKE2B a27cce7e19c3737657cbdba31d919d51d0db137aafddc6397ff018fe36346a8e99b0353c76f4a4bc4dcc7dcf63ec326e87b2ebc809b78de1511963357be280b0 SHA512 f2d0acc8dcdb0a36c8ad236f60c6e9d7f8f76ea25183017218953dbe3432a19de5b0be8214714add71b88b211ac78318f09429d4df7ecba1e19dc94d4414f0e1
+DIST ocaml-ssl-0.5.12.tar.gz 40242 BLAKE2B c5e0102f2b2a8448c4774139a3c49df198b81ed5b6bd14373bd15a22f8b4b30d29fd449139c12850bcfaa522415f4ff001f48fe218cd3d527598bafc78145d3f SHA512 d9365b2af911b24ffe0687d8d742cb82b67be39fd64ba04fcfab48a957cd2aefbb1b46ddccd944e1a73ee482866f4a0e95767b135fe43fe82d978493b7b3a827
DIST ocaml-ssl-0.5.9.tar.gz 32721 BLAKE2B c6b1ec659fddf384005f2cb045c0b0c059daaa93bd782904354e12e1ce63432c04c9bdc823dbfd0cd903ce872c91f0a750975cc69a56c9384ef6d09ed46c22cd SHA512 6826e5a6ab9f51013e8d097900f443d091e085e3d2d232a315a0e3a90ca334c9b9779d20dcae267f9ed961bc4a08fcb80372e669389c59a22d5c7706d37fcd5f
diff --git a/dev-ml/ocaml-ssl/ocaml-ssl-0.5.12.ebuild b/dev-ml/ocaml-ssl/ocaml-ssl-0.5.12.ebuild
new file mode 100644
index 000000000000..4c76a96825c3
--- /dev/null
+++ b/dev-ml/ocaml-ssl/ocaml-ssl-0.5.12.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DUNE_PKG_NAME=ssl
+
+inherit dune
+
+DESCRIPTION="OCaml bindings for OpenSSL"
+HOMEPAGE="https://github.com/savonet/ocaml-ssl"
+SRC_URI="https://github.com/savonet/ocaml-ssl/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"
+IUSE="+ocamlopt"
+
+BDEPEND="dev-ml/dune-configurator"
+DEPEND="dev-libs/openssl:0=
+ >=dev-lang/ocaml-3.10:=[ocamlopt?]"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ dune_src_install
+
+ dodoc CHANGES.md README.md
+}