summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-05-06 23:08:51 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-05-06 23:08:51 +0300
commitf3d49380b088149554ed88474edc755363ed6bda (patch)
treeb6d9c0356b01881a4b29888a52c68e61ed98281c
parentdev-lang/python: Stabilize 2.7.18_p15 hppa, #839942 (diff)
downloadgentoo-f3d49380.tar.gz
gentoo-f3d49380.tar.bz2
gentoo-f3d49380.zip
dev-python/fonttools: drop 4.30.0, 4.31.1
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/fonttools/Manifest2
-rw-r--r--dev-python/fonttools/fonttools-4.30.0.ebuild58
-rw-r--r--dev-python/fonttools/fonttools-4.31.1.ebuild58
3 files changed, 0 insertions, 118 deletions
diff --git a/dev-python/fonttools/Manifest b/dev-python/fonttools/Manifest
index 07910863c4f0..2ec498f824b9 100644
--- a/dev-python/fonttools/Manifest
+++ b/dev-python/fonttools/Manifest
@@ -1,5 +1,3 @@
-DIST fonttools-4.30.0.tar.gz 2961097 BLAKE2B 23b592daa16fd215688f149d99258209b819caa843d26c889fb4016aae6d6614a9f87dd13fa1d2aa254fadb5169cf7d57ba02b7b15af79611995148d698ca2ec SHA512 2b4e676f956c3456bf3ca435a7d80e1a0a9f36872ba3a820072d1e13ed5751a8546f424369731afd4ccddc298ec0658bb4384d2e18670b108dd1b3a99fc205f4
-DIST fonttools-4.31.1.tar.gz 2964489 BLAKE2B d1bb7059383785dd527f7276ef876042f81d3e2cc5acc1b69e111b540cf8d35273a0070e6f0602ca438f35e3b83d0a04736cd5c97b1b7669822d1a6b1ad1b487 SHA512 cdf70f376e690ab1edc5e761ba45d1ddd7760c3aefdb5e9b88cc97118edd4ff694789c8b79ece791b4b6a597dcac1abb0eec5f0634f1db0792e5e62a2137282d
DIST fonttools-4.31.2.tar.gz 2965796 BLAKE2B d776073e7a9358e67b8753dd4557e2b1b4c44d9662c8c728abe42d970bca1db1789a655df8865fef39eed3a32271749d2cb772e306f34efc87e737b7384c0b5d SHA512 50cc8bca9136675a413ac947b583f694d512872127cee129a78505d0259fe1cf6922f806558761af982758f72c7d95e1245b8de55b6ebd6ddd3bd7506d41abcf
DIST fonttools-4.32.0.tar.gz 2966840 BLAKE2B 67a79c8c2e26f9f72fcf6ea4ab5ee3712d3541b47528a209221f9fcf82a5b5db589561200e4b6911a32102a4f4dc4b4e34c8271eb97b1cee18a81b3039efdf03 SHA512 a71a44601c7ec9f709ddc14da1c26d1248909fba8a0bfb7104ebe5f9b85949fe479c5eabdd2c94086d9999756035291e68bb7e861488d4123ccf667ac3ac2e03
DIST fonttools-4.33.0.tar.gz 3525052 BLAKE2B 5ea275adbfbf6e01222f6eba8f5eef7afe533b9692e6a7a2fb644fb68dec632ab2962d6b7f6b4ff876676e8314aadbfc04a005ea7a389904e398723feaa756d0 SHA512 147f6d41d1a6b27ebe6973cb91a90384291ad8c7b75b71c3b814908012530066b79f4c39bdd6da9e98614ef61b1cc19803756aba73e4da7ce2e82147390f0023
diff --git a/dev-python/fonttools/fonttools-4.30.0.ebuild b/dev-python/fonttools/fonttools-4.30.0.ebuild
deleted file mode 100644
index 0ca22fe5ef4b..000000000000
--- a/dev-python/fonttools/fonttools-4.30.0.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} )
-PYTHON_REQ_USE="xml(+)"
-
-inherit distutils-r1 virtualx
-
-DESCRIPTION="Library for manipulating TrueType, OpenType, AFM and Type1 fonts"
-HOMEPAGE="https://github.com/fonttools/fonttools/"
-SRC_URI="https://github.com/fonttools/fonttools/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ppc ppc64 ~riscv sparc x86 ~x64-macos"
-
-RDEPEND=">=dev-python/fs-2.4.9[${PYTHON_USEDEP}]"
-BDEPEND="${RDEPEND}
- dev-python/cython[${PYTHON_USEDEP}]
- test? (
- app-arch/brotli[python,${PYTHON_USEDEP}]
- app-arch/zopfli
- )
-"
-
-distutils_enable_tests pytest
-
-python_prepare_all() {
- # When dev-python/pytest-shutil is installed, we get weird import errors.
- # This is due to incomplete nesting in the Tests/ tree:
- #
- # Tests/feaLib/__init__.py
- # Tests/ufoLib/__init__.py
- # Tests/svgLib/path/__init__.py
- # Tests/otlLib/__init__.py
- # Tests/varLib/__init__.py
- #
- # This tree requires an __init__.py in Tests/svgLib/ too, bug #701148.
- touch Tests/svgLib/__init__.py || die
-
- distutils-r1_python_prepare_all
-}
-
-src_configure() {
- export FONTTOOLS_WITH_CYTHON=1
-}
-
-src_test() {
- # virtualx used when matplotlib is installed causing plot module tests to run
- virtx distutils-r1_src_test
-}
-
-python_test() {
- epytest Tests fontTools || die "Tests failed with ${EPYTHON}"
-}
diff --git a/dev-python/fonttools/fonttools-4.31.1.ebuild b/dev-python/fonttools/fonttools-4.31.1.ebuild
deleted file mode 100644
index f0532d0a8742..000000000000
--- a/dev-python/fonttools/fonttools-4.31.1.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} )
-PYTHON_REQ_USE="xml(+)"
-
-inherit distutils-r1 virtualx
-
-DESCRIPTION="Library for manipulating TrueType, OpenType, AFM and Type1 fonts"
-HOMEPAGE="https://github.com/fonttools/fonttools/"
-SRC_URI="https://github.com/fonttools/fonttools/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~sparc ~x86 ~x64-macos"
-
-RDEPEND=">=dev-python/fs-2.4.9[${PYTHON_USEDEP}]"
-BDEPEND="${RDEPEND}
- dev-python/cython[${PYTHON_USEDEP}]
- test? (
- app-arch/brotli[python,${PYTHON_USEDEP}]
- app-arch/zopfli
- )
-"
-
-distutils_enable_tests pytest
-
-python_prepare_all() {
- # When dev-python/pytest-shutil is installed, we get weird import errors.
- # This is due to incomplete nesting in the Tests/ tree:
- #
- # Tests/feaLib/__init__.py
- # Tests/ufoLib/__init__.py
- # Tests/svgLib/path/__init__.py
- # Tests/otlLib/__init__.py
- # Tests/varLib/__init__.py
- #
- # This tree requires an __init__.py in Tests/svgLib/ too, bug #701148.
- touch Tests/svgLib/__init__.py || die
-
- distutils-r1_python_prepare_all
-}
-
-src_configure() {
- export FONTTOOLS_WITH_CYTHON=1
-}
-
-src_test() {
- # virtualx used when matplotlib is installed causing plot module tests to run
- virtx distutils-r1_src_test
-}
-
-python_test() {
- epytest Tests fontTools || die "Tests failed with ${EPYTHON}"
-}