summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-09-14 08:05:07 +0200
committerMichał Górny <mgorny@gentoo.org>2023-09-14 08:05:07 +0200
commitf3dad63bafb7c3241b777e87fea4a81f11855f2f (patch)
treef43b750ff105120ab19cd665dc1279a6ead88093
parentdev-python/sphinx: Bump to 7.2.6 (diff)
downloadgentoo-f3dad63b.tar.gz
gentoo-f3dad63b.tar.bz2
gentoo-f3dad63b.zip
dev-python/pynacl: Unpin dev-libs/libsodium
Bug: https://bugs.gentoo.org/914156 Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pynacl/pynacl-1.5.0-r3.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/pynacl/pynacl-1.5.0-r3.ebuild b/dev-python/pynacl/pynacl-1.5.0-r3.ebuild
new file mode 100644
index 000000000000..5eea6a5f0842
--- /dev/null
+++ b/dev-python/pynacl/pynacl-1.5.0-r3.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python binding to the Networking and Cryptography (NaCl) library"
+HOMEPAGE="
+ https://github.com/pyca/pynacl/
+ https://pypi.org/project/PyNaCl/
+"
+SRC_URI="
+ https://github.com/pyca/${PN}/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND="
+ dev-libs/libsodium:=
+"
+RDEPEND="
+ ${DEPEND}
+ >=dev-python/cffi-1.4.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/cffi-1.4.1[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/hypothesis-3.27.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_compile() {
+ # For not using the bundled libsodium
+ local -x SODIUM_INSTALL=system
+ distutils-r1_src_compile
+}