summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-11-16 17:54:20 +0100
committerMichał Górny <mgorny@gentoo.org>2022-11-16 18:21:36 +0100
commitf3f6a58d3dc4b7ed96246d58d42fc50c821f1377 (patch)
treeb33b086ca13566f69defd7c49b1cbe57c1b37931
parentdev-python/jupyter_client: Bump to 7.4.7 (diff)
downloadgentoo-f3f6a58d3dc4b7ed96246d58d42fc50c821f1377.tar.gz
gentoo-f3f6a58d3dc4b7ed96246d58d42fc50c821f1377.tar.bz2
gentoo-f3f6a58d3dc4b7ed96246d58d42fc50c821f1377.zip
dev-python/google-api-python-client: Bump to 2.66.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/google-api-python-client/Manifest1
-rw-r--r--dev-python/google-api-python-client/google-api-python-client-2.66.0.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/google-api-python-client/Manifest b/dev-python/google-api-python-client/Manifest
index 7903639dddb5..66381b12c31b 100644
--- a/dev-python/google-api-python-client/Manifest
+++ b/dev-python/google-api-python-client/Manifest
@@ -1,2 +1,3 @@
DIST google-api-python-client-2.64.0.gh.tar.gz 36028133 BLAKE2B 8e9abadddda17d078210c9cdf5e18db02199bae1ee6f7e5364002266ca9795100fefd8dbbfbaecd5c9e2b74e5125e42535e23f9735fb83b8fe5bc1adae1fe815 SHA512 a525d26224e7b4b647bf5fde82434fbe0e221ff55591b1564b0a3af5e1d49492b3ea157d75bec0328bda754318b9d5e57d78b4d8d532afad2e3b8cbfc650f876
DIST google-api-python-client-2.65.0.gh.tar.gz 36079173 BLAKE2B 32e60989dbc6e02ed2bd128772a71c24670d16da09ca4e5be6d4f56ebf16c94ccac120e233b4efb5fb9c9b8c464d052129eb6305a57fb61f732ca9d593f1297c SHA512 3b215e290c9a63aca914c08478342ab41ef760c135d3d5a13387be52a2993b814568c86cad752de6afe16fb3097989f4d7df06f4c9ce9c453fb7d0cb55f17053
+DIST google-api-python-client-2.66.0.gh.tar.gz 36477219 BLAKE2B 1da02e7747fd1421bdc62180103784af7b50ab0a672ac932f2fe28c22141a922d6f59d9c11ee74b78ff13583bdeee98d35f7b6d616af84fe99aa3d1a0de17342 SHA512 6b3cdf7279067080ff216d184f23c76c74c586e34b70afd936f1d10671fc0c7e7a8ba446a1ca5a9003bab2e3855e939376610ff4e45811fd6ead5e4942f62247
diff --git a/dev-python/google-api-python-client/google-api-python-client-2.66.0.ebuild b/dev-python/google-api-python-client/google-api-python-client-2.66.0.ebuild
new file mode 100644
index 000000000000..7e8aaa05d6d4
--- /dev/null
+++ b/dev-python/google-api-python-client/google-api-python-client-2.66.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Google API Client for Python"
+HOMEPAGE="
+ https://github.com/googleapis/google-api-python-client/
+ https://pypi.org/project/google-api-python-client/
+"
+SRC_URI="
+ https://github.com/googleapis/google-api-python-client/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/httplib2-0.15[${PYTHON_USEDEP}]
+ <dev-python/httplib2-1[${PYTHON_USEDEP}]
+ >=dev-python/google-api-core-2.3.1[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-1.35.0[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-httplib2-0.1.0[${PYTHON_USEDEP}]
+ >=dev-python/uritemplate-3.0.0[${PYTHON_USEDEP}]
+ <dev-python/uritemplate-5[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/oauth2client[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/parameterized[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # require Internet access (and credentials)
+ tests/test_discovery.py::DiscoveryErrors::test_credentials_and_credentials_file_mutually_exclusive
+ tests/test_discovery.py::DiscoveryFromDocument::test_api_endpoint_override_from_client_options_mapping_object
+ )
+
+ epytest tests
+}