summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJack Todaro <solpeth@posteo.org>2022-07-23 12:47:23 +1000
committerSam James <sam@gentoo.org>2022-07-23 05:06:22 +0100
commitf3fdc21d0651fff702ebdce7e9f00ec75f2f74eb (patch)
tree80bb73fe9ca3117a9c86aab19e8c3b933f4e9119
parentdev-haskell/yesod: add 1.6.2 (diff)
downloadgentoo-f3fdc21d0651fff702ebdce7e9f00ec75f2f74eb.tar.gz
gentoo-f3fdc21d0651fff702ebdce7e9f00ec75f2f74eb.tar.bz2
gentoo-f3fdc21d0651fff702ebdce7e9f00ec75f2f74eb.zip
dev-haskell/yesod-core: add 1.6.23.1
Signed-off-by: Jack Todaro <solpeth@posteo.org> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-haskell/yesod-core/Manifest1
-rw-r--r--dev-haskell/yesod-core/yesod-core-1.6.23.1.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-haskell/yesod-core/Manifest b/dev-haskell/yesod-core/Manifest
index 5702a1c1f6ff..a98798e15629 100644
--- a/dev-haskell/yesod-core/Manifest
+++ b/dev-haskell/yesod-core/Manifest
@@ -1 +1,2 @@
DIST yesod-core-1.6.18.8.tar.gz 100016 BLAKE2B 117535cc875be850011b357ebf3bb89e6d854870cefe26e20001e70b93247d85a3bd190e2f889626819f8bc80211b2c64b5d8dac7e9606229ed07c03d8926c2e SHA512 1774281bf8de190995360bcf461adc46b65bac5fa2200aada0b511f73b3bc7bab8365fa4737b4de4723481f7b76c0cb440d68b118c15c46e3d455ea9126bffa7
+DIST yesod-core-1.6.23.1.tar.gz 103119 BLAKE2B a15ee64ddc5da8f531690b8d6b661af618754a44e3e3511f15af69d82a53ce6d7886a4b55243d611727c2618446a145469db27b9ba122a32bd538d8cf6abdf80 SHA512 edbdf46c2a04a7286d46030212dcbb2c7f0e0e8b62e87682ae8ed4468796d15544990fb43d56a801fcfbf4dde740bc09cfa192ec21c3d5aeb72b92a5ed0cb173
diff --git a/dev-haskell/yesod-core/yesod-core-1.6.23.1.ebuild b/dev-haskell/yesod-core/yesod-core-1.6.23.1.ebuild
new file mode 100644
index 000000000000..c276f0082c3c
--- /dev/null
+++ b/dev-haskell/yesod-core/yesod-core-1.6.23.1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.7.1.2.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Creation of type-safe, RESTful web applications"
+HOMEPAGE="https://www.yesodweb.com/"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+
+RESTRICT=test # requires network access
+
+RDEPEND=">=dev-haskell/aeson-1.0:=[profile?]
+ dev-haskell/auto-update:=[profile?]
+ >=dev-haskell/blaze-html-0.5:=[profile?]
+ >=dev-haskell/blaze-markup-0.7.1:=[profile?]
+ >=dev-haskell/case-insensitive-0.2:=[profile?]
+ >=dev-haskell/cereal-0.3:=[profile?]
+ >=dev-haskell/clientsession-0.9.1:=[profile?] <dev-haskell/clientsession-0.10:=[profile?]
+ >=dev-haskell/conduit-1.3:=[profile?]
+ dev-haskell/conduit-extra:=[profile?]
+ >=dev-haskell/cookie-0.4.3:=[profile?] <dev-haskell/cookie-0.5:=[profile?]
+ dev-haskell/entropy:=[profile?]
+ >=dev-haskell/fast-logger-2.2:=[profile?]
+ >=dev-haskell/http-types-0.7:=[profile?]
+ dev-haskell/memory:=[profile?]
+ >=dev-haskell/monad-logger-0.3.10:=[profile?] <dev-haskell/monad-logger-0.4:=[profile?]
+ >=dev-haskell/path-pieces-0.1.2:=[profile?] <dev-haskell/path-pieces-0.3:=[profile?]
+ >=dev-haskell/primitive-0.6:=[profile?]
+ >=dev-haskell/random-1.0.0.2:=[profile?] <dev-haskell/random-1.3:=[profile?]
+ >=dev-haskell/resourcet-1.2:=[profile?]
+ >=dev-haskell/shakespeare-2.0:=[profile?]
+ dev-haskell/unix-compat:=[profile?]
+ dev-haskell/unliftio:=[profile?]
+ >=dev-haskell/unordered-containers-0.2:=[profile?]
+ >=dev-haskell/vector-0.9:=[profile?] <dev-haskell/vector-0.13:=[profile?]
+ >=dev-haskell/wai-3.2:=[profile?]
+ >=dev-haskell/wai-extra-3.0.7:=[profile?]
+ >=dev-haskell/wai-logger-0.2:=[profile?]
+ >=dev-haskell/warp-3.0.2:=[profile?]
+ dev-haskell/word8:=[profile?]
+ >=dev-lang/ghc-8.4.3:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2.0.1
+ test? ( dev-haskell/async
+ >=dev-haskell/hspec-1.3
+ dev-haskell/hspec-expectations
+ dev-haskell/hunit
+ dev-haskell/network
+ dev-haskell/streaming-commons )
+"