summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOz Tiram <oz.tiram@gmail.com>2022-12-01 10:40:38 +0100
committerSam James <sam@gentoo.org>2022-12-03 01:04:15 +0000
commitf3fe2093ca6a3c24bf319eaa90c46dadf4a50818 (patch)
tree951aa1157851291fc2c628add5ce58d50425e201
parentapp-editors/pluma-plugins: new package, add 1.26.0 (diff)
downloadgentoo-f3fe2093ca6a3c24bf319eaa90c46dadf4a50818.tar.gz
gentoo-f3fe2093ca6a3c24bf319eaa90c46dadf4a50818.tar.bz2
gentoo-f3fe2093ca6a3c24bf319eaa90c46dadf4a50818.zip
dev-python/python-caja: add 1.26.0
Signed-off-by: Oz Tiram <oz.tiram@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-python/python-caja/Manifest1
-rw-r--r--dev-python/python-caja/python-caja-1.26.0.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/dev-python/python-caja/Manifest b/dev-python/python-caja/Manifest
index 7f7de412fe04..45565b674f4f 100644
--- a/dev-python/python-caja/Manifest
+++ b/dev-python/python-caja/Manifest
@@ -1 +1,2 @@
DIST python-caja-1.24.0.tar.xz 312340 BLAKE2B a860cb1cc983221710d93943ac39b9b77761997fa6a52b32dceeeec381ee86d976c56266013d0370a28e7cb26de3601fec42234b4f91c78e5ac54992035e17ee SHA512 9febf7cae1736e30c80218dcfd3cc05b948823b99945ed67c1839ab5149aa3fe05b090d46c598810f0cde8ba66b83426c4642f6ebdbef6067f6b2fbc0798e816
+DIST python-caja-1.26.0.tar.xz 314936 BLAKE2B 1fabd7bafa19051a19643aa9f10180d72062bc485231760439d988936406e07b9e600a80c1c9d45c88a5ac40c0b16e90878c02dba81f722d8a6f60713fe28cc7 SHA512 632b0b4a9fa29bdcde3b84b37820a7e171b59e78972f71c0c3d25d52cad8233ae7d1548e23ed6d3a06734b084532db1c4e85c3beaed15fce88cf8abff5be35d0
diff --git a/dev-python/python-caja/python-caja-1.26.0.ebuild b/dev-python/python-caja/python-caja-1.26.0.ebuild
new file mode 100644
index 000000000000..378681f190a4
--- /dev/null
+++ b/dev-python/python-caja/python-caja-1.26.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MATE_LA_PUNT="yes"
+PYTHON_COMPAT=( python{3_8,3_9,3_10,3_11} )
+
+inherit mate python-single-r1
+
+if [[ ${PV} != 9999 ]]; then
+ KEYWORDS="~amd64 ~arm ~x86"
+fi
+
+DESCRIPTION="Python bindings for the Caja file manager"
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="doc"
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+COMMON_DEPEND="${PYTHON_DEPS}
+ >=dev-libs/glib-2.50:2
+ $( python_gen_cond_dep 'dev-python/pygobject:3[${PYTHON_USEDEP}]' )
+ >=mate-base/caja-1.17.1[introspection]
+ >=x11-libs/gtk+-3.22:3
+"
+
+RDEPEND="${COMMON_DEPEND}"
+
+BDEPEND="${COMMON_DEPEND}
+ dev-util/gtk-doc
+ dev-util/gtk-doc-am
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ doc? ( app-text/docbook-xml-dtd:4.1.2 )
+"
+
+src_prepare() {
+ MATE_FORCE_AUTORECONF="true"
+
+ sed -i "s/\$(PACKAGE)/${PF}/g" examples/Makefile.am || die
+ mate_src_prepare
+}
+
+src_install() {
+ mate_src_install
+
+ # Keep the directory for systemwide extensions.
+ keepdir /usr/share/caja-python/extensions/
+
+ # The HTML documentation generation is broken and commented out by upstream.
+ #
+ #if use doc ; then
+ # insinto /usr/share/gtk-doc/html/nautilus-python # for dev-util/devhelp
+ # doins -r docs/html/*
+ #fi
+}