summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-07-04 10:52:29 +0200
committerLars Wendler <polynomial-c@gentoo.org>2018-07-04 10:52:29 +0200
commitf42813d4e2d519c368462fcdefd2dfe4e982ebb6 (patch)
tree427392e2ae0dcfabc00b2649c82139fd8dbc5285
parentwww-client/seamonkey: Bump to version 2.49.9.0_p0 (diff)
downloadgentoo-f42813d4.tar.gz
gentoo-f42813d4.tar.bz2
gentoo-f42813d4.zip
media-libs/harfbuzz: Bump to version 1.8.2
Package-Manager: Portage-2.3.41, Repoman-2.3.9
-rw-r--r--media-libs/harfbuzz/Manifest1
-rw-r--r--media-libs/harfbuzz/harfbuzz-1.8.2.ebuild109
2 files changed, 110 insertions, 0 deletions
diff --git a/media-libs/harfbuzz/Manifest b/media-libs/harfbuzz/Manifest
index bcf10c7e48de..1d5f560ffa03 100644
--- a/media-libs/harfbuzz/Manifest
+++ b/media-libs/harfbuzz/Manifest
@@ -2,3 +2,4 @@ DIST harfbuzz-1.7.2.tar.bz2 1708416 BLAKE2B d182bdfa163e07ff41bf36e30373470bf0dd
DIST harfbuzz-1.7.6.tar.bz2 2586909 BLAKE2B 0ae5902b9fe00a4f05a5dc407d698195920454efff79be10f1d85af5430d8bde7df071ba226b978c860d1dd8778a8259f330ab633a1aaa416a4451888fa9ae6a SHA512 259656574b1ec2916ada951b759a591f45c11c5c639fa29831e06320312bf951f4f5ef6306f9ffc373abf0d40dbf944db918d4c54aca3bd7eab2c3a886db7a68
DIST harfbuzz-1.8.0.tar.bz2 3793974 BLAKE2B d6f6a58e1fe2778f5007e73abc90ccd5bed3b170f27ef1a656fcad824a410b2f4d7f560ce01e5dc87ad97dea0bc926c7d49f2c9e87fec5b7c84cac6be4373afc SHA512 90cccdaa45bbd7b5a75c9600d49e15dea820f0db4f9e4eda2c451092000281657a2ecb281b574d339e84e72842e978f5cbf505845fa573e6b76382192d8dd4fb
DIST harfbuzz-1.8.1.tar.bz2 3804867 BLAKE2B 9687b35bbdb74a42c28764a7b026a46ff90640b84bc40702bdbfadc79bbe3c393de837d4cdbbb8798f28aa8c75687c4f07e1c79e98bf9bd506403d89b4baf6a5 SHA512 7ef27232b294883b0c7404c8412837acfba95f12677f226d764f87e22cd169fe037e7bf13a9309e78c9aa905225fb332b3a143a01b13308b05fcccaeddb0c931
+DIST harfbuzz-1.8.2.tar.bz2 3820498 BLAKE2B 7ed1509a7b54571e14d72fa097d19a56e27b3c0020243e51315ff783910319486e6c1af7cec88060c17ccf5788ff1b09f26ee4dbc879b009c983ede767e00316 SHA512 c88a3e9e55866608647318a1af7c5d848863cd894d635583b8a2d2a7a02eea875b7a5a4f0f38555d80f2e81628743e40710f5e6f9251bf629f1d15ac51103e5a
diff --git a/media-libs/harfbuzz/harfbuzz-1.8.2.ebuild b/media-libs/harfbuzz/harfbuzz-1.8.2.ebuild
new file mode 100644
index 000000000000..c723137a7e55
--- /dev/null
+++ b/media-libs/harfbuzz/harfbuzz-1.8.2.ebuild
@@ -0,0 +1,109 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit flag-o-matic libtool multilib-minimal python-any-r1 xdg-utils
+
+DESCRIPTION="An OpenType text shaping engine"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/HarfBuzz"
+
+if [[ ${PV} = 9999 ]] ; then
+ EGIT_REPO_URI="https://anongit.freedesktop.org/git/harfbuzz.git"
+ inherit git-r3 autotools
+else
+ SRC_URI="https://www.freedesktop.org/software/${PN}/release/${P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~x64-macos ~x86-macos ~x64-solaris"
+fi
+
+LICENSE="Old-MIT ISC icu"
+SLOT="0/0.9.18" # 0.9.18 introduced the harfbuzz-icu split; bug #472416
+
+IUSE="+cairo debug fontconfig +glib +graphite icu +introspection static-libs test +truetype"
+REQUIRED_USE="introspection? ( glib )"
+
+RDEPEND="
+ cairo? ( x11-libs/cairo:= )
+ fontconfig? ( media-libs/fontconfig:1.0[${MULTILIB_USEDEP}] )
+ glib? ( >=dev-libs/glib-2.38:2[${MULTILIB_USEDEP}] )
+ graphite? ( >=media-gfx/graphite2-1.2.1:=[${MULTILIB_USEDEP}] )
+ icu? ( >=dev-libs/icu-51.2-r1:=[${MULTILIB_USEDEP}] )
+ introspection? ( >=dev-libs/gobject-introspection-1.34:= )
+ truetype? ( >=media-libs/freetype-2.5.0.1:2=[${MULTILIB_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+ dev-util/gtk-doc-am
+ virtual/pkgconfig
+ test? ( ${PYTHON_DEPS} )
+"
+# eautoreconf requires gobject-introspection-common
+# ragel needed if regenerating *.hh files from *.rl
+if [[ ${PV} = 9999 ]] ; then
+ DEPEND+="
+ >=dev-libs/gobject-introspection-common-1.34
+ dev-util/ragel
+ "
+fi
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+ if ! use debug ; then
+ append-cppflags -DHB_NDEBUG
+ fi
+}
+
+src_prepare() {
+ default
+
+ xdg_environment_reset
+
+ if [[ ${CHOST} == *-darwin* || ${CHOST} == *-solaris* ]] ; then
+ # on Darwin/Solaris we need to link with g++, like automake defaults
+ # to, but overridden by upstream because on Linux this is not
+ # necessary, bug #449126
+ sed -i \
+ -e 's/\<LINK\>/CXXLINK/' \
+ src/Makefile.am || die
+ sed -i \
+ -e '/libharfbuzz_la_LINK = /s/\<LINK\>/CXXLINK/' \
+ src/Makefile.in || die
+ sed -i \
+ -e '/AM_V_CCLD/s/\<LINK\>/CXXLINK/' \
+ test/api/Makefile.in || die
+ fi
+
+ [[ ${PV} == 9999 ]] && eautoreconf
+ elibtoolize # for Solaris
+
+ # bug 618772
+ append-cxxflags -std=c++14
+}
+
+multilib_src_configure() {
+ # harfbuzz-gobject only used for instrospection, bug #535852
+ local myeconfargs=(
+ --without-coretext
+ --without-uniscribe
+ $(use_enable static-libs static)
+ $(multilib_native_use_with cairo)
+ $(use_with fontconfig)
+ $(use_with glib)
+ $(use_with introspection gobject)
+ $(use_with graphite graphite2)
+ $(use_with icu)
+ $(multilib_native_use_enable introspection)
+ $(use_with truetype freetype)
+ )
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+
+ if multilib_is_native_abi; then
+ ln -s "${S}"/docs/html docs/html || die
+ fi
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ find "${ED}" -name "*.la" -delete || die
+}