summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2023-05-07 14:37:03 +0200
committerPacho Ramos <pacho@gentoo.org>2023-05-07 14:38:34 +0200
commitf436be32835d022495ef58fc4a2d7e3b0906ecb6 (patch)
tree58547566b2065f81b433554797b806182e6e258e
parentnet-analyzer/speedtest-cli: switch to json serverlist (diff)
downloadgentoo-f436be32835d022495ef58fc4a2d7e3b0906ecb6.tar.gz
gentoo-f436be32835d022495ef58fc4a2d7e3b0906ecb6.tar.bz2
gentoo-f436be32835d022495ef58fc4a2d7e3b0906ecb6.zip
x11-wm/mutter: Apply important fixes from upstream
One fixes drag&drop with QT apps and the other makes RDP desktop sharing usable again. Signed-off-by: Pacho Ramos <pacho@gentoo.org>
-rw-r--r--x11-wm/mutter/files/mutter-44.1-frame-updates.patch158
-rw-r--r--x11-wm/mutter/files/mutter-44.1-xdnd-frame-window.patch50
-rw-r--r--x11-wm/mutter/mutter-44.1-r1.ebuild240
3 files changed, 448 insertions, 0 deletions
diff --git a/x11-wm/mutter/files/mutter-44.1-frame-updates.patch b/x11-wm/mutter/files/mutter-44.1-frame-updates.patch
new file mode 100644
index 000000000000..bc6f5411204b
--- /dev/null
+++ b/x11-wm/mutter/files/mutter-44.1-frame-updates.patch
@@ -0,0 +1,158 @@
+From 82bd40dcbcc3601da755678778f033bd9a30286d Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Jonas=20=C3=85dahl?= <jadahl@gmail.com>
+Date: Thu, 4 May 2023 12:31:41 +0200
+Subject: [PATCH] screen-cast/src: Never dequeue pw_buffer's we refuse to
+ record to
+
+The DMA buffer paths vs MemFd paths differ slightly in when content is
+recorded. This was in some places done by trying to record but bail if
+the dequeued buffer had the wrong type. This is problematic for two
+reasons: we'd update the timestamp even if we refused to record, making
+the follow-up attempt fail, and we'd dequeue and queue buffers that
+didn't get any content, meaning the receiving end would see empty
+buffers potentially with only cursor updates.
+
+Fix this by keeping track if a stream is DMA buffer able or not, and
+don't attempt to record at all in the places we would previously require
+DMA buffers. This avoids both issues: we don't dequeue/queue pw_buffers
+that we refuse to record to, and we won't update the recorded timestamp
+when we didn't intend to record to begin with.
+
+Closes: https://gitlab.gnome.org/GNOME/mutter/-/issues/2783
+Part-of: <https://gitlab.gnome.org/GNOME/mutter/-/merge_requests/2987>
+---
+ .../meta-screen-cast-monitor-stream-src.c | 25 ++++++++++++-------
+ src/backends/meta-screen-cast-stream-src.c | 22 ++++++++++------
+ src/backends/meta-screen-cast-stream-src.h | 3 ++-
+ 3 files changed, 32 insertions(+), 18 deletions(-)
+
+diff --git a/src/backends/meta-screen-cast-monitor-stream-src.c b/src/backends/meta-screen-cast-monitor-stream-src.c
+index efb458067e..073a4d101f 100644
+--- a/src/backends/meta-screen-cast-monitor-stream-src.c
++++ b/src/backends/meta-screen-cast-monitor-stream-src.c
+@@ -158,8 +158,8 @@ stage_painted (MetaStage *stage,
+ MetaScreenCastMonitorStreamSrc *monitor_src =
+ META_SCREEN_CAST_MONITOR_STREAM_SRC (user_data);
+ MetaScreenCastStreamSrc *src = META_SCREEN_CAST_STREAM_SRC (monitor_src);
+- MetaScreenCastRecordResult record_result;
+- MetaScreenCastRecordFlag flags;
++ MetaScreenCastRecordResult record_result =
++ META_SCREEN_CAST_RECORD_RESULT_RECORDED_NOTHING;
+ int64_t presentation_time_us;
+
+ if (monitor_src->maybe_record_idle_id)
+@@ -168,12 +168,16 @@ stage_painted (MetaStage *stage,
+ if (!clutter_frame_get_target_presentation_time (frame, &presentation_time_us))
+ presentation_time_us = g_get_monotonic_time ();
+
+- flags = META_SCREEN_CAST_RECORD_FLAG_DMABUF_ONLY;
+- record_result =
+- meta_screen_cast_stream_src_maybe_record_frame_with_timestamp (src,
+- flags,
+- NULL,
+- presentation_time_us);
++ if (meta_screen_cast_stream_src_uses_dma_bufs (src))
++ {
++ MetaScreenCastRecordFlag flags = META_SCREEN_CAST_RECORD_FLAG_NONE;
++
++ record_result =
++ meta_screen_cast_stream_src_maybe_record_frame_with_timestamp (src,
++ flags,
++ NULL,
++ presentation_time_us);
++ }
+
+ if (!(record_result & META_SCREEN_CAST_RECORD_RESULT_RECORDED_FRAME))
+ {
+@@ -200,13 +204,16 @@ before_stage_painted (MetaStage *stage,
+ if (monitor_src->maybe_record_idle_id)
+ return;
+
++ if (!meta_screen_cast_stream_src_uses_dma_bufs (src))
++ return;
++
+ if (!clutter_stage_view_peek_scanout (view))
+ return;
+
+ if (!clutter_frame_get_target_presentation_time (frame, &presentation_time_us))
+ presentation_time_us = g_get_monotonic_time ();
+
+- flags = META_SCREEN_CAST_RECORD_FLAG_DMABUF_ONLY;
++ flags = META_SCREEN_CAST_RECORD_FLAG_NONE;
+ meta_screen_cast_stream_src_maybe_record_frame_with_timestamp (src,
+ flags,
+ NULL,
+diff --git a/src/backends/meta-screen-cast-stream-src.c b/src/backends/meta-screen-cast-stream-src.c
+index 91a8afab47..94fc222e43 100644
+--- a/src/backends/meta-screen-cast-stream-src.c
++++ b/src/backends/meta-screen-cast-stream-src.c
+@@ -107,6 +107,7 @@ typedef struct _MetaScreenCastStreamSrcPrivate
+ int64_t last_frame_timestamp_us;
+ guint follow_up_frame_source_id;
+
++ gboolean uses_dma_bufs;
+ GHashTable *dmabuf_handles;
+
+ cairo_region_t *redraw_clip;
+@@ -513,15 +514,9 @@ do_record_frame (MetaScreenCastStreamSrc *src,
+ {
+ MetaScreenCastStreamSrcPrivate *priv =
+ meta_screen_cast_stream_src_get_instance_private (src);
+- gboolean dmabuf_only;
+
+- dmabuf_only = flags & META_SCREEN_CAST_RECORD_FLAG_DMABUF_ONLY;
+- if (dmabuf_only && spa_buffer->datas[0].type != SPA_DATA_DmaBuf)
+- return FALSE;
+-
+- if (!dmabuf_only &&
+- (spa_buffer->datas[0].data ||
+- spa_buffer->datas[0].type == SPA_DATA_MemFd))
++ if (spa_buffer->datas[0].data ||
++ spa_buffer->datas[0].type == SPA_DATA_MemFd)
+ {
+ int width = priv->video_format.size.width;
+ int height = priv->video_format.size.height;
+@@ -1058,6 +1053,8 @@ on_stream_add_buffer (void *data,
+ dmabuf_handle = NULL;
+ }
+
++ priv->uses_dma_bufs = !!dmabuf_handle;
++
+ if (dmabuf_handle)
+ {
+ meta_topic (META_DEBUG_SCREEN_CAST,
+@@ -1595,3 +1592,12 @@ meta_screen_cast_stream_src_class_init (MetaScreenCastStreamSrcClass *klass)
+ NULL, NULL, NULL,
+ G_TYPE_NONE, 0);
+ }
++
++gboolean
++meta_screen_cast_stream_src_uses_dma_bufs (MetaScreenCastStreamSrc *src)
++{
++ MetaScreenCastStreamSrcPrivate *priv =
++ meta_screen_cast_stream_src_get_instance_private (src);
++
++ return priv->uses_dma_bufs;
++}
+diff --git a/src/backends/meta-screen-cast-stream-src.h b/src/backends/meta-screen-cast-stream-src.h
+index 63058f2c35..a15ca54f15 100644
+--- a/src/backends/meta-screen-cast-stream-src.h
++++ b/src/backends/meta-screen-cast-stream-src.h
+@@ -41,7 +41,6 @@ typedef enum _MetaScreenCastRecordFlag
+ {
+ META_SCREEN_CAST_RECORD_FLAG_NONE = 0,
+ META_SCREEN_CAST_RECORD_FLAG_CURSOR_ONLY = 1 << 0,
+- META_SCREEN_CAST_RECORD_FLAG_DMABUF_ONLY = 1 << 1,
+ } MetaScreenCastRecordFlag;
+
+ typedef enum _MetaScreenCastRecordResult
+@@ -132,4 +131,6 @@ void meta_screen_cast_stream_src_set_cursor_sprite_metadata (MetaScreenCastStrea
+ float scale,
+ MetaMonitorTransform transform);
+
++gboolean meta_screen_cast_stream_src_uses_dma_bufs (MetaScreenCastStreamSrc *src);
++
+ #endif /* META_SCREEN_CAST_STREAM_SRC_H */
+--
+GitLab
+
diff --git a/x11-wm/mutter/files/mutter-44.1-xdnd-frame-window.patch b/x11-wm/mutter/files/mutter-44.1-xdnd-frame-window.patch
new file mode 100644
index 000000000000..4067e31ef277
--- /dev/null
+++ b/x11-wm/mutter/files/mutter-44.1-xdnd-frame-window.patch
@@ -0,0 +1,50 @@
+From f21cc690527010918d10638cfc7747df3eede496 Mon Sep 17 00:00:00 2001
+From: Sebastian Keller <skeller@gnome.org>
+Date: Fri, 28 Apr 2023 12:20:11 +0200
+Subject: [PATCH] frames: Disable XDND support on the frame window
+
+All X11 surfaces created by gtk4 claim to support XDND via the XdndAware
+property. This was leading some clients, e.g. Qt, to consider the frame
+window as drop target instead of the client window.
+
+Avoid this issue by removing the XdndAware property again after gtk has
+created the surface.
+
+Closes: https://gitlab.gnome.org/GNOME/mutter/-/issues/2715
+Part-of: <https://gitlab.gnome.org/GNOME/mutter/-/merge_requests/2978>
+
+
+(cherry picked from commit d643eb5c6fe50e7f1afffda0e8747a87f668a799)
+---
+ src/frames/meta-frame.c | 8 ++++++++
+ 1 file changed, 8 insertions(+)
+
+diff --git a/src/frames/meta-frame.c b/src/frames/meta-frame.c
+index be685c51fc..345751ad14 100644
+--- a/src/frames/meta-frame.c
++++ b/src/frames/meta-frame.c
+@@ -504,6 +504,7 @@ frame_sync_wm_state (MetaFrame *frame,
+ GtkWidget *
+ meta_frame_new (Window window)
+ {
++ GdkDisplay *display;
+ GtkWidget *frame, *header, *content;
+ GdkSurface *surface;
+ int frame_height = 0;
+@@ -549,6 +550,13 @@ meta_frame_new (Window window)
+ frame_sync_motif_wm_hints (GTK_WINDOW (frame), window);
+ frame_sync_wm_normal_hints (GTK_WINDOW (frame), window);
+
++ /* Disable XDND support on the frame window, because it can cause some clients
++ * to try use it instead of the client window as drop target */
++ display = gtk_widget_get_display (GTK_WIDGET (frame));
++ XDeleteProperty (gdk_x11_display_get_xdisplay (display),
++ gdk_x11_surface_get_xid (surface),
++ gdk_x11_get_xatom_by_name_for_display (display, "XdndAware"));
++
+ return frame;
+ }
+
+--
+GitLab
+
diff --git a/x11-wm/mutter/mutter-44.1-r1.ebuild b/x11-wm/mutter/mutter-44.1-r1.ebuild
new file mode 100644
index 000000000000..8f0ee64bf0e6
--- /dev/null
+++ b/x11-wm/mutter/mutter-44.1-r1.ebuild
@@ -0,0 +1,240 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{9..11} )
+inherit gnome.org gnome2-utils meson python-any-r1 udev xdg
+
+DESCRIPTION="GNOME compositing window manager based on Clutter"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/mutter/"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.gnome.org/GNOME/mutter.git"
+ SRC_URI=""
+else
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+fi
+
+LICENSE="GPL-2+"
+SLOT="0/$(($(ver_cut 1) - 32))" # 0/libmutter_api_version - ONLY gnome-shell (or anything using mutter-clutter-<api_version>.pc) should use the subslot
+
+IUSE="debug elogind gnome gtk-doc input_devices_wacom +introspection screencast sysprof systemd test udev wayland video_cards_nvidia"
+# native backend requires gles3 for hybrid graphics blitting support, udev and a logind provider
+REQUIRED_USE="
+ gtk-doc? ( introspection )
+ wayland? ( ^^ ( elogind systemd ) udev )
+ test? ( wayland )"
+RESTRICT="!test? ( test )"
+
+# gnome-settings-daemon is build checked, but used at runtime only for org.gnome.settings-daemon.peripherals.keyboard gschema
+# xorg-server is needed at build and runtime with USE=wayland for Xwayland
+# v3.32.2 has many excessive or unused *_req variables declared, thus currently the dep order ignores those and goes via dependency() call order
+DEPEND="
+ >=media-libs/graphene-1.10.2[introspection?]
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/pango-1.46[introspection?]
+ >=x11-libs/cairo-1.14[X]
+ >=dev-libs/fribidi-1.0.0
+ >=gnome-base/gsettings-desktop-schemas-42.0[introspection?]
+ >=dev-libs/glib-2.75.1:2
+ gnome-base/gnome-settings-daemon
+ >=dev-libs/json-glib-0.12.0[introspection?]
+ >=x11-libs/libxkbcommon-0.4.3
+ x11-libs/libICE
+ >=app-accessibility/at-spi2-core-2.46:2[introspection?]
+ sys-apps/dbus
+ >=x11-misc/colord-1.4.5:=
+ >=media-libs/lcms-2.6:2
+ >=media-libs/harfbuzz-2.6.0:=
+
+ gnome? ( gnome-base/gnome-desktop:4= )
+
+ >=media-libs/libcanberra-0.26
+
+ media-libs/libglvnd[X]
+
+ wayland? (
+ >=dev-libs/wayland-protocols-1.31
+ >=dev-libs/wayland-1.21.0
+
+ x11-libs/libdrm
+ media-libs/mesa[gbm(+)]
+ >=dev-libs/libinput-1.18.0:=
+
+ elogind? ( sys-auth/elogind )
+ x11-base/xwayland
+ video_cards_nvidia? ( gui-libs/egl-wayland )
+ )
+ udev? (
+ >=virtual/libudev-232-r1:=
+ >=dev-libs/libgudev-232
+ )
+ systemd? ( sys-apps/systemd )
+ x11-libs/libSM
+ input_devices_wacom? ( >=dev-libs/libwacom-0.13:= )
+ >=x11-libs/startup-notification-0.7
+ screencast? ( >=media-video/pipewire-0.3.21:= )
+ introspection? ( >=dev-libs/gobject-introspection-1.54:= )
+ test? ( >=x11-libs/gtk+-3.19.8:3[X,introspection?] )
+ sysprof? ( >=dev-util/sysprof-capture-3.40.1:4 >=dev-util/sysprof-3.46.0 )
+"
+# for now upstream has "have_x11 = true" in the meson.build, but sooner or later upstream is going to make X optional.
+# X? (
+DEPEND+="
+ >=gui-libs/gtk-4.0.0:4[X,introspection?]
+ >=x11-libs/libX11-1.7.0
+ >=x11-libs/libXcomposite-0.4
+ x11-libs/libXcursor
+ x11-libs/libXdamage
+ x11-libs/libXext
+ >=x11-libs/libXfixes-3
+ >=x11-libs/libXi-1.7.4
+ x11-libs/libXtst
+ x11-libs/libxkbfile
+ x11-misc/xkeyboard-config
+ >=x11-libs/libxkbcommon-0.4.3[X]
+ x11-libs/libXrender
+ >=x11-libs/libXrandr-1.5.0
+ x11-libs/libxcb:=
+ x11-libs/libXinerama
+ x11-libs/libXau
+"
+# )"
+
+RDEPEND="${DEPEND}
+ gnome-extra/zenity
+
+ !<gui-libs/gtk-4.6.4:4
+"
+DEPEND="${DEPEND}
+ x11-base/xorg-proto
+ sysprof? ( >=dev-util/sysprof-common-3.38.0 )
+"
+BDEPEND="
+ dev-util/wayland-scanner
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ gtk-doc? ( >=dev-util/gi-docgen-2021.1 )
+ test? (
+ ${PYTHON_DEPS}
+ $(python_gen_any_dep '
+ >=dev-python/python-dbusmock-0.28[${PYTHON_USEDEP}]
+ ')
+ app-text/docbook-xml-dtd:4.5
+ x11-misc/xvfb-run
+ )
+ wayland? (
+ >=sys-kernel/linux-headers-4.4
+ x11-libs/libxcvt
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-43.0-Disable-anonymous-file-test.patch
+
+ # Fixes from 'master'
+ # Fix drag&drop in QT apps
+ "${FILESDIR}"/${P}-xdnd-frame-window.patch
+ # Fix frames dropping on screencast
+ "${FILESDIR}"/${P}-frame-updates.patch
+)
+
+python_check_deps() {
+ if use test; then
+ python_has_version ">=dev-python/python-dbusmock-0.28[${PYTHON_USEDEP}]"
+ fi
+}
+
+src_prepare() {
+ default
+
+ sed -i -e "s:#!/usr/bin/bash:#!$(command -v bash):" src/tests/x11-test.sh || die
+}
+
+src_configure() {
+ local emesonargs=(
+ # Mutter X11 renderer only supports gles2 and GLX, thus do NOT pass
+ #
+ # -Dopengl_libname=libOpenGL.so.0
+ #
+ # while we build the x11 renderer, as we currently enable gles2 only
+ # with USE=wayland and x11 renderer wouldn't find the needed GLX symbols
+ # in a configuration where wayland is disabled, as libOpenGL doesn't
+ # include them.
+ #
+ # See
+ # - https://bugs.gentoo.org/835786
+ # - https://forums.gentoo.org/viewtopic-p-8695669.html
+
+ --buildtype $(usex debug debug plain)
+ -Dopengl=true
+ $(meson_use wayland gles2)
+ #gles2_libname
+ -Degl=true
+ -Dglx=true
+ $(meson_use wayland)
+ $(meson_use wayland xwayland)
+ $(meson_use systemd)
+ $(meson_use wayland native_backend)
+ $(meson_use screencast remote_desktop)
+ $(meson_use gnome libgnome_desktop)
+ $(meson_use udev)
+ -Dudev_dir=$(get_udevdir)
+ $(meson_use input_devices_wacom libwacom)
+ -Dsound_player=true
+ -Dpango_ft2=true
+ -Dstartup_notification=true
+ -Dsm=true
+ $(meson_use introspection)
+ $(meson_use gtk-doc docs)
+ $(meson_use test cogl_tests)
+ $(meson_use wayland core_tests) # core tests require wayland; overall -Dtests option is honored on top, so no extra conditional needed
+ -Dnative_tests=false
+ $(meson_use test clutter_tests)
+ $(meson_use test tests)
+ -Dkvm_tests=false
+ -Dtty_tests=false
+ $(meson_use sysprof profiler)
+ -Dinstalled_tests=false
+
+ #verbose # Let upstream choose default for verbose mode
+ #xwayland_path
+ # TODO: relies on default settings, but in Gentoo we might have some more packages we want to give Xgrab access (mostly virtual managers and remote desktops)
+ #xwayland_grab_default_access_rules
+ )
+
+ if use wayland && use video_cards_nvidia; then
+ emesonargs+=(
+ -Degl_device=true
+ -Dwayland_eglstream=true
+ )
+ else
+ emesonargs+=(
+ -Degl_device=false
+ -Dwayland_eglstream=false
+ )
+ fi
+
+ meson_src_configure
+}
+
+src_test() {
+ gnome2_environment_reset # Avoid dconf that looks at XDG_DATA_DIRS, which can sandbox fail if flatpak is installed
+ glib-compile-schemas "${BUILD_DIR}"/data
+ GSETTINGS_SCHEMA_DIR="${BUILD_DIR}"/data meson_src_test --setup=CI
+}
+
+pkg_postinst() {
+ use udev && udev_reload
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ use udev && udev_reload
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}