summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-01-24 07:19:57 +0100
committerMichał Górny <mgorny@gentoo.org>2023-01-24 09:52:28 +0100
commitf438192f95114ddbcb9ed1e2e84734d218349b2c (patch)
treefc0f7bd45e994accaca684230894f04ea5b9eda2
parentapp-emulation/virtualbox: Fix built-in help path (diff)
downloadgentoo-f438192f95114ddbcb9ed1e2e84734d218349b2c.tar.gz
gentoo-f438192f95114ddbcb9ed1e2e84734d218349b2c.tar.bz2
gentoo-f438192f95114ddbcb9ed1e2e84734d218349b2c.zip
dev-python/moto: Bump to 4.1.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/moto/Manifest1
-rw-r--r--dev-python/moto/moto-4.1.1.ebuild96
2 files changed, 97 insertions, 0 deletions
diff --git a/dev-python/moto/Manifest b/dev-python/moto/Manifest
index 90db06d9bc01..29e4a969d13c 100644
--- a/dev-python/moto/Manifest
+++ b/dev-python/moto/Manifest
@@ -1,3 +1,4 @@
DIST moto-4.0.12.tar.gz 2559220 BLAKE2B 475097f498bc648d6a29db36343135372f0881069ee02b21f0361df0215e852c344edfb7661154c150da88c4de86f832765169dfa9bc159213f15599a21ea0cb SHA512 ea404e603450791956cca9701825afad523ee99358597a3c627af2fda8732c2bbcca41f5d0fe67130a06a225f1ced35a9d35fa520130ff311120c8d6d5863a0a
DIST moto-4.0.13.tar.gz 2563514 BLAKE2B 1d2f01ff0af7c1ab4bc8670015eeefddf70970aa321ca641989ef740bf3f896bacfeaf8b16cdf37b7fedecafa8d81cc3d66473315f867fcbd6143a7d010d9aba SHA512 1c5a6a19a5eccfd70de71ec0aaa7263f8a7ebb16f9576eb78d72b0a3f0dbdaa3e6db1a631ba36d5c1b04f6d8aded6f492cb8792da1e6fd036897a1dfbdca0b56
DIST moto-4.1.0.tar.gz 2561695 BLAKE2B ce95abe8d49bee64d5323988526e251c52cd5ee5df95fc058240336a2eb580bf7eafbef6b594328a4a5ef34d047a293656c8ec9cdbf9c41bf3c7df05fdfb33c5 SHA512 c5b234c7d7057922880ad9ba09bb4e0453ca09d9f2b58ffce1990092e5d5cb070954e9d6cca307730ecb5540509792d0dbb4135289137fc12469354a91f326b8
+DIST moto-4.1.1.tar.gz 2581128 BLAKE2B a4af36e5f87633a8b3f0dcfc5b786d95925dc787acf4b6a7698262637208a1fa0344e734a4a5c8073643e5d92740ee52d3b37f305b1afbf81e3a2f8496b5ecf1 SHA512 1b7ec2cd1a2a7273a22cc8fe3ddf64b9e4447cdf7d4fd966dee1cbde6b95c1a51d1e5870530eee1f19dbdaa196bff5c283a2df08462ab9ffac3b683f789bca25
diff --git a/dev-python/moto/moto-4.1.1.ebuild b/dev-python/moto/moto-4.1.1.ebuild
new file mode 100644
index 000000000000..f33f12783a79
--- /dev/null
+++ b/dev-python/moto/moto-4.1.1.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Mock library for boto"
+HOMEPAGE="
+ https://github.com/getmoto/moto/
+ https://pypi.org/project/moto/
+"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/aws-xray-sdk-python-0.93[${PYTHON_USEDEP}]
+ >=dev-python/cfn-lint-0.40.0[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-3.3.1[${PYTHON_USEDEP}]
+ dev-python/cookies[${PYTHON_USEDEP}]
+ >=dev-python/docker-py-2.5.1[${PYTHON_USEDEP}]
+ >=dev-python/idna-2.5[${PYTHON_USEDEP}]
+ >=dev-python/jinja-2.10.1[${PYTHON_USEDEP}]
+ >=dev-python/jsondiff-1.1.2[${PYTHON_USEDEP}]
+ dev-python/boto3[${PYTHON_USEDEP}]
+ dev-python/botocore[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/flask-cors[${PYTHON_USEDEP}]
+ dev-python/more-itertools[${PYTHON_USEDEP}]
+ >=dev-python/pyparsing-3.0.7[${PYTHON_USEDEP}]
+ >=dev-python/openapi-spec-validator-0.2.8[${PYTHON_USEDEP}]
+ dev-python/pretty-yaml[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.1[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.1[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/python-jose[${PYTHON_USEDEP}]
+ dev-python/python-sshpubkeys[${PYTHON_USEDEP}]
+ >=dev-python/responses-0.9.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.5[${PYTHON_USEDEP}]
+ dev-python/xmltodict[${PYTHON_USEDEP}]
+ dev-python/werkzeug[${PYTHON_USEDEP}]
+ dev-python/zipp[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ >=dev-python/sure-1.4.11[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ tests/test_firehose/test_firehose_put.py::test_put_record_http_destination
+ tests/test_firehose/test_firehose_put.py::test_put_record_batch_http_destination
+ tests/test_swf/responses/test_decision_tasks.py::test_respond_decision_task_completed_with_schedule_activity_task_boto3
+ tests/test_swf/responses/test_timeouts.py::test_activity_task_heartbeat_timeout_boto3
+ tests/test_swf/responses/test_timeouts.py::test_decision_task_start_to_close_timeout_boto3
+ tests/test_swf/responses/test_timeouts.py::test_workflow_execution_start_to_close_timeout_boto3
+ # broken code (local variable used referenced before definition)
+ tests/test_appsync/test_appsync_schema.py
+ tests/test_appsync/test_server.py::test_appsync_list_tags_for_resource
+ # Needs network (or docker?) but not marked as such, bug #807031
+ # TODO: report upstream
+ tests/test_batch/test_batch_jobs.py::test_terminate_job
+ tests/test_batch/test_batch_jobs.py::test_cancel_pending_job
+ tests/test_batch/test_batch_jobs.py::test_cancel_running_job
+ tests/test_batch/test_batch_jobs.py::test_dependencies
+ tests/test_batch/test_batch_jobs.py::test_container_overrides
+ tests/test_cloudformation/test_cloudformation_custom_resources.py::test_create_custom_lambda_resource__verify_cfnresponse_failed
+ tests/test_cloudformation/test_cloudformation_stack_integration.py::test_lambda_function
+ tests/test_events/test_events_lambdatriggers_integration.py::test_creating_bucket__invokes_lambda
+ tests/test_sqs/test_integration.py::test_invoke_function_from_sqs_exception
+ tests/test_sqs/test_sqs_integration.py::test_invoke_function_from_sqs_exception
+ tests/test_s3/test_server.py::test_s3_server_post_to_bucket_redirect
+ tests/test_s3/test_multiple_accounts_server.py::TestAccountIdResolution::test_with_custom_request_header
+ "tests/test_s3/test_s3_lambda_integration.py::test_objectcreated_put__invokes_lambda[match_events0-ObjectCreated:Put]"
+ "tests/test_s3/test_s3_lambda_integration.py::test_objectcreated_put__invokes_lambda[match_events1-ObjectCreated:Put]"
+ "tests/test_s3/test_s3_lambda_integration.py::test_objectcreated_put__invokes_lambda[match_events3-ObjectCreated:Put]"
+ # TODO
+ tests/test_batch/test_batch_jobs.py::test_failed_dependencies
+ tests/test_batch/test_batch_jobs.py::test_failed_job
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -m 'not network'
+}