summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2021-07-09 08:23:57 +0200
committerHans de Graaff <graaff@gentoo.org>2021-07-09 08:55:10 +0200
commitf45035ab09489022fc00f2505ba16a9a408e9590 (patch)
tree204339c93f20e7b79a9edc10b1340db3bfa0eb1f
parentdev-util/cucumber-rails: add ruby27 (diff)
downloadgentoo-f45035ab.tar.gz
gentoo-f45035ab.tar.bz2
gentoo-f45035ab.zip
app-emacs/transient: add 0.3.6
Package-Manager: Portage-3.0.20, Repoman-3.0.2 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
-rw-r--r--app-emacs/transient/Manifest1
-rw-r--r--app-emacs/transient/transient-0.3.6.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/app-emacs/transient/Manifest b/app-emacs/transient/Manifest
index 1e142ee8b8af..738a9ac88dcb 100644
--- a/app-emacs/transient/Manifest
+++ b/app-emacs/transient/Manifest
@@ -1,2 +1,3 @@
DIST transient-0.3.4.tar.gz 100193 BLAKE2B 0dd91cf1af22cfd6c3b6fefaa1b84ba3a241e269aef5165befa9408171f8b5477b04e2886e690cfd8d20af31e83fe669e05f0bf40c3391aab353d33a59345689 SHA512 feb24bf9045c9212a45cbc0a99805bdad6f4f5871279d44c64a883ad5d33a40128189525ee546d6cff14bf2d60d3c1e684cf8894fefc01860e363073eafea220
DIST transient-0.3.5.tar.gz 100274 BLAKE2B ffb7f5823552eb3e84fd1d8c3842c8e49f7ce0fa79fae72ab6088f2af3ef19f27a327a15136f69a9173c742ed4c984d1d7106eda476f3e1a7d751337d19711ad SHA512 cfe30b95022d6f88569f7601cd3994255b613477b3886a42a87ad297edb656ba8968d285cd9b80e98ba18725334cb7b02fac27cb0f9717d344e5af3db8cf77a5
+DIST transient-0.3.6.tar.gz 100905 BLAKE2B cc7a78104b77a7ff49d2ee686a780db7509744b1f737e4f995d5e5f8ada18828ccf1b6ae5d995fb8aa09e9fc16895226e5e8cf3cf50a79c246c5d07d5f467ce0 SHA512 c1b43046f07f9efce1720f6e151d8223922574262d4e5436b0c81453b0a21a404f1c555a5bc92a201c71beb1b2f95aafb38b88203cd08c1d3a9d80f45ed0d0c9
diff --git a/app-emacs/transient/transient-0.3.6.ebuild b/app-emacs/transient/transient-0.3.6.ebuild
new file mode 100644
index 000000000000..5f2eb4af6a92
--- /dev/null
+++ b/app-emacs/transient/transient-0.3.6.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+NEED_EMACS=25
+
+inherit elisp
+
+DESCRIPTION="Use the Emacsclient as the \$EDITOR of child processes"
+HOMEPAGE="https://magit.vc/manual/transient"
+SRC_URI="https://github.com/magit/transient/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+
+SITEFILE="50${PN}-gentoo.el"
+ELISP_TEXINFO="docs/*.texi"
+DOCS="README.md docs/transient.org"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+DEPEND="${DEPEND} sys-apps/texinfo"
+
+src_prepare() {
+ mv lisp/*.el . || die
+
+ default
+}