summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2022-11-08 11:49:03 -0800
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2022-11-08 11:49:03 -0800
commitf4607505c6a057dcc1b308de540f5895d91387b1 (patch)
tree9cefb87b42505010580daa2c033abe45ddd8094c
parentdev-util/cargo-ebuild: drop 0.4.0, 0.5.0, 0.5.1 (diff)
downloadgentoo-f4607505c6a057dcc1b308de540f5895d91387b1.tar.gz
gentoo-f4607505c6a057dcc1b308de540f5895d91387b1.tar.bz2
gentoo-f4607505c6a057dcc1b308de540f5895d91387b1.zip
dev-util/cargo-ebuild: filter out -flto
Closes: https://bugs.gentoo.org/858332 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
-rw-r--r--dev-util/cargo-ebuild/cargo-ebuild-0.5.2.ebuild3
1 files changed, 2 insertions, 1 deletions
diff --git a/dev-util/cargo-ebuild/cargo-ebuild-0.5.2.ebuild b/dev-util/cargo-ebuild/cargo-ebuild-0.5.2.ebuild
index f81bab7773b5..02b3b5bb3de2 100644
--- a/dev-util/cargo-ebuild/cargo-ebuild-0.5.2.ebuild
+++ b/dev-util/cargo-ebuild/cargo-ebuild-0.5.2.ebuild
@@ -142,7 +142,7 @@ CRATES="
winapi-x86_64-pc-windows-gnu-0.4.0
"
-inherit cargo
+inherit cargo flag-o-matic
DESCRIPTION="Generates an ebuild for a package using the in-tree eclasses."
# Double check the homepage as the cargo_metadata crate
@@ -170,6 +170,7 @@ RDEPEND="
QA_FLAGS_IGNORED="usr/bin/cargo-ebuild"
src_configure() {
+ filter-flags '-flto*' # https://bugs.gentoo.org/858332
export LIBGIT2_SYS_USE_PKG_CONFIG=1 LIBSSH2_SYS_USE_PKG_CONFIG=1 PKG_CONFIG_ALLOW_CROSS=1
cargo_src_configure
}