summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRonny (tastytea) Gutbrod <gentoo@tastytea.de>2022-11-23 19:47:15 +0100
committerViorel Munteanu <ceamac@gentoo.org>2022-12-12 09:20:06 +0200
commitf478bb395fc9caf122e9bca7d487ee263440dc57 (patch)
treeebde64a386bfc437e2b1cc49b24a1bb06c5cf8b6
parentapp-emulation/ruffle: sync live (diff)
downloadgentoo-f478bb395fc9caf122e9bca7d487ee263440dc57.tar.gz
gentoo-f478bb395fc9caf122e9bca7d487ee263440dc57.tar.bz2
gentoo-f478bb395fc9caf122e9bca7d487ee263440dc57.zip
www-apps/hugo: add 0.107.0
Signed-off-by: Ronny (tastytea) Gutbrod <gentoo@tastytea.de> Signed-off-by: Viorel Munteanu <ceamac@gentoo.org>
-rw-r--r--www-apps/hugo/Manifest2
-rw-r--r--www-apps/hugo/hugo-0.107.0.ebuild93
2 files changed, 95 insertions, 0 deletions
diff --git a/www-apps/hugo/Manifest b/www-apps/hugo/Manifest
index cf959778cf10..a090761c9b6f 100644
--- a/www-apps/hugo/Manifest
+++ b/www-apps/hugo/Manifest
@@ -3,3 +3,5 @@ DIST hugo-0.104.3-vendor.tar.xz 5785560 BLAKE2B ac96f75bb267cab751e908225654bcf4
DIST hugo-0.104.3.tar.gz 27639976 BLAKE2B a299c7ea5bbdfc819ceba3bbc83646f705f553546fd7c4e18bba26e09f6bc16216cafecabd9e4bdd6f685fe5102394ba205b8d39c873567e8b5bad931062a9c5 SHA512 feb5b610f5c4080c968e5d5f861c4976553d6bcbcca951824f2c14dcf2510e5d9d3a680ef274470d5599f0a270d931b4a4e5dc4c39830226e15c2b2091f8c8f5
DIST hugo-0.105.0-vendor.tar.xz 5727760 BLAKE2B 0295adf688650292531ed250e793ef2914e8eab8cdf60c3aaf4278e26174a63c2bab0fe2ea5e95c6d543a3828c1d500240585e584bd7015e59dc78b42bc09332 SHA512 c2196922f8ac233ee9a2962168fa584aed594d89292dff93ad772f4d2ecef3b2b76f72eff05d0f508e776fabbe18fec108bd64e23ec9e478dbbb3ceb9976e5b2
DIST hugo-0.105.0.tar.gz 27645900 BLAKE2B f9dbbc6d1dd2408736a688e6fb782f03bf1675559562e44cdb002fbf55afc4a56fc111240232ddca2bcbd80438f25ef2dfbebaaeb42ebc46f728399449ae449f SHA512 0cc9011ef30caf469d0e3aceb97ea988e4eb099d1b3e39d67ae9d4809e585025d5ed6e7dce498eb28b757217acc1ac668fcd3d4f625c02e341329def92112be3
+DIST hugo-0.107.0-vendor.tar.xz 5736140 BLAKE2B bca854d21e93b9d6296a6a60d61b800db0be9bdec63e8863f4f96266670ada8ee9e7b072234542c3380b24655c8257c44227c534f65d22b3089608fee3dd78a2 SHA512 0b3fe77d67ad739c8162bd2baff405403a50285ff349826cf5f3b83056f36260288f6efd67f313183e9fd0e27568b2ef6a6e3b3c7ac4d07afc11a179bc80b33c
+DIST hugo-0.107.0.tar.gz 29042775 BLAKE2B c03fd0725b3575471eae54549716897a12f83caea62d4c0561531d940529c4a0fae72f29c3a589ec06087a84003a65f6d4914cb9d704360dab67cd362680134a SHA512 39a2b87e18dd91ac0e423f0009434f76c4228b80511233ee742d22964ff2419954e13745b17f0350f64a557c378942a234ca988ce3add7b2ab9127d66c688919
diff --git a/www-apps/hugo/hugo-0.107.0.ebuild b/www-apps/hugo/hugo-0.107.0.ebuild
new file mode 100644
index 000000000000..129d62e8af01
--- /dev/null
+++ b/www-apps/hugo/hugo-0.107.0.ebuild
@@ -0,0 +1,93 @@
+# Copyright 2018-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module bash-completion-r1
+
+DESCRIPTION="Fast static HTML and CSS website generator"
+HOMEPAGE="https://gohugo.io https://github.com/gohugoio/hugo"
+SRC_URI="
+ https://github.com/gohugoio/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ https://tastytea.de/files/gentoo/${P}-vendor.tar.xz
+"
+
+# NOTE: To create the vendor tarball, run:
+# `go mod vendor && cd .. && tar -caf ${P}-vendor.tar.xz ${P}/vendor`
+
+LICENSE="Apache-2.0 BSD BSD-2 MIT Unlicense"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~loong ~x86"
+IUSE="doc +sass test"
+
+BDEPEND="
+ >=dev-lang/go-1.18
+ test? (
+ dev-python/docutils
+ dev-ruby/asciidoctor
+ virtual/pandoc
+ )
+"
+RDEPEND="
+ >=media-libs/libwebp-1.2.3-r1:=
+ sass? ( dev-libs/libsass:= )
+"
+DEPEND="${RDEPEND}"
+
+RESTRICT="!test? ( test )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.96.0-unbundle-libwebp-and-libsass.patch
+ "${FILESDIR}"/${PN}-0.104.3-skip-some-tests.patch
+ "${FILESDIR}"/${PN}-0.99.1-test-timeout.patch
+)
+
+src_configure() {
+ export CGO_ENABLED=1
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+
+ MY_BUILDFLAGS="$(usev sass "-tags extended")"
+
+ default
+}
+
+src_compile() {
+ mkdir -pv bin || die
+ ego build -ldflags "-X github.com/gohugoio/hugo/common/hugo.vendorInfo=gentoo:${PVR}" \
+ ${MY_BUILDFLAGS} -o "${S}/bin/hugo"
+
+ bin/hugo gen man --dir man || die
+
+ mkdir -pv completions || die
+ bin/hugo completion bash > completions/hugo || die
+ bin/hugo completion fish > completions/hugo.fish || die
+ bin/hugo completion zsh > completions/_hugo || die
+
+ if use doc ; then
+ bin/hugo gen doc --dir doc || die
+ fi
+}
+
+src_test() {
+ ego test -race "./..." ${MY_BUILDFLAGS}
+}
+
+src_install() {
+ dobin bin/*
+ doman man/*
+
+ dobashcomp completions/${PN}
+
+ insinto /usr/share/fish/vendor_completions.d
+ doins completions/${PN}.fish
+
+ insinto /usr/share/zsh/site-functions
+ doins completions/_${PN}
+
+ if use doc ; then
+ dodoc -r doc/*
+ fi
+}