summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiogo Pereira <sir.suriv@gmail.com>2019-01-28 00:41:03 +0000
committerAndreas Sturmlechner <asturm@gentoo.org>2019-02-03 15:07:54 +0100
commitf47abe773d4a432e19357b92129d584dd66f7e60 (patch)
tree1933a3fe7a2bc3fa04db73244cbe717f3bfb4cde
parentmedia-gfx/img2pdf: drop 0.2.4 (diff)
downloadgentoo-f47abe77.tar.gz
gentoo-f47abe77.tar.bz2
gentoo-f47abe77.zip
media-gfx/img2pdf: version bump to 0.3.3
Closes: https://bugs.gentoo.org/675834 Closes: https://bugs.gentoo.org/676100 Signed-off-by: Diogo Pereira <sir.suriv@gmail.com> Package-Manager: Portage-2.3.51, Repoman-2.3.11 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--media-gfx/img2pdf/Manifest1
-rw-r--r--media-gfx/img2pdf/img2pdf-0.3.3.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/media-gfx/img2pdf/Manifest b/media-gfx/img2pdf/Manifest
index fe7314c8992a..84eb6ab00544 100644
--- a/media-gfx/img2pdf/Manifest
+++ b/media-gfx/img2pdf/Manifest
@@ -1 +1,2 @@
DIST img2pdf-0.3.1.tar.gz 67954 BLAKE2B d0d6a9927e9b3e7087e562a108157677a46a17a896beddcc424dd2c234fd7c4f1376b824dbf814b42d9a314a8495b149bc9df65ab2864405b9dde0054e7bafdf SHA512 25f788f78e93ed336ed8e31e88350d89263b82477c8d9c36103dfa522a5e661922fc09b59e1d5104161fe1be15114f843172555efa942722d8b093900d38bae1
+DIST img2pdf-0.3.3.tar.gz 80523 BLAKE2B 39e372f1ab82d9f521cf2c512b173680afe6463dd041283b336af49c41b12d12261fe5947ad9f03d489b7898d3c8d161faedb2b3366cb75bd1bc0666f905f60c SHA512 234e0031d75727d2f5d2b82603bb447d9101ace81e604b6d5eb358d0b4681e209dbd737775b90b44096cf84239aac9e87e2369e0c6112a17f24ccbf10a20cdd5
diff --git a/media-gfx/img2pdf/img2pdf-0.3.3.ebuild b/media-gfx/img2pdf/img2pdf-0.3.3.ebuild
new file mode 100644
index 000000000000..9436b9466ccc
--- /dev/null
+++ b/media-gfx/img2pdf/img2pdf-0.3.3.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Losslessly convert raster images to PDF"
+HOMEPAGE="https://gitlab.mister-muffin.de/josch/img2pdf"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pdfrw[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP},tiff,zlib]
+ )"
+RDEPEND="dev-python/pillow[${PYTHON_USEDEP}]"
+
+python_test() {
+ esetup.py test
+}