summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-02-26 12:31:28 +0100
committerLars Wendler <polynomial-c@gentoo.org>2017-02-26 12:31:43 +0100
commitf49b0e3afee3c713ec88fe461dbf2f10e487403d (patch)
tree7fddffd03b05abb5d428131548a914966d9f7a54
parentnet-analyzer/arpon: EAPI 6, readme.gentoo-r1 eclass (diff)
downloadgentoo-f49b0e3a.tar.gz
gentoo-f49b0e3a.tar.bz2
gentoo-f49b0e3a.zip
dev-vcs/git: gitview has been removed (bug #610946).
Package-Manager: Portage-2.3.3, Repoman-2.3.1
-rw-r--r--dev-vcs/git/git-2.12.0.ebuild16
-rw-r--r--dev-vcs/git/git-9999-r1.ebuild16
-rw-r--r--dev-vcs/git/git-9999-r2.ebuild16
-rw-r--r--dev-vcs/git/git-9999-r3.ebuild16
-rw-r--r--dev-vcs/git/git-9999.ebuild16
5 files changed, 15 insertions, 65 deletions
diff --git a/dev-vcs/git/git-2.12.0.ebuild b/dev-vcs/git/git-2.12.0.ebuild
index a1f5e74e5a89..0be668f04597 100644
--- a/dev-vcs/git/git-2.12.0.ebuild
+++ b/dev-vcs/git/git-2.12.0.ebuild
@@ -43,7 +43,7 @@ fi
LICENSE="GPL-2"
SLOT="0"
-IUSE="+blksha1 +curl cgi doc emacs +gpg gtk highlight +iconv libressl libsecret mediawiki mediawiki-experimental +nls +pcre +perl +python ppcsha1 tk +threads +webdav xinetd cvs subversion test"
+IUSE="+blksha1 +curl cgi doc emacs +gpg highlight +iconv libressl libsecret mediawiki mediawiki-experimental +nls +pcre +perl +python ppcsha1 tk +threads +webdav xinetd cvs subversion test"
# Common to both DEPEND and RDEPEND
CDEPEND="
@@ -75,12 +75,8 @@ RDEPEND="${CDEPEND}
cvs? ( >=dev-vcs/cvsps-2.1:0 dev-perl/DBI dev-perl/DBD-SQLite )
subversion? ( dev-vcs/subversion[-dso,perl] dev-perl/libwww-perl dev-perl/TermReadKey )
)
- python? ( gtk?
- (
- >=dev-python/pygtk-2.8[${PYTHON_USEDEP}]
- >=dev-python/pygtksourceview-2.10.1-r1:2[${PYTHON_USEDEP}]
- )
- ${PYTHON_DEPS} )"
+ python? ( ${PYTHON_DEPS} )
+"
# This is how info docs are created with Git:
# .txt/asciidoc --(asciidoc)---------> .xml/docbook
@@ -112,7 +108,6 @@ REQUIRED_USE="
mediawiki-experimental? ( mediawiki )
subversion? ( perl )
webdav? ( curl )
- gtk? ( python )
python? ( ${PYTHON_REQUIRED_USE} )
"
@@ -423,11 +418,6 @@ src_install() {
elisp-site-file-install "${FILESDIR}"/${SITEFILE}
fi
- if use python && use gtk ; then
- python_doscript "${S}"/contrib/gitview/gitview
- dodoc "${S}"/contrib/gitview/gitview.txt
- fi
-
#dobin contrib/fast-import/git-p4 # Moved upstream
#dodoc contrib/fast-import/git-p4.txt # Moved upstream
newbin contrib/fast-import/import-tars.perl import-tars
diff --git a/dev-vcs/git/git-9999-r1.ebuild b/dev-vcs/git/git-9999-r1.ebuild
index 996fd1fa4be4..6cc2e4ddc3f3 100644
--- a/dev-vcs/git/git-9999-r1.ebuild
+++ b/dev-vcs/git/git-9999-r1.ebuild
@@ -43,7 +43,7 @@ fi
LICENSE="GPL-2"
SLOT="0"
-IUSE="+blksha1 +curl cgi doc emacs +gpg gtk highlight +iconv libressl libsecret mediawiki mediawiki-experimental +nls +pcre +perl +python ppcsha1 tk +threads +webdav xinetd cvs subversion test"
+IUSE="+blksha1 +curl cgi doc emacs +gpg highlight +iconv libressl libsecret mediawiki mediawiki-experimental +nls +pcre +perl +python ppcsha1 tk +threads +webdav xinetd cvs subversion test"
# Common to both DEPEND and RDEPEND
CDEPEND="
@@ -75,12 +75,8 @@ RDEPEND="${CDEPEND}
cvs? ( >=dev-vcs/cvsps-2.1:0 dev-perl/DBI dev-perl/DBD-SQLite )
subversion? ( dev-vcs/subversion[-dso,perl] dev-perl/libwww-perl dev-perl/TermReadKey )
)
- python? ( gtk?
- (
- >=dev-python/pygtk-2.8[${PYTHON_USEDEP}]
- >=dev-python/pygtksourceview-2.10.1-r1:2[${PYTHON_USEDEP}]
- )
- ${PYTHON_DEPS} )"
+ python? ( ${PYTHON_DEPS} )
+"
# This is how info docs are created with Git:
# .txt/asciidoc --(asciidoc)---------> .xml/docbook
@@ -112,7 +108,6 @@ REQUIRED_USE="
mediawiki-experimental? ( mediawiki )
subversion? ( perl )
webdav? ( curl )
- gtk? ( python )
python? ( ${PYTHON_REQUIRED_USE} )
"
@@ -423,11 +418,6 @@ src_install() {
elisp-site-file-install "${FILESDIR}"/${SITEFILE}
fi
- if use python && use gtk ; then
- python_doscript "${S}"/contrib/gitview/gitview
- dodoc "${S}"/contrib/gitview/gitview.txt
- fi
-
#dobin contrib/fast-import/git-p4 # Moved upstream
#dodoc contrib/fast-import/git-p4.txt # Moved upstream
newbin contrib/fast-import/import-tars.perl import-tars
diff --git a/dev-vcs/git/git-9999-r2.ebuild b/dev-vcs/git/git-9999-r2.ebuild
index 1924612f28b9..e9fecdd35ea2 100644
--- a/dev-vcs/git/git-9999-r2.ebuild
+++ b/dev-vcs/git/git-9999-r2.ebuild
@@ -43,7 +43,7 @@ fi
LICENSE="GPL-2"
SLOT="0"
-IUSE="+blksha1 +curl cgi doc emacs +gpg gtk highlight +iconv libressl libsecret mediawiki mediawiki-experimental +nls +pcre +perl +python ppcsha1 tk +threads +webdav xinetd cvs subversion test"
+IUSE="+blksha1 +curl cgi doc emacs +gpg highlight +iconv libressl libsecret mediawiki mediawiki-experimental +nls +pcre +perl +python ppcsha1 tk +threads +webdav xinetd cvs subversion test"
# Common to both DEPEND and RDEPEND
CDEPEND="
@@ -75,12 +75,8 @@ RDEPEND="${CDEPEND}
cvs? ( >=dev-vcs/cvsps-2.1:0 dev-perl/DBI dev-perl/DBD-SQLite )
subversion? ( dev-vcs/subversion[-dso,perl] dev-perl/libwww-perl dev-perl/TermReadKey )
)
- python? ( gtk?
- (
- >=dev-python/pygtk-2.8[${PYTHON_USEDEP}]
- >=dev-python/pygtksourceview-2.10.1-r1:2[${PYTHON_USEDEP}]
- )
- ${PYTHON_DEPS} )"
+ python? ( ${PYTHON_DEPS} )
+"
# This is how info docs are created with Git:
# .txt/asciidoc --(asciidoc)---------> .xml/docbook
@@ -112,7 +108,6 @@ REQUIRED_USE="
mediawiki-experimental? ( mediawiki )
subversion? ( perl )
webdav? ( curl )
- gtk? ( python )
python? ( ${PYTHON_REQUIRED_USE} )
"
@@ -423,11 +418,6 @@ src_install() {
elisp-site-file-install "${FILESDIR}"/${SITEFILE}
fi
- if use python && use gtk ; then
- python_doscript "${S}"/contrib/gitview/gitview
- dodoc "${S}"/contrib/gitview/gitview.txt
- fi
-
#dobin contrib/fast-import/git-p4 # Moved upstream
#dodoc contrib/fast-import/git-p4.txt # Moved upstream
newbin contrib/fast-import/import-tars.perl import-tars
diff --git a/dev-vcs/git/git-9999-r3.ebuild b/dev-vcs/git/git-9999-r3.ebuild
index faa18537adff..ede0b6473744 100644
--- a/dev-vcs/git/git-9999-r3.ebuild
+++ b/dev-vcs/git/git-9999-r3.ebuild
@@ -43,7 +43,7 @@ fi
LICENSE="GPL-2"
SLOT="0"
-IUSE="+blksha1 +curl cgi doc emacs +gpg gtk highlight +iconv libressl libsecret mediawiki mediawiki-experimental +nls +pcre +perl +python ppcsha1 tk +threads +webdav xinetd cvs subversion test"
+IUSE="+blksha1 +curl cgi doc emacs +gpg highlight +iconv libressl libsecret mediawiki mediawiki-experimental +nls +pcre +perl +python ppcsha1 tk +threads +webdav xinetd cvs subversion test"
# Common to both DEPEND and RDEPEND
CDEPEND="
@@ -75,12 +75,8 @@ RDEPEND="${CDEPEND}
cvs? ( >=dev-vcs/cvsps-2.1:0 dev-perl/DBI dev-perl/DBD-SQLite )
subversion? ( dev-vcs/subversion[-dso,perl] dev-perl/libwww-perl dev-perl/TermReadKey )
)
- python? ( gtk?
- (
- >=dev-python/pygtk-2.8[${PYTHON_USEDEP}]
- >=dev-python/pygtksourceview-2.10.1-r1:2[${PYTHON_USEDEP}]
- )
- ${PYTHON_DEPS} )"
+ python? ( ${PYTHON_DEPS} )
+"
# This is how info docs are created with Git:
# .txt/asciidoc --(asciidoc)---------> .xml/docbook
@@ -112,7 +108,6 @@ REQUIRED_USE="
mediawiki-experimental? ( mediawiki )
subversion? ( perl )
webdav? ( curl )
- gtk? ( python )
python? ( ${PYTHON_REQUIRED_USE} )
"
@@ -423,11 +418,6 @@ src_install() {
elisp-site-file-install "${FILESDIR}"/${SITEFILE}
fi
- if use python && use gtk ; then
- python_doscript "${S}"/contrib/gitview/gitview
- dodoc "${S}"/contrib/gitview/gitview.txt
- fi
-
#dobin contrib/fast-import/git-p4 # Moved upstream
#dodoc contrib/fast-import/git-p4.txt # Moved upstream
newbin contrib/fast-import/import-tars.perl import-tars
diff --git a/dev-vcs/git/git-9999.ebuild b/dev-vcs/git/git-9999.ebuild
index a1f5e74e5a89..0be668f04597 100644
--- a/dev-vcs/git/git-9999.ebuild
+++ b/dev-vcs/git/git-9999.ebuild
@@ -43,7 +43,7 @@ fi
LICENSE="GPL-2"
SLOT="0"
-IUSE="+blksha1 +curl cgi doc emacs +gpg gtk highlight +iconv libressl libsecret mediawiki mediawiki-experimental +nls +pcre +perl +python ppcsha1 tk +threads +webdav xinetd cvs subversion test"
+IUSE="+blksha1 +curl cgi doc emacs +gpg highlight +iconv libressl libsecret mediawiki mediawiki-experimental +nls +pcre +perl +python ppcsha1 tk +threads +webdav xinetd cvs subversion test"
# Common to both DEPEND and RDEPEND
CDEPEND="
@@ -75,12 +75,8 @@ RDEPEND="${CDEPEND}
cvs? ( >=dev-vcs/cvsps-2.1:0 dev-perl/DBI dev-perl/DBD-SQLite )
subversion? ( dev-vcs/subversion[-dso,perl] dev-perl/libwww-perl dev-perl/TermReadKey )
)
- python? ( gtk?
- (
- >=dev-python/pygtk-2.8[${PYTHON_USEDEP}]
- >=dev-python/pygtksourceview-2.10.1-r1:2[${PYTHON_USEDEP}]
- )
- ${PYTHON_DEPS} )"
+ python? ( ${PYTHON_DEPS} )
+"
# This is how info docs are created with Git:
# .txt/asciidoc --(asciidoc)---------> .xml/docbook
@@ -112,7 +108,6 @@ REQUIRED_USE="
mediawiki-experimental? ( mediawiki )
subversion? ( perl )
webdav? ( curl )
- gtk? ( python )
python? ( ${PYTHON_REQUIRED_USE} )
"
@@ -423,11 +418,6 @@ src_install() {
elisp-site-file-install "${FILESDIR}"/${SITEFILE}
fi
- if use python && use gtk ; then
- python_doscript "${S}"/contrib/gitview/gitview
- dodoc "${S}"/contrib/gitview/gitview.txt
- fi
-
#dobin contrib/fast-import/git-p4 # Moved upstream
#dodoc contrib/fast-import/git-p4.txt # Moved upstream
newbin contrib/fast-import/import-tars.perl import-tars