summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-28 08:37:30 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-28 09:28:36 +0100
commitf4a2fe76ee05ce8932ce97d47f83f4fd960ef626 (patch)
tree6354763c1de418ae98182c803e8546eb8944c9aa
parentdev-python/xlsxwriter: Bump to 3.0.3 (diff)
downloadgentoo-f4a2fe76.tar.gz
gentoo-f4a2fe76.tar.bz2
gentoo-f4a2fe76.zip
dev-python/nuitka: Bump to 0.7.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/nuitka/Manifest1
-rw-r--r--dev-python/nuitka/nuitka-0.7.2.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/nuitka/Manifest b/dev-python/nuitka/Manifest
index 260cb2e5e2d2..31f8489aff3b 100644
--- a/dev-python/nuitka/Manifest
+++ b/dev-python/nuitka/Manifest
@@ -3,4 +3,5 @@ DIST Nuitka-0.6.19.5.tar.gz 3728119 BLAKE2B 8300356499e53185cd2b6a547b8deef818bf
DIST Nuitka-0.6.19.6.tar.gz 3726831 BLAKE2B d1b10f8a599898824cbc40a43dda6b88d89b8e4e8ae1d32b4458f6f5e9241e088fc2d4b6fb8e68e889abdbb2309f47cba100df78c5fe54a5b5333eb79a2143d7 SHA512 fc537b6c12c2a4f165c59f4fae39fea2894bc2f6221361dac39dc39a120a82b725e22810857c618305799b862b887e314c6dd340650e5c2029923e550143869e
DIST Nuitka-0.6.19.7.tar.gz 3728926 BLAKE2B 56d497b8ef556671f3442952a3af32b9401cd5ec52bc082ace472f644a90d42f16bd3831bd430c887c6bd0fb866bf14fc37ac6662a679856801a16723e4f7401 SHA512 f1921c7717247a139ac0b8f3be9ae4f3d40b928da86fcfc671843e0e0e96184489daf3e2ff8c84f3214e4797cb7d6121c05f5d8bc3fceb0ccd85d81675ade97e
DIST Nuitka-0.7.1.tar.gz 3753656 BLAKE2B 3df355bec346442a76a73e73a17b923fda43404305d727a239275991cf7fd31fef902635aa5f406485e28e43fb79950ce53fe5fcf7110869bdead5f5576513aa SHA512 debbef81475e70d3ab01cd3df990cb20f7b7217f73a35c66bb10dd6ec6ded7abf098239d1f88001f3bb282b84790f570a07dba4ab9823833e84d3faa6e7fe4f8
+DIST Nuitka-0.7.2.tar.gz 3754512 BLAKE2B 6d4dfbc51ab5144f5690864abd8ff1e143f98384c859011f43f91b7e25ec6802531c0f017381c5a99b12d0051c716a06fa8f1cc7ceb4e1c46881fea359eb0ab3 SHA512 65a2fe6f51593a717aab3738979b3870ba21fda8b25df88ab99f0b27f58b261cb68511cb45b0bccd0a9eafdf1bf96c4a93d735efc80f882e44dbbef76298db02
DIST Nuitka-0.7.tar.gz 3754689 BLAKE2B 28df135ff6d036c8bf27390d07ccc0bf924d39d924e9515fbf7c99a5a5a4dd837695c37cc0ef0889a8da27d277f48ada6dbcb52cc6b1a041b1f2c0a5e44ca7c5 SHA512 9732178faaf9607af0a37861b3f1eb8e64a2b7b5705351f5e82d3238713325f9dcbcb1a549a012c247cd08e3657e21a95c4d42e8fb1233d3fbb1403b09860235
diff --git a/dev-python/nuitka/nuitka-0.7.2.ebuild b/dev-python/nuitka/nuitka-0.7.2.ebuild
new file mode 100644
index 000000000000..1a35fde421ee
--- /dev/null
+++ b/dev-python/nuitka/nuitka-0.7.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1 flag-o-matic optfeature
+
+DESCRIPTION="Python to native compiler"
+HOMEPAGE="https://www.nuitka.net"
+SRC_URI="https://nuitka.net/releases/${P^}.tar.gz"
+S="${WORKDIR}/${P^}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-util/scons[${PYTHON_USEDEP}]"
+BDEPEND="
+ ${RDEPEND}
+ test? ( dev-util/ccache )
+"
+
+DOCS=( Changelog.pdf Developer_Manual.pdf README.pdf )
+
+distutils-r1_src_prepare() {
+ # remove vendored version of SCons that is Python2 only
+ # this should be removed when upstream removes support for Python2
+ rm -vR "${PN}/build/inline_copy/lib/scons-2.3.2/SCons" || die
+ eapply_user
+}
+
+python_install() {
+ distutils-r1_python_install
+ doman doc/nuitka3.1 doc/nuitka3-run.1
+}
+
+python_test() {
+ append-ldflags -Wl,--no-warn-search-mismatch
+ ./tests/basics/run_all.py search || die
+}
+
+pkg_postinst() {
+ optfeature "support for stand-alone executables" app-admin/chrpath
+}