summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-03-19 09:50:16 +0100
committerMichał Górny <mgorny@gentoo.org>2020-03-19 10:40:57 +0100
commitf4e685358dbe88b1d97d49e5a7c36734027a9f35 (patch)
tree533dda9884d23394d9e6ee741e5d40e307cfecaf
parentapp-portage/repoman: Drop py2 (diff)
downloadgentoo-f4e68535.tar.gz
gentoo-f4e68535.tar.bz2
gentoo-f4e68535.zip
app-admin/webapp-config: Drop old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--app-admin/webapp-config/Manifest3
-rw-r--r--app-admin/webapp-config/files/webapp-config-1.52-nulls-doctest.patch185
-rw-r--r--app-admin/webapp-config/files/webapp-config-1.53-sources-function.sh-from-lib-gentoo.patch25
-rw-r--r--app-admin/webapp-config/files/webapp-config-1.54-fix-bashism.patch12
-rw-r--r--app-admin/webapp-config/files/webapp-config-1.54-pvr-check.patch49
-rw-r--r--app-admin/webapp-config/webapp-config-1.52-r1.ebuild64
-rw-r--r--app-admin/webapp-config/webapp-config-1.53-r2.ebuild67
-rw-r--r--app-admin/webapp-config/webapp-config-1.54-r2.ebuild65
8 files changed, 0 insertions, 470 deletions
diff --git a/app-admin/webapp-config/Manifest b/app-admin/webapp-config/Manifest
index f3a98ce64784..958441a48502 100644
--- a/app-admin/webapp-config/Manifest
+++ b/app-admin/webapp-config/Manifest
@@ -1,4 +1 @@
-DIST webapp-config-1.52.tar.bz2 62951 BLAKE2B 8abc9f5503c9204fdb2d860f819e06a9f75f285bc0190bf1c479caea08754da92a351a12abe026d8600a51d8e33d57d827b027e8a0f9da5a8af1f09daa0de1e5 SHA512 ec616067588e6ab306af067e70bab9d17961aa675f387ee67a2291235ce81638b49a784d9a6c31891b7c78a712f276c3e62c6681a5e496a52c7e6fe7753922ea
-DIST webapp-config-1.53.tar.bz2 63429 BLAKE2B bb13d52a4c19859ff4730df2f7db75452effa23d1864d97aada38137f00ada8eec530f728f1c3ae06ecbed713a2d489b7225db3fc02aeabbf6241d0956761609 SHA512 7d2fc7197d537f2264c26b68b61e69273d2fcd3eec93657db54ba685c8383e7b8245cf05ed2ddd8b72453bf3fbf8f4bc4867e53d608331799df2e6162be14820
-DIST webapp-config-1.54.tar.bz2 58954 BLAKE2B 42a4305c51ccb8bb9db455c6ae2663b5d17c9d477eee3e504569c802e5f0d10183f3e6cd1e747462dcc0559d6ed7ba53a8b5607ed422f34813a33e0e8148bb90 SHA512 fa61e88696eaed130575e5ae9a17ec827aa14aece359e5ba43fa723ad00083def22e44fb02d99fc5ba6000a5949c5ce7aecea9307d2bfae333e202ef111dcd31
DIST webapp-config-1.55.tar.bz2 72583 BLAKE2B be958dc991f0e1f6835d9c29350b7d97e3f23d52971f6013165ce59a8f4b32ac6262c9719956d1bcdbe60797f07d77910b44a749ae545c4dc15f765525144709 SHA512 44294b276fd036908438cd984ebf70433639caa18d8330bab348433b4f39ea2c42c57fa8de4f0a6198f7875429a3ef9ebe61321c288d910f9be8b3414865f438
diff --git a/app-admin/webapp-config/files/webapp-config-1.52-nulls-doctest.patch b/app-admin/webapp-config/files/webapp-config-1.52-nulls-doctest.patch
deleted file mode 100644
index 97c64a90df25..000000000000
--- a/app-admin/webapp-config/files/webapp-config-1.52-nulls-doctest.patch
+++ /dev/null
@@ -1,185 +0,0 @@
-From 5f61d249507c3502c3c76faf3926522e6e63370d Mon Sep 17 00:00:00 2001
-From: Devan Franchini <twitch153@gentoo.org>
-Date: Fri, 3 Jan 2014 21:03:00 -0500
-Subject: [PATCH] WebappConfig/{ebuild,content}.py: Nulls doctest code.
-
-Due to the variable nature of the returning values of the two functions
-run_vars() and add(), it is unrealistic to depend on doctest to not
-fail. It has been decided that disabling these two doctest codes would
-be the best decision to prevent failures that are not detrimental.
-
-X-Gentoo-Bug: 430010
-X-Gentoo-Bug-URL: https://bugs.gentoo.org/430010
----
- WebappConfig/content.py | 36 ++++++++++++++++++------------------
- WebappConfig/ebuild.py | 46 +++++++++++++++++++++++-----------------------
- 2 files changed, 41 insertions(+), 41 deletions(-)
-
-diff --git a/WebappConfig/content.py b/WebappConfig/content.py
-index 8fe5be9..c635f5a 100644
---- a/WebappConfig/content.py
-+++ b/WebappConfig/content.py
-@@ -379,71 +379,71 @@ class Contents:
- (and this is important for md5)
- relative - 1 for storing a relative filename, 0 otherwise
-
-- >>> OUT.color_off()
-- >>> import os.path
-- >>> here = os.path.dirname(os.path.realpath(__file__))
-+ OUT.color_off()
-+ import os.path
-+ here = os.path.dirname(os.path.realpath(__file__))
-
- One for pretending:
-
-- >>> a = Contents(here + '/tests/testfiles/contents/app/',
-+ a = Contents(here + '/tests/testfiles/contents/app/',
- ... package = 'test', version = '1.0',
- ... pretend = True)
-
- And this one is for real:
-
-- >>> b = Contents(here + '/tests/testfiles/contents/app/',
-+ b = Contents(here + '/tests/testfiles/contents/app/',
- ... package = 'test', version = '1.0')
-
- Pretend to add a file:
-
-- >>> a.add('file', 'config-owned',
-+ a.add('file', 'config-owned',
- ... destination = here + '/tests/testfiles/contents/app/',
- ... path = '/test1', relative = True)
- * pretending to add: file 1 config-owned "test1"
-
- Lets not pretend this time:
-
-- >>> b.add('file', 'config-owned',
-+ b.add('file', 'config-owned',
- ... destination = here + '/tests/testfiles/contents/app/',
- ... path = '/test1', relative = True)
-- >>> b.entry(here + '/tests/testfiles/contents/app/test1') #doctest: +ELLIPSIS
-+ b.entry(here + '/tests/testfiles/contents/app/test1') #doctest: +ELLIPSIS
- 'file 1 config-owned "test1" ... d8e8fca2dc0f896fd7cb4cb0031ba249 '
-
- Lets produce an error with a file that does not exist:
-
-- >>> b.add('file', 'config-owned',
-+ b.add('file', 'config-owned',
- ... destination = here + '/tests/testfiles/contents/app/',
- ... path = '/nothere', relative = True) #doctest: +ELLIPSIS
- * Cannot access file .../tests/testfiles/contents/app/nothere to add it as installation content. This should not happen!
-
- Other file types:
-
-- >>> b.add('hardlink', 'config-owned',
-+ b.add('hardlink', 'config-owned',
- ... destination = here + '/tests/testfiles/contents/app/',
- ... path = '/test2', relative = True)
-- >>> b.entry(here + '/tests/testfiles/contents/app/test2') #doctest: +ELLIPSIS
-+ b.entry(here + '/tests/testfiles/contents/app/test2') #doctest: +ELLIPSIS
- 'file 1 config-owned "test2" ... d8e8fca2dc0f896fd7cb4cb0031ba249 '
-- >>> b.add('dir', 'default-owned',
-+ b.add('dir', 'default-owned',
- ... destination = here + '/tests/testfiles/contents/app/',
- ... path = '/dir1', relative = True)
-- >>> b.entry(here + '/tests/testfiles/contents/app/dir1') #doctest: +ELLIPSIS
-+ b.entry(here + '/tests/testfiles/contents/app/dir1') #doctest: +ELLIPSIS
- 'dir 1 default-owned "dir1" ... 0 '
-- >>> b.add('dir', 'default-owned', destination = here + '/tests/testfiles/contents/app',
-+ b.add('dir', 'default-owned', destination = here + '/tests/testfiles/contents/app',
- ... path = '/dir1',
- ... relative = False)
-- >>> b.entry(here + '/tests/testfiles/contents/app/dir1') #doctest: +ELLIPSIS
-+ b.entry(here + '/tests/testfiles/contents/app/dir1') #doctest: +ELLIPSIS
- 'dir 0 default-owned ".../tests/testfiles/contents/app/dir1" ... 0 '
-
- Q: Is the full link to the target what we want?
- A: Yes, since the link will still be ok even if we move the directory.
-
-- >>> b.add('sym', 'virtual',
-+ b.add('sym', 'virtual',
- ... destination = here + '/tests/testfiles/contents/app/',
- ... path = '/test3', relative = True)
-- >>> b.entry(here + '/tests/testfiles/contents/app/test3') #doctest: +ELLIPSIS
-+ b.entry(here + '/tests/testfiles/contents/app/test3') #doctest: +ELLIPSIS
- 'sym 1 virtual "test3" ... 0 .../tests/testfiles/contents/app/test1'
-
-- >>> b.db_print() #doctest: +ELLIPSIS
-+ b.db_print() #doctest: +ELLIPSIS
- file 1 config-owned "test1" ... d8e8fca2dc0f896fd7cb4cb0031ba249
- file 1 config-owned "test2" ... d8e8fca2dc0f896fd7cb4cb0031ba249
- sym 1 virtual "test3" ... 0 .../tests/testfiles/contents/app/test1
-diff --git a/WebappConfig/ebuild.py b/WebappConfig/ebuild.py
-index 03c0c57..cc23bec 100644
---- a/WebappConfig/ebuild.py
-+++ b/WebappConfig/ebuild.py
-@@ -201,35 +201,35 @@ class Ebuild:
- The procedure from above is repeated to set up the default
- environment:
-
-- >>> import WebappConfig.config
-- >>> config = WebappConfig.config.Config()
-- >>> config.config.set('USER', 'my_htdocsbase', 'htdocs')
-- >>> config.config.set('USER', 'pn', 'horde')
-- >>> config.config.set('USER', 'pvr', '3.0.5')
-- >>> import os.path
-- >>> here = os.path.dirname(os.path.realpath(__file__))
-- >>> config.config.set('USER', 'my_approot', here +
-- ... '/tests/testfiles/share-webapps')
-- >>> my_approot = config.config.get('USER', 'my_approot')
-- >>> my_appdir = my_approot + "/horde/3.0.5"
-- >>> config.config.set('USER', 'my_appdir', my_appdir)
-- >>> config.config.set('USER', 'my_hookscriptsdir', my_appdir + '/hooks')
-- >>> config.config.set('USER', 'my_cgibinbase', 'cgi-bin')
-- >>> config.config.set('USER', 'my_errorsbase', 'error')
-- >>> config.config.set('USER', 'my_iconsbase', 'icons')
-- >>> config.config.set('USER', 'my_serverconfigdir', '/'.join([my_appdir,'conf']))
-- >>> config.config.set('USER', 'my_hostrootdir', '/'.join([my_appdir,'hostroot']))
-- >>> config.config.set('USER', 'my_htdocsdir', '/'.join([my_appdir,'htdocs']))
-- >>> config.config.set('USER', 'my_sqlscriptsdir', '/'.join([my_appdir,'sqlscripts']))
-+ "">>> import WebappConfig.config"
-+ ">>> config = WebappConfig.config.Config()"
-+ ">>> config.config.set('USER', 'my_htdocsbase', 'htdocs')"
-+ ">>> config.config.set('USER', 'pn', 'horde')"
-+ ">>> config.config.set('USER', 'pvr', '3.0.5')"
-+ ">>> import os.path"
-+ ">>> here = os.path.dirname(os.path.realpath(__file__))"
-+ ">>> config.config.set('USER', 'my_approot', here +"
-+ "... '/tests/testfiles/share-webapps')"
-+ ">>> my_approot = config.config.get('USER', 'my_approot')"
-+ ">>> my_appdir = my_approot + "/horde/3.0.5""
-+ ">>> config.config.set('USER', 'my_appdir', my_appdir)"
-+ ">>> config.config.set('USER', 'my_hookscriptsdir', my_appdir + '/hooks')"
-+ ">>> config.config.set('USER', 'my_cgibinbase', 'cgi-bin')"
-+ ">>> config.config.set('USER', 'my_errorsbase', 'error')"
-+ ">>> config.config.set('USER', 'my_iconsbase', 'icons')"
-+ ">>> config.config.set('USER', 'my_serverconfigdir', '/'.join([my_appdir,'conf']))"
-+ ">>> config.config.set('USER', 'my_hostrootdir', '/'.join([my_appdir,'hostroot']))"
-+ ">>> config.config.set('USER', 'my_htdocsdir', '/'.join([my_appdir,'htdocs']))"
-+ ">>> config.config.set('USER', 'my_sqlscriptsdir', '/'.join([my_appdir,'sqlscripts']))"
-
- Time to create the ebuild handler:
-
-- >>> a = Ebuild(config)
-+ ">>> a = Ebuild(config)"
-
- The dummy post-install file should display all the variables
- that are exported here:
-
-- >>> a.show_postinst() #doctest: +ELLIPSIS
-+ ">>> a.show_postinst() #doctest: +ELLIPSIS
- <BLANKLINE>
- =================================================================
- POST-INSTALL INSTRUCTIONS
-@@ -270,7 +270,7 @@ class Ebuild:
- PVR: 3.0.5
- <BLANKLINE>
- =================================================================
-- <BLANKLINE>
-+ <BLANKLINE>"
- '''
-
- v_root = self.get_config('vhost_root')
---
-1.8.3.2
-
diff --git a/app-admin/webapp-config/files/webapp-config-1.53-sources-function.sh-from-lib-gentoo.patch b/app-admin/webapp-config/files/webapp-config-1.53-sources-function.sh-from-lib-gentoo.patch
deleted file mode 100644
index 06a924a426be..000000000000
--- a/app-admin/webapp-config/files/webapp-config-1.53-sources-function.sh-from-lib-gentoo.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-From ff7ba0d89c79584f14a8137d886a656a9af6de5c Mon Sep 17 00:00:00 2001
-From: Devan Franchini <twitch153@gentoo.org>
-Date: Sat, 27 Dec 2014 20:43:08 -0500
-Subject: [PATCH] webapp-cleaner: sources function.sh from /lib/gentoo
-
----
- sbin/webapp-cleaner | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/sbin/webapp-cleaner b/sbin/webapp-cleaner
-index bfec623..52e44ac 100755
---- a/sbin/webapp-cleaner
-+++ b/sbin/webapp-cleaner
-@@ -13,7 +13,7 @@ CMD="emerge -Cav"
- WEBAPP_DIR="/usr/share/webapps"
- WEBAPP_CONFIG=
-
--[[ -z ${RC_GOT_FUNCTIONS} ]] && source /etc/init.d/functions.sh
-+[[ -z ${RC_GOT_FUNCTIONS} ]] && source /lib/gentoo/functions.sh
-
- function help() {
- echo "Remove obsolete and unused versions of web applications"
---
-2.0.5
-
diff --git a/app-admin/webapp-config/files/webapp-config-1.54-fix-bashism.patch b/app-admin/webapp-config/files/webapp-config-1.54-fix-bashism.patch
deleted file mode 100644
index 9958c142d4a7..000000000000
--- a/app-admin/webapp-config/files/webapp-config-1.54-fix-bashism.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -Naur WebappConfig.old/ebuild.py WebappConfig/ebuild.py
---- WebappConfig/ebuild.py
-+++ WebappConfig/ebuild.py
-@@ -101,7 +101,7 @@
-
- for i in post_instructions:
- i = i.replace('"', '\\"')
-- post.append(os.popen('echo -n "' + i + '"\n').read()[:-1])
-+ post.append(os.popen('printf "' + i + '"\n').read()[:-1])
-
- post = post + [
- '',
diff --git a/app-admin/webapp-config/files/webapp-config-1.54-pvr-check.patch b/app-admin/webapp-config/files/webapp-config-1.54-pvr-check.patch
deleted file mode 100644
index 9a35ad70cafb..000000000000
--- a/app-admin/webapp-config/files/webapp-config-1.54-pvr-check.patch
+++ /dev/null
@@ -1,49 +0,0 @@
-commit 9e251c7574d074e424ea19024f743c754f321979
-Author: Devan Franchini <twitch153@gentoo.org>
-Date: Fri Jul 10 21:25:17 2015 -0400
-
- config.py: Fixes package version checking regression
-
- Previously webapp-config would not do any sanity checks when
- setting the package version. After adding a sanity check in 1.54
- I made the mistake of not being flexible enough and this caused
- a regression that prevented web apps with versions such as
- "20140929d"[1] to be installed. This commit fixes that while still
- allowing for some sanity checking.
-
- [1]: https://github.com/gentoo/webapp-config/issues/2
-
-diff --git a/WebappConfig/config.py b/WebappConfig/config.py
-index 6c915c3..3a176a0 100644
---- a/WebappConfig/config.py
-+++ b/WebappConfig/config.py
-@@ -996,17 +996,20 @@ class Config:
- OUT.die('Invalid package name')
-
- if len(args) > 1:
-- argsvr = args[1].split('.')
-- if len(argsvr) == 1:
-- OUT.die('Invalid package version: %(pvr)s'
-+ pvr = args[1]
-+ has_int = False # A package version should have at least one
-+ # numerical value, but we want to allow for
-+ # the flexibility of having any alphanumeric
-+ # value while checking to make sure it's sane.
-+
-+ for char in pvr:
-+ if char.isdigit():
-+ has_int = True
-+
-+ if not has_int:
-+ OUT.die('Invalid package version: "%(pvr)s"'
- % {'pvr': args[1]})
-
-- pvr = ''
-- for i in range(0, len(argsvr)):
-- if not i == len(argsvr) - 1:
-- pvr += argsvr[i] + '.'
-- else:
-- pvr += argsvr[i]
- self.config.set('USER', 'pvr', pvr)
-
- if (not options['dir'] and
diff --git a/app-admin/webapp-config/webapp-config-1.52-r1.ebuild b/app-admin/webapp-config/webapp-config-1.52-r1.ebuild
deleted file mode 100644
index 09cd5701172a..000000000000
--- a/app-admin/webapp-config/webapp-config-1.52-r1.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1
-
-SRC_URI="https://dev.gentoo.org/~twitch153/${PN}/${P}.tar.bz2"
-KEYWORDS="~alpha amd64 arm hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86"
-
-DESCRIPTION="Gentoo's installer for web-based applications"
-HOMEPAGE="https://sourceforge.net/projects/webapp-config/"
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="+portage"
-
-DEPEND="app-text/xmlto
- !dev-python/configparser"
-RDEPEND="portage? ( sys-apps/portage[${PYTHON_USEDEP}] )"
-
-python_prepare() {
- epatch "${FILESDIR}/${P}-nulls-doctest.patch"
-}
-
-python_compile_all() {
- emake -C doc/
-}
-
-python_install() {
- # According to this discussion:
- # http://mail.python.org/pipermail/distutils-sig/2004-February/003713.html
- # distutils does not provide for specifying two different script install
- # locations. Since we only install one script here the following should
- # be ok
- distutils-r1_python_install --install-scripts="${EPREFIX}/usr/sbin"
-}
-
-python_install_all() {
- distutils-r1_python_install_all
-
- insinto /etc/vhosts
- doins config/webapp-config
-
- keepdir /usr/share/webapps
- keepdir /var/db/webapps
-
- dodoc AUTHORS
- doman doc/*.[58]
- dohtml doc/*.[58].html
-}
-
-python_test() {
- PYTHONPATH="." "${PYTHON}" WebappConfig/tests/dtest.py \
- || die "Testing failed with ${EPYTHON}"
-}
-
-pkg_postinst() {
- elog "Now that you have upgraded webapp-config, you **must** update your"
- elog "config files in /etc/vhosts/webapp-config before you emerge any"
- elog "packages that use webapp-config."
-}
diff --git a/app-admin/webapp-config/webapp-config-1.53-r2.ebuild b/app-admin/webapp-config/webapp-config-1.53-r2.ebuild
deleted file mode 100644
index ee19757707a0..000000000000
--- a/app-admin/webapp-config/webapp-config-1.53-r2.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-
-RESTRICT="test"
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1
-
-SRC_URI="https://dev.gentoo.org/~twitch153/${PN}/${P}.tar.bz2"
-KEYWORDS="~alpha amd64 arm ~arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86"
-
-DESCRIPTION="Gentoo's installer for web-based applications"
-HOMEPAGE="https://sourceforge.net/projects/webapp-config/"
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="+portage"
-
-DEPEND="app-text/xmlto
- !dev-python/configparser
- sys-apps/gentoo-functions"
-RDEPEND="portage? ( sys-apps/portage[${PYTHON_USEDEP}] )"
-
-python_prepare() {
- epatch "${FILESDIR}/${P}-sources-function.sh-from-lib-gentoo.patch"
-}
-
-python_compile_all() {
- emake -C doc/
-}
-
-python_install() {
- # According to this discussion:
- # http://mail.python.org/pipermail/distutils-sig/2004-February/003713.html
- # distutils does not provide for specifying two different script install
- # locations. Since we only install one script here the following should
- # be ok
- distutils-r1_python_install --install-scripts="${EPREFIX}/usr/sbin"
-}
-
-python_install_all() {
- distutils-r1_python_install_all
-
- insinto /etc/vhosts
- doins config/webapp-config
-
- keepdir /usr/share/webapps
- keepdir /var/db/webapps
-
- dodoc AUTHORS
- doman doc/*.[58]
- dohtml doc/*.[58].html
-}
-
-python_test() {
- PYTHONPATH="." "${PYTHON}" WebappConfig/tests/dtest.py \
- || die "Testing failed with ${EPYTHON}"
-}
-
-pkg_postinst() {
- elog "Now that you have upgraded webapp-config, you **must** update your"
- elog "config files in /etc/vhosts/webapp-config before you emerge any"
- elog "packages that use webapp-config."
-}
diff --git a/app-admin/webapp-config/webapp-config-1.54-r2.ebuild b/app-admin/webapp-config/webapp-config-1.54-r2.ebuild
deleted file mode 100644
index 8e74ce226438..000000000000
--- a/app-admin/webapp-config/webapp-config-1.54-r2.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_7,3_6} )
-
-inherit distutils-r1
-
-SRC_URI="https://dev.gentoo.org/~twitch153/${PN}/${P}.tar.bz2"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-
-DESCRIPTION="Gentoo's installer for web-based applications"
-HOMEPAGE="https://sourceforge.net/projects/webapp-config/"
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="+portage"
-
-DEPEND="app-text/xmlto
- sys-apps/gentoo-functions"
-RDEPEND="portage? ( sys-apps/portage[${PYTHON_USEDEP}] )"
-
-python_prepare() {
- epatch "${FILESDIR}/${P}-pvr-check.patch"\
- "${FILESDIR}/${P}-fix-bashism.patch"
-}
-python_compile_all() {
- emake -C doc/
-}
-
-python_install() {
- # According to this discussion:
- # http://mail.python.org/pipermail/distutils-sig/2004-February/003713.html
- # distutils does not provide for specifying two different script install
- # locations. Since we only install one script here the following should
- # be ok
- distutils-r1_python_install --install-scripts="${EPREFIX}/usr/sbin"
-}
-
-python_install_all() {
- distutils-r1_python_install_all
-
- insinto /etc/vhosts
- doins config/webapp-config
-
- keepdir /usr/share/webapps
- keepdir /var/db/webapps
-
- dodoc AUTHORS
- doman doc/*.[58]
- dohtml doc/*.[58].html
-}
-
-python_test() {
- PYTHONPATH="." "${PYTHON}" WebappConfig/tests/external.py \
- || die "Testing failed with ${EPYTHON}"
-}
-
-pkg_postinst() {
- elog "webapp-config now requires that all -I/-U/-C commands be followed"
- elog "by the package name and package version of the webapp"
- elog "eg.) 'webapp-config -d drupal -I drupal 8.0.0_beta10'"
- elog "See 'man 8 webapp-config' for more information"
-}