summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-10-17 22:11:00 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2020-10-17 22:48:02 -0500
commitf4eb41ce8ea5fe7b0418bad75f2125461d215082 (patch)
treefa45172015aad1efbba9a618b203c90d45deb2d7
parentdev-python/simplegeneric: add py38 (diff)
downloadgentoo-f4eb41ce.tar.gz
gentoo-f4eb41ce.tar.bz2
gentoo-f4eb41ce.zip
dev-python/WSME: 0.10.0 bump
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
-rw-r--r--dev-python/WSME/Manifest1
-rw-r--r--dev-python/WSME/WSME-0.10.0.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/WSME/Manifest b/dev-python/WSME/Manifest
index aa7858e4ca2d..44e9944fbe83 100644
--- a/dev-python/WSME/Manifest
+++ b/dev-python/WSME/Manifest
@@ -1 +1,2 @@
+DIST WSME-0.10.0.tar.gz 89701 BLAKE2B 8ce4160919b66c4c858d71af02cc40741fda0261fe0c23f390805a3913e85879011975a7a562c647a877ce6b40cd0c5d273f4f44f0affff4efe5717339a143cb SHA512 2015ed56e12f566e9c40cf2d37d3dce1edf5f4678a2703b3477d362abb52866a519addc77cfcc57b712de58ab6bcad707c6971eb3de60d7f6f209fdf4cfb7a88
DIST WSME-0.9.3.tar.gz 124775 BLAKE2B 393168629333c4e304689758c9462164d638cdc529c6128975ed5cb6624db4caef5a700a41ae8e51565cd796d1c4e5539bc553bc358991c3c62c1a18aa443cd4 SHA512 dcff4a1742c778af37b1182f45d4025a3a9b60b1aa7b7c1e62957eb1a2c0d38ffe0a0d16a921e44fda1f2310aa60cdae9bdacc1941cb01d8eb8f36cb31514c9c
diff --git a/dev-python/WSME/WSME-0.10.0.ebuild b/dev-python/WSME/WSME-0.10.0.ebuild
new file mode 100644
index 000000000000..e80a811bb69c
--- /dev/null
+++ b/dev-python/WSME/WSME-0.10.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_7 python3_8 )
+
+inherit distutils-r1
+
+DESCRIPTION="Simplify the writing of REST APIs, and extend them with additional protocols."
+HOMEPAGE="https://pythonhosted.org/WSME"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+DEPEND=">=dev-python/pbr-1.3[${PYTHON_USEDEP}]"
+RDEPEND="
+ >=dev-python/pbr-1.3[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ >=dev-python/webob-1.8.0[${PYTHON_USEDEP}]
+ dev-python/simplegeneric[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ >=dev-python/netaddr-0.7.12[${PYTHON_USEDEP}]
+"