summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-10-11 04:27:35 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-10-11 04:56:04 -0400
commitf4ef6988d51fec607dcee7f567c601596353b171 (patch)
treef76d9bd2b10cd1615f7f7279b498684844141c23
parentx11-misc/xearth: pass -std=gnu89 (diff)
downloadgentoo-f4ef6988d51fec607dcee7f567c601596353b171.tar.gz
gentoo-f4ef6988d51fec607dcee7f567c601596353b171.tar.bz2
gentoo-f4ef6988d51fec607dcee7f567c601596353b171.zip
x11-misc/xfishtank: pass -std=gnu89
Does not build with `clang -std=c2x`, early workaround for when this will become a default. (not actively hunting for these, merely revisiting packages previously looked at for clang16 even if not an issue "yet"). Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
-rw-r--r--x11-misc/xfishtank/xfishtank-2.5.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/x11-misc/xfishtank/xfishtank-2.5.ebuild b/x11-misc/xfishtank/xfishtank-2.5.ebuild
index 48df2a9e84c5..22bdac1cd667 100644
--- a/x11-misc/xfishtank/xfishtank-2.5.ebuild
+++ b/x11-misc/xfishtank/xfishtank-2.5.ebuild
@@ -2,7 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit toolchain-funcs
+
+inherit flag-o-matic toolchain-funcs
DESCRIPTION="Turns your root window into an aquarium"
HOMEPAGE="https://jim.rees.org/computers/xfishtank.html"
@@ -29,6 +30,8 @@ BDEPEND="
S=${WORKDIR}/${PN}
src_configure() {
+ append-cflags -std=gnu89 # old codebase, incompatible with c2x
+
CC="$(tc-getBUILD_CC)" LD="$(tc-getLD)" \
IMAKECPP="${IMAKECPP:-${CHOST}-gcc -E}" xmkmf || die
}