summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Schmaus <flow@gentoo.org>2022-02-27 09:51:51 +0100
committerFlorian Schmaus <flow@gentoo.org>2022-02-27 09:52:51 +0100
commitf4f10ce05d84f8a5f3d103077e48802a398caece (patch)
treee0ccaeb5476de72ff1e50d8b57cdd737061ef777
parentdev-python/rpyc: Remove python@ (diff)
downloadgentoo-f4f10ce0.tar.gz
gentoo-f4f10ce0.tar.bz2
gentoo-f4f10ce0.zip
sys-fs/fragview: bump to EAPI 8, switch to cmake.eclass, fix deps
Signed-off-by: Florian Schmaus <flow@gentoo.org>
-rw-r--r--sys-fs/fragview/fragview-0.1.1-r1.ebuild (renamed from sys-fs/fragview/fragview-0.1.1.ebuild)19
-rw-r--r--sys-fs/fragview/fragview-9999.ebuild19
2 files changed, 26 insertions, 12 deletions
diff --git a/sys-fs/fragview/fragview-0.1.1.ebuild b/sys-fs/fragview/fragview-0.1.1-r1.ebuild
index 5e531deaaae0..5e579ec7c56e 100644
--- a/sys-fs/fragview/fragview-0.1.1.ebuild
+++ b/sys-fs/fragview/fragview-0.1.1-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
-inherit cmake-utils
+inherit cmake
if [[ ${PV} == *9999 ]]; then
inherit git-r3
@@ -19,12 +19,19 @@ HOMEPAGE="https://github.com/i-rinat/fragview"
LICENSE="MIT"
SLOT="0"
-DEPEND="
+COMMON_DEPEND="
+ dev-cpp/atkmm:0
+ dev-cpp/cairomm:0
dev-cpp/glibmm:2
dev-cpp/gtkmm:3.0
dev-db/sqlite:3
- dev-libs/boost:=
+ dev-libs/glib:2
+ dev-libs/libsigc++:2
+"
+DEPEND="
+ ${COMMON_DEPEND}
+ dev-libs/boost
"
-RDEPEND="${DEPEND}"
+RDEPEND="${COMMON_DEPEND}"
PATCHES=( "${FILESDIR}/${P}-fix-linking.patch" )
diff --git a/sys-fs/fragview/fragview-9999.ebuild b/sys-fs/fragview/fragview-9999.ebuild
index 679d6254f5ae..1679ebd4e588 100644
--- a/sys-fs/fragview/fragview-9999.ebuild
+++ b/sys-fs/fragview/fragview-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
-inherit cmake-utils
+inherit cmake
if [[ ${PV} == *9999 ]]; then
inherit git-r3
@@ -19,10 +19,17 @@ HOMEPAGE="https://github.com/i-rinat/fragview"
LICENSE="MIT"
SLOT="0"
-DEPEND="
+COMMON_DEPEND="
+ dev-cpp/atkmm:0
+ dev-cpp/cairomm:0
dev-cpp/glibmm:2
dev-cpp/gtkmm:3.0
dev-db/sqlite:3
- dev-libs/boost:=
+ dev-libs/glib:2
+ dev-libs/libsigc++:2
+"
+DEPEND="
+ ${COMMON_DEPEND}
+ dev-libs/boost
"
-RDEPEND="${DEPEND}"
+RDEPEND="${COMMON_DEPEND}"