summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-12-06 07:10:03 +0100
committerMichał Górny <mgorny@gentoo.org>2023-12-06 07:51:31 +0100
commitf51fd9e04b9a6deefa9794712dc97894efc1655a (patch)
tree663e478df88256f942676e27b15acc72c8ad77aa
parentdev-python/sqlglot: Remove old (diff)
downloadgentoo-f51fd9e04b9a6deefa9794712dc97894efc1655a.tar.gz
gentoo-f51fd9e04b9a6deefa9794712dc97894efc1655a.tar.bz2
gentoo-f51fd9e04b9a6deefa9794712dc97894efc1655a.zip
dev-python/google-auth: Bump to 2.25.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/google-auth/Manifest1
-rw-r--r--dev-python/google-auth/google-auth-2.25.1.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/dev-python/google-auth/Manifest b/dev-python/google-auth/Manifest
index 007fab5f359a..257b25eb7491 100644
--- a/dev-python/google-auth/Manifest
+++ b/dev-python/google-auth/Manifest
@@ -1,2 +1,3 @@
DIST google-auth-2.23.4.tar.gz 233560 BLAKE2B 3d058c9c16af4f982aac7411b306eeace70f17d23b7043328c235bff5233e79360cc5a9ca24b06e33d318606acd331b33fef14c7574338f9ac3caee3088c4f35 SHA512 561cff5003f5b6e37a0ab4fa4c827646bb9b3fee3dc500214b88ec3fc7203022f487abaee315751fb7d90b4ed9a9d9d0ab6f3dc7d3336d9df9d4b45e6146bc2f
DIST google-auth-2.24.0.tar.gz 234771 BLAKE2B 05111637ae26529b9345ef1f3ce8334bbcfc782e93d560749205a18e50075593573130e6ba3d33e79cd0190305ae382d44aac071c12ab67df7a8064a041220f2 SHA512 e4987b8e52be45e2fd2906525e1a4645f73b2322a6d7055f9b9c00555f4ffe05b7cda6e21cbf9f491e1e0f2b43772050017b7473b24a92cf5ca6ae6e589a15e0
+DIST google-auth-2.25.1.tar.gz 235616 BLAKE2B 48dc210069bef63e8620d5d28931877f34cb0d2a1bcdc593f9424e519700441ee469c6e4cb69757706409c3beb12ccb39bb4c4953d9f21a5da78e72e357824c7 SHA512 11d71091627c72abce4db7b5c4d779fa89c38005fae7a39508851029fe297d00d302297f34e3c5e70c299708394db7acdc3066253655e24581ba681a655f508b
diff --git a/dev-python/google-auth/google-auth-2.25.1.ebuild b/dev-python/google-auth/google-auth-2.25.1.ebuild
new file mode 100644
index 000000000000..3136de42f585
--- /dev/null
+++ b/dev-python/google-auth/google-auth-2.25.1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Google Authentication Library"
+HOMEPAGE="
+ https://github.com/googleapis/google-auth-library-python/
+ https://pypi.org/project/google-auth/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ <dev-python/cachetools-6.0.0[${PYTHON_USEDEP}]
+ >=dev-python/pyasn1-0.1.7[${PYTHON_USEDEP}]
+ >=dev-python/pyasn1-modules-0.2.1[${PYTHON_USEDEP}]
+ >=dev-python/rsa-3.1.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/grpcio[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/moto[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ dev-python/pytest-localserver[${PYTHON_USEDEP}]
+ dev-python/pyu2f[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ # these are compatibility tests with oauth2client
+ # disable them to unblock removal of that package
+ tests/test__oauth2client.py
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}
+
+python_compile() {
+ distutils-r1_python_compile
+ find "${BUILD_DIR}" -name '*.pth' -delete || die
+}