summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2021-07-11 22:21:24 +0200
committerConrad Kostecki <conikost@gentoo.org>2021-07-11 23:18:19 +0200
commitf5288dda82ce4164afd230eaf81f91a890c07b23 (patch)
tree5c82136cf45df7fb4e8fdbff67050d88f640734b
parentprofiles/base: fix date format in mask (diff)
downloadgentoo-f5288dda.tar.gz
gentoo-f5288dda.tar.bz2
gentoo-f5288dda.zip
net-analyzer/ngrep: migrate to GLEP 81
Bug: https://bugs.gentoo.org/781353 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
-rw-r--r--net-analyzer/ngrep/ngrep-1.47-r1.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/net-analyzer/ngrep/ngrep-1.47-r1.ebuild b/net-analyzer/ngrep/ngrep-1.47-r1.ebuild
new file mode 100644
index 000000000000..4dbf881dcf41
--- /dev/null
+++ b/net-analyzer/ngrep/ngrep-1.47-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="A grep for network layers"
+HOMEPAGE="https://github.com/jpr5/ngrep"
+SRC_URI="https://github.com/jpr5/ngrep/archive/V${PV/./_}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${P/./_}"
+
+LICENSE="ngrep"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm ~hppa ~ia64 ppc ppc64 ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="ipv6"
+
+DEPEND="
+ dev-libs/libpcre
+ net-libs/libpcap
+"
+
+RDEPEND="
+ ${DEPEND}
+ acct-group/ngrep
+ acct-user/ngrep
+"
+
+PATCHES=( "${FILESDIR}"/${PN}-1.47-regex.patch )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable ipv6)
+ --disable-pcap-restart
+ --enable-pcre
+ --with-dropprivs-user=ngrep
+ --with-pcap-includes="${EPREFIX}"/usr/include/pcap
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ emake -C regex-0.12
+ emake STRIPFLAG="${CFLAGS}"
+}