summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2019-12-13 13:41:32 +0100
committerAlexis Ballier <aballier@gentoo.org>2019-12-13 14:53:20 +0100
commitf54abd7d1b2f5e879ffe81ef05802f686a3e4a1d (patch)
tree97cebef7f6f0296ee5aed3ca9c66b6fb0b3162b1
parentdev-ros/ament_cmake_target_dependencies: use python-any-r1 (diff)
downloadgentoo-f54abd7d1b2f5e879ffe81ef05802f686a3e4a1d.tar.gz
gentoo-f54abd7d1b2f5e879ffe81ef05802f686a3e4a1d.tar.bz2
gentoo-f54abd7d1b2f5e879ffe81ef05802f686a3e4a1d.zip
dev-ros/ament_cmake_python: use python-any-r1
Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
-rw-r--r--dev-ros/ament_cmake_python/ament_cmake_python-0.8.1-r1.ebuild23
-rw-r--r--dev-ros/ament_cmake_python/ament_cmake_python-9999.ebuild23
2 files changed, 16 insertions, 30 deletions
diff --git a/dev-ros/ament_cmake_python/ament_cmake_python-0.8.1-r1.ebuild b/dev-ros/ament_cmake_python/ament_cmake_python-0.8.1-r1.ebuild
index 43d5e2330457..fba573262bf6 100644
--- a/dev-ros/ament_cmake_python/ament_cmake_python-0.8.1-r1.ebuild
+++ b/dev-ros/ament_cmake_python/ament_cmake_python-0.8.1-r1.ebuild
@@ -5,7 +5,7 @@ EAPI=7
PYTHON_COMPAT=( python{3_6,3_7} )
-inherit cmake-utils python-r1
+inherit cmake-utils python-any-r1
ROS_PN="ament_cmake"
if [ "${PV#9999}" != "${PV}" ] ; then
@@ -30,20 +30,13 @@ else
fi
IUSE=""
-DEPEND="
- dev-ros/ament_cmake_core[${PYTHON_USEDEP}]
+RDEPEND="
+ dev-ros/ament_cmake_core
+"
+DEPEND="${RDEPEND}"
+# Deps here are transitive from ament_cmake_core to have matching python support
+BDEPEND="
+ $(python_gen_any_dep 'dev-python/ament_package[${PYTHON_USEDEP}] dev-python/catkin_pkg[${PYTHON_USEDEP}]')
${PYTHON_DEPS}
"
-RDEPEND="${DEPEND}"
-BDEPEND="${DEPEND}"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
PATCHES=( "${FILESDIR}/destdir.patch" )
-
-src_configure() {
- # This is a build tool that does not install python-related files
- # ... but we need to propagate the deps and use python3 to build it.
- local pyimpl="${PYTHON_COMPAT[0]}"
- python_export "${pyimpl}" EPYTHON PYTHON
- python_wrapper_setup
- cmake-utils_src_configure
-}
diff --git a/dev-ros/ament_cmake_python/ament_cmake_python-9999.ebuild b/dev-ros/ament_cmake_python/ament_cmake_python-9999.ebuild
index 43d5e2330457..fba573262bf6 100644
--- a/dev-ros/ament_cmake_python/ament_cmake_python-9999.ebuild
+++ b/dev-ros/ament_cmake_python/ament_cmake_python-9999.ebuild
@@ -5,7 +5,7 @@ EAPI=7
PYTHON_COMPAT=( python{3_6,3_7} )
-inherit cmake-utils python-r1
+inherit cmake-utils python-any-r1
ROS_PN="ament_cmake"
if [ "${PV#9999}" != "${PV}" ] ; then
@@ -30,20 +30,13 @@ else
fi
IUSE=""
-DEPEND="
- dev-ros/ament_cmake_core[${PYTHON_USEDEP}]
+RDEPEND="
+ dev-ros/ament_cmake_core
+"
+DEPEND="${RDEPEND}"
+# Deps here are transitive from ament_cmake_core to have matching python support
+BDEPEND="
+ $(python_gen_any_dep 'dev-python/ament_package[${PYTHON_USEDEP}] dev-python/catkin_pkg[${PYTHON_USEDEP}]')
${PYTHON_DEPS}
"
-RDEPEND="${DEPEND}"
-BDEPEND="${DEPEND}"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
PATCHES=( "${FILESDIR}/destdir.patch" )
-
-src_configure() {
- # This is a build tool that does not install python-related files
- # ... but we need to propagate the deps and use python3 to build it.
- local pyimpl="${PYTHON_COMPAT[0]}"
- python_export "${pyimpl}" EPYTHON PYTHON
- python_wrapper_setup
- cmake-utils_src_configure
-}