summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-08-06 04:37:24 +0100
committerSam James <sam@gentoo.org>2022-08-06 04:49:29 +0100
commitf553b896d25848f8924ae58b456ede494f8503e3 (patch)
tree5f56571c60f0c4659fb3d7f2594f75bbbccb0fc0
parentsys-devel/binutils: fix typo in comment (diff)
downloadgentoo-f553b896d25848f8924ae58b456ede494f8503e3.tar.gz
gentoo-f553b896d25848f8924ae58b456ede494f8503e3.tar.bz2
gentoo-f553b896d25848f8924ae58b456ede494f8503e3.zip
dev-db/libodbc++: fix build w/ musl 1.2.3 (and possibly libcxx?)
Closes: https://bugs.gentoo.org/855887 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-db/libodbc++/files/libodbc++-0.2.3-musl-1.2.3-null.patch16
-rw-r--r--dev-db/libodbc++/libodbc++-0.2.5-r3.ebuild3
2 files changed, 18 insertions, 1 deletions
diff --git a/dev-db/libodbc++/files/libodbc++-0.2.3-musl-1.2.3-null.patch b/dev-db/libodbc++/files/libodbc++-0.2.3-musl-1.2.3-null.patch
new file mode 100644
index 000000000000..f7d5a2e3436f
--- /dev/null
+++ b/dev-db/libodbc++/files/libodbc++-0.2.3-musl-1.2.3-null.patch
@@ -0,0 +1,16 @@
+https://cgit.freebsd.org/ports/tree/databases/libodbc++/files/patch-src-datetime.cpp
+https://bugs.gentoo.org/855887
+
+(Given the source, possibly fixes libcxx too?)
+--- a/src/datetime.cpp
++++ b/src/datetime.cpp
+@@ -272,7 +272,7 @@
+ # endif
+ #endif
+ ,ODBCXX_STRING_CONST("%09d"),nanos_);
+- buf[9] = NULL;// Terminate string
++ buf[9] = '\0';// Terminate string
+ ret+=ODBCXX_STRING(buf);
+ }
+ return ret;
+
diff --git a/dev-db/libodbc++/libodbc++-0.2.5-r3.ebuild b/dev-db/libodbc++/libodbc++-0.2.5-r3.ebuild
index 3241509b98af..b3ebd27f321a 100644
--- a/dev-db/libodbc++/libodbc++-0.2.5-r3.ebuild
+++ b/dev-db/libodbc++/libodbc++-0.2.5-r3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -27,6 +27,7 @@ PATCHES=(
"${FILESDIR}"/${PN}-0.2.3-doxygen.patch
"${FILESDIR}"/${PN}-0.2.3-gcc41.patch
"${FILESDIR}"/${PN}-0.2.3-gcc44.patch
+ "${FILESDIR}"/${PN}-0.2.3-musl-1.2.3-null.patch
)
src_prepare() {