summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-01-24 23:16:13 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2023-02-01 10:52:46 +0100
commitf55458507d313fcc9056eb7c1b021324337439e8 (patch)
treea09effed1241f22b10ed2781fceb315cbd044f4f
parentdev-util/rocm-cmake: drop 5.0.2-r1 (diff)
downloadgentoo-f55458507d313fcc9056eb7c1b021324337439e8.tar.gz
gentoo-f55458507d313fcc9056eb7c1b021324337439e8.tar.bz2
gentoo-f55458507d313fcc9056eb7c1b021324337439e8.zip
dev-util/rocminfo: drop 5.0.2
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--dev-util/rocminfo/Manifest1
-rw-r--r--dev-util/rocminfo/files/rocminfo-4.3.0-detect-builtin-amdgpu.patch25
-rw-r--r--dev-util/rocminfo/rocminfo-5.0.2.ebuild30
3 files changed, 0 insertions, 56 deletions
diff --git a/dev-util/rocminfo/Manifest b/dev-util/rocminfo/Manifest
index fd18d19d9f8d..78cf76123025 100644
--- a/dev-util/rocminfo/Manifest
+++ b/dev-util/rocminfo/Manifest
@@ -1,3 +1,2 @@
-DIST rocminfo-5.0.2.tar.gz 15767 BLAKE2B 4617e4df51cc0b02d1743e655491600510e4f9fc22ef47612aa69bc311e7dc3979b0063c650d9a4fee0124be404b92c110dc9db056a554ee25ba3d4bfd12f618 SHA512 dd02837e621a414b54ef50b52ca816509ffa8b613e7de5f8b09449c5fc543dee054860a2245462008f687683af48203b6d2080fe71bf6e3654981d6bfd56e254
DIST rocminfo-5.1.3.tar.gz 16772 BLAKE2B 1b35661f9e6cd8cd5180ef3e4fd3dd8e7d6b282947d25c81b0b8bd347a5bee11cf87d950bbd8adcbd7a8a3053c41622b8e99fc0b56f4a14bdf4acf20992becc7 SHA512 998d499b0ae9a22bde30b2c26e31587a78b5ed63a19649d5b203eb47a044f17d1d4d3e951ec094d5be1ca3ba37efa4b19f5b53047727158170fa90c13a8c7563
DIST rocminfo-5.3.3.tar.gz 16829 BLAKE2B 341908048b9726a22ab5e81317916166d4ba114c5060fd8b7b455e0f4df3857b16a735cfccce2d013cd6632680e29b2e0c9ef91461d46b7e94dc71b0751aa42e SHA512 336a408eb49eb8d40b506f58d62de3fd406d00b0de169bc3f6176c76f1f50366347d212de8783b5c48ae1b6660d307b276ba6b3bac8d8286f5e93cfe739c4dae
diff --git a/dev-util/rocminfo/files/rocminfo-4.3.0-detect-builtin-amdgpu.patch b/dev-util/rocminfo/files/rocminfo-4.3.0-detect-builtin-amdgpu.patch
deleted file mode 100644
index a01eb3ec3909..000000000000
--- a/dev-util/rocminfo/files/rocminfo-4.3.0-detect-builtin-amdgpu.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-/sys/module/amdgpu instead of lsmod for builtin amdgpu kernel module
-
-https://github.com/RadeonOpenCompute/rocminfo/pull/43
-https://github.com/RadeonOpenCompute/rocminfo/issues/42
---- a/rocminfo.cc
-+++ b/rocminfo.cc
-@@ -1035,14 +1035,15 @@ AcquireAndDisplayAgentInfo(hsa_agent_t agent, void* data) {
-
- int CheckInitialState(void) {
- // Check kernel module for ROCk is loaded
-- FILE *fd = popen("lsmod | grep amdgpu", "r");
-- char buf[16];
-- if (fread (buf, 1, sizeof (buf), fd) <= 0) {
-+ int module_dir;
-+ module_dir = open("/sys/module/amdgpu", O_DIRECTORY);
-+ if (module_dir < 0) {
- printf("%sROCk module is NOT loaded, possibly no GPU devices%s\n",
- COL_RED, COL_RESET);
- return -1;
- } else {
- printf("%sROCk module is loaded%s\n", COL_WHT, COL_RESET);
-+ close(module_dir);
- }
-
- // Check if user belongs to the group for /dev/kfd (e.g. "video" or
diff --git a/dev-util/rocminfo/rocminfo-5.0.2.ebuild b/dev-util/rocminfo/rocminfo-5.0.2.ebuild
deleted file mode 100644
index 1cbe2856e43a..000000000000
--- a/dev-util/rocminfo/rocminfo-5.0.2.ebuild
+++ /dev/null
@@ -1,30 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake
-
-if [[ ${PV} == *9999 ]] ; then
- EGIT_REPO_URI="https://github.com/RadeonOpenCompute/rocminfo/"
- inherit git-r3
-else
- SRC_URI="https://github.com/RadeonOpenCompute/rocminfo/archive/rocm-${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64"
- S="${WORKDIR}/rocminfo-rocm-${PV}"
-fi
-
-DESCRIPTION="ROCm Application for Reporting System Info"
-HOMEPAGE="https://github.com/RadeonOpenCompute/rocminfo"
-LICENSE="UoI-NCSA"
-SLOT="0/$(ver_cut 1-2)"
-
-RDEPEND=">=dev-libs/rocr-runtime-${PV}"
-DEPEND="${RDEPEND}"
-
-PATCHES=("${FILESDIR}/${PN}-4.3.0-detect-builtin-amdgpu.patch")
-
-src_prepare() {
- sed -e "/CPACK_RESOURCE_FILE_LICENSE/d" -i CMakeLists.txt || die
- cmake_src_prepare
-}